2 Replies Latest reply: Feb 8, 2012 9:03 AM by ssolvason RSS

Session Lost for a Document with Server Bookmark

amars

Hi all,

We are using Qlikview Server 10 with Enterprise Edition , we use Ajax as our preffered client. Few days back we were using QVS 9 SBE. Now our user's are creating Server Bookmarks. Now for one of my Qlikview Document's the Ajax URL shows Session Lost message. I checked in my config.xml & increased <QvsTimeout> from 60 sec to 120. as well On the server I have (EMC->System->Setup->QVS->Performance):

 

Possible session timeout: 1800 sec
Maximum Inactive Session Time: 1800 sec
Maximum total session time: 0 (means no limit)
Object Calculation Time limit: 240 sec.

But still the Session Lost message occurs. Now I checked in my application path & found that when I delete DocumentName.QVW.Shared file it starts working but after accessing the dashboard again, these files get's created as we have server bookmark for the document & these shared files contain that. Again after these Shared files get's created this Session Lost message keeps coming. I couldn't understand why? Please suggest. Thanks in advance.

Amar.



  • Re: Session Lost for a Document with Server Bookmark
    gwynwjones

    amars - this worked for me, good stuff, session lost message was driving me mad.  Thought it was due to the size of the file but was because a user has been removed who created a bookmark.  Deleting the shared file fixed the issue

  • Re: Session Lost for a Document with Server Bookmark
    ssolvason

    ageorge wrote:

     

    We are also troubleshooting this issue.

    We looked at the server logs during these disconnects and found the following line.

    Windows System Info: Failed to translate name DOMAIN\USERNAME - "The parameter is incorrect.

    Where "DOMAIN" and "USERNAME" are our domain and the username of the person that created the bookmark.

    In our case, the USERNAME is no longer an employee of the company.

    Hexediting the .shared file shows that username in several places, we are going to replace that username with another one (with the same number of characters) and see if that resolves our issue.

     

    We found this same issue in QV 10 SR4. It is in fact caused by there being bookmarks in the .SHARED file referencing users that have been deleted from the active directory. There is no issue with deactivated users.

     

    This issue causes the following problems:

    1. In the Ajax client, the document crashes and a message saying "Session lost" appears. This renders the entire QlikView document unusable.
    2. When using the IE plugin, the application works until one tries to add or edit bookmarks. The document crashes and this message appears: "Server communication lost, closing document!"
    3. When using the Enterprise Management Console, and trying to view the document in the User Documents section, the following message appears: "An existing connection was forcibly closed by the remote host". Thereafter, no settings can be made for the document, and a crash of the entire management console occurs if an attempt is made.

     

    The are two fixes to this issue, none of which are optimal solutions:

    1. Delete the .SHARED file and lose all your bookmarks
    2. Edit the .SHARED file and delete any references to users no longer in the Active Directory.

     

    As solution #1 is not a viable solution for us as our users have many bookmarks, we opted for solution #2.

     

    To edit the .SHARED file we used the Shared File Viewer provided in the QlikView Power Tools package. With this tool, we found deleted users, unchecked them, and pressed Defrag to save the file without those users. The document worked again.

     

    This is an issue that needs to be addressed by QlikTech as the required maintenance of removing users is tedious, and a missing user should not be a cause for a crash of the entire document.

     

    I hope this helped anyone else experiencing this problem