6 Replies Latest reply: Apr 7, 2012 3:49 PM by Shubhasheesh Chakraverty RSS

Alerts

anthonyb

I'm having trouble with alerts. I'll start by saying I've searched community.qlik.com "alerts" on google, and have probably read every topic on this forum but still cannot figure out alerts, maybe somebody can appoint me.

 

I'm running QV 10 w/ Publisher, I understand QEMC needs to be set up but I cannot even get the document to show a pop-up.

 

My 'Condition' is: sum(ProgressItems.ManHoursVarianceToDatePercent) <= -10

My 'Message' is: =count(ProgressItems.ManHoursVarianceToDatePercent <= -10) & '' & 'cost item(s) have been found with negative variance. Please check where this work stands.'

 

My 'Mail Subject' is: ='Qlikview has identified' =count(ProgressItems.ManHoursVarianceToDatePercent <= -10) & '' & 'negative cost item(s)'

 

Everything else is visible.

 

What am I doing wrong? Am I not understanding part of this process?

 

Thanks in the advance.

 

Untitled.png

 

Message was edited by: anthonyb

  • Alerts
    Rob Wunderlich

    Will the Alert fire when you reload in Developer? (You'll need to check the Mode Interactive on).

     

    -Rob

    http://robwunderlich.com

    • Re: Alerts
      anthonyb

      Hi Rob, thank you for replying.

       

      Yes, the alert fired off when I reloaded developer with interactive on. Some of my formatting was a little off.

       

      I received a pop-up showing the mail tab in user settings, which I then x'ed out of, and another pop-up then opened asking if I wanted to email 'anthony.babich@harddollar.com', I chose yes and haven't received anything. I did see my text alert within the software though, which is a plus, I haven't got that to work until now.

       

      What steps do you suggest I take to get this working smoothly?

       

      What are the mail options within QEMC used for opposed to the mail options within the developer software?

       

      Thank you,

      Arb

      • Alerts
        Rob Wunderlich

        For developer, the mail setup is in Settings, User Preferences, Mail.

         

        For QEMC, the mail setup is in System, Setup, Mail Server.

         

        -Rob

        http://robwunderlich.com

        • Re: Alerts
          anthonyb

          Totally understood that side of it (where the settings are). Do either conflict with each other? Do I have to set up both the developer mail setup and QEMC mail setup for it to work?

          • Alerts
            Rob Wunderlich

            The developer settings are used when the qvw is reloaded or opened (from the filesystem) in Developer.

             

            The QEMC settings are used when the qvw is reloaded or opened on the server.

             

            So no, they don't conflict or merge with one another. They are assigned to the environment - Desktop or Server -- not the document.

             

            -Rob

            http://robwunderlich

  • Alerts
    Shubhasheesh Chakraverty

    Hi,

     

    What I understand. Alert is getting fired but mail is not reaching to recepient.

     

    When u are setting mail credentials in User Preferences in qvw. There is Authentication Method drop down has certain options. Mind it SSL and TLLS is not supported here.

     

    In this context Gmail will not work but your company domain email account may work if they don't require SSL / TLS things.

    Do a little check with some email address without them.

     

    Regards,

    Shubhasheesh