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How to Use This Guide   

Qlik Sense can be deployed in a multitude of environments.  While this guide tries to keep all 

deployments the same, some variation may be required because of the deployment environment.  

These variations are identified throughout the document with the graphics below:  

  

Location Domain 

Instance installed on 

Amazon EC2 or 

Microsoft Azure 

Instance installed on 

a Virtual Machine or 

Physical Server 

Windows is on  

domain controller  

(Active Directory) 

Windows is on  

local domain 

(No Active Directory) 

 

  

  

 

  

 

  

 

  

 

*** 

Do not start the installation of Qlik Sense until you have answered the  

questions and satisfied the prerequisites outlined in the next section.  

*** 
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Before You Begin  

Please review and attend to the following prerequisites before starting the Qlik Sense 

installation.  

 

Qlik Sense Installation Prerequisites  

1. Determine where Qlik Sense Enterprise is to be installed.  Supported environments include, a 

virtual machine on premise, a physical server, or a cloud provider (such as Amazon, Azure or 

Rackspace).  

2. Determine whether the Windows Server will be connected to a domain controller.  

3. Validate that the target server meets the following requirements:  

o Windows 2012, Windows 2012 R2, or Windows 2016 – 64 bit.  (Note Windows 7, 8.1 

and 10 can be used is some situations but is not recommended).  

o At least 4 cores and 16 GB of RAM is recommended, but this will depend on data 

volumes and the number of users accessing the server. 

o A clean Windows Server OS installation is desirable. 

o Microsoft .NET 4.5.2 installed and updates applied (the default is 4.5 for Windows 

2012).  The Qlik Sense installation software will automatically install or update .NET if 

required. 

o IPv4 or IPv6 (dual stack)  

o Internet access from server is needed for license registration.  If Internet access is 

not available, you will need to obtain an LEF file from a Qlik representative to license 

the server. 

4. Obtain administrative rights and Remote Desktop access to the target server. 

5. Obtain a service account with local administrative rights on the server.  Ideally the service 

account will be a domain account if the server is attached to a domain controller, but a local 

account will also work.  

6. Install database drivers on the server for any databases that Qlik Sense needs to access.  

7. Identify data sources and credentials for any database that Qlik Sense needs to access. 

8. Client browser requirement:  

o Windows 7: IE 11, Chrome, Firefox  

o Windows 8.1: IE 11, Chrome, Firefox  

o Windows 10: Edge, IE 11, Chrome, Firefox  

o OS X 10.11 and 10.12: Safari, Chrome, Firefox  

o iOS 3rd generation and above or iPhone 5 and above: Safari 8 or higher  

o Android 4.3, 4.4.4, 5.1.1, and 6.0: Chrome  

o Windows Phone 8.1: IE 11  

o NOTE: Customers wishing to access Qlik Sense from an iOS device need to be 

aware that as of iOS version 8, untrusted certificates are not allowed.  This means 

that the self-signed certificates that Qlik Sense uses out of the box are not sufficient 

to enable Hub access on iOS devices.  See   
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o Apple iOS Mobile Safari Browser Access on page 18 for more details. 

9. Download or copy the Qlik Sense Enterprise install program and any patches to the server. 

10. Obtain the Qlik Sense Enterprise site license (serial number and control number).  If the 

server on which you will be installing Qlik Sense does not have Internet access, you will need 

to obtain an LEF file from a Qlik representative. 

 

 

 

Server Prerequisites 

  

If you are installing into Amazon EC2 follow the steps in the Appendix: Amazon EC2 

– Launch an Instance.  At this point, make sure you can RDP to the server and that 

ports 80, 443, 4244, and 4248 are open in the EC2 console.  

If you are installing into Microsoft Azure follow the steps in the Appendix: Microsoft 

Azure – Launch an Instance.  At this point, make sure you can RDP to the server 

and that ports 80, 443, 4244, and 4248 are open in the Azure console.  

  

If you are installing onto physical hardware or a virtual machine on premise, make 

sure you can RDP to the server at this point.  

  

 

Windows Prerequisites 

 

If you plan to rename the machine or workgroup, do so before installing Qlik 

Sense.  

  

Disable Windows Firewall completely (if this is not acceptable, open inbound ports 

80, 443, 4244, 4248).  For help with this, see Appendix: Windows Firewall.  

  

Disable Windows Internet Explorer Enhanced Security Configuration (IE ESC). For 

help with this, see Appendix: IE Enhanced Security Configuration. 

  

Download and install Chrome on the server (optional). The Chrome browser is 

faster than IE. 

  

  

If another installation of Qlik Sense already exists on this machine, follow the cleanup 

steps outlined in Appendix: Qlik Sense Uninstall.  

 

If other software is installed on this machine, check for known conflicts – IIS, Skype, 

VMWare Workstation, Tableau, and SQL Server all are known to use port 443.  These 

should be disabled and/or configured to not use port 443.  For additional information, 

see Appendix: Known Conflicts.  
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User Accounts 

Service Account Setup  

If you do not already have a service account to run Qlik Sense, follow the procedures below to create 

one; otherwise, you can move on to the User Account Setup section.  

 

• On the Qlik Sense server, 

Click Start and search for 

Computer Management.  

 

 

 

• Find the Users folder, then 

click Action > New User…  

• Enter user name QVAdmin 

and password QlikSense! 

• Uncheck User must change 

password at next logon 

• Check User cannot change 

password and Password 

never expires 

• Click Create 

 

 

• Double click on QVAdmin 

o Click Member Of   

o Click Add...   

o Type Administrators   

o Click Check Names  

o Click OK   

o Click Users  

o Click Remove   

o Click OK  

 

This account will be 

used during the 

installation of Qlik 

Sense. 
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User Account Setup  

  
If the server is connected to a domain controller (Active Directory), skip this 

section and move on to the Installation section.  

  
  

If the server is NOT connected to a domain controller, follow the procedures 

below to create some local users that can be used to login into Qlik Sense.  

  

 

• On the Qlik Sense server, 

Click Start and search for 

Computer Management. 

 

 

• Find the Users folder, then 

click Action > New User…  

• Add user QlikUser1 

o Password 

QlikSense!   

o Uncheck User 

must chance 

password at next 

logon  

o Check User 

cannot change 

password 

o Check Password 

never expires 

• Click Create 

• Repeat steps above for 

QlikUser2 and QlikUser3 

 

 

  

 

These will be the user accounts and passwords you hand out so people can login and 

evaluate Qlik Sense.  You can add more or fewer user accounts based on your needs.  

You can also use different user names and passwords if desired. 
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Windows File Share Setup 

 

• Navigate to “D:\” and create a folder  

titled “QlikShare” (If there is no D:\ available 

then use C:\ or preferred attached drive).  

 

 

 

• Right click on the folder and click “Properties”. 

• Click “Sharing” tab. 

• Select the “Share” button.  

• Select the Qlik service account (or Add it)  

• Click “Share”.  

 

 

 

 

 

 

 

 

 

 

 

• You should see the new UNC 

path created in the confirmation 

screen: 
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• Verify that the Network Path is visible under the 

Sharing tab. This is what will be used later on in 

the installation for your Root folder location.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Ensure permission levels are set to full control 

for the Qlik service account by doing the 

following: 

o Under the folder properties>security, 

select Advanced 
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• Select the service account user 

for the “Select a user” link by 

entering the service account 

name in at the prompt.  

• Select “View effective access” 

 

 

 

 

 

 

 

 

 

• Verify the service account 

has Full control effective 

permissions and select “OK” 

to close out of the window. 
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Installation  

It is now time to install the Qlik Sense services.  To begin, remote desktop into the Qlik Sense server 

and login with the service account you created or that was provided to you.  This account must have 

local administrative rights and full access to the file share created previously in Step 11.  

 

Download Qlik Sense  

If you don’t have the Qlik Sense server installation media, following the procedures below: 

1. Open a browser and navigate to www.qlik.com  

2. Choose Login  

3. Navigate to Services > Support > Customer Downloads  and locate 

Qlik_Sense_setup.exe  

  

Run the Qlik Sense Installer 

 • Right click on 

Qlik_Sense_setup.exe, and 

choose Run as administrator 

 

• Select Install  

 

 

• Accept the license agreement  

 

 

 

• Choose Create Cluster 

 

  

• Check “Install local 

database”  

• Enter the Database user 

password.  For a PoC, it is 

recommended that you use 

the same password as the 

service account “QlikSense!”.  

If you use a different 

password, write it down so you 

don’t forget it. 

 

• Click Next. 

 

 

   

http://www.qlik.com/
http://www.qlik.com/
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• Click Next for single node 

installations.  Multi-node is not 

within the scope of this guide. 

 

 

 

 

 

 

 

 

 

 

 

• Enter the file share path in the 

“Root folder” input box. 

Example:  

\\Windows2012\QlikShare.  

This is the share you created 

in section “Qlik Sense 

Installation Prerequisites”, 

Step #11. 

 

Click Next. 

 

• Choose the default installation 

location and click Next. If you 

wish to install to a different 

location, such as D:\\Program 

Files\Qlik\Sense you can do 

so here.  

 

• Uncheck “Configure 

centralized logging”. 

 

• Click Next. 

 

 

 

 

 

 

 

 

 

 

• Enter the same Repository 

Database Superuser 

Password entered previously 

for the “Database user 

Password” and click Next. 

 

 

file://///Windows2012/QlikShare
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• Enter the service account 

username and password 

 
If you are using a domain 

account, the format will be 

DOMAIN\USER 

 
If you are using a local account, 

the format will be 

MACHINENAME\USER 

 

Whichever you choose, the 

account should belong to the 

Administrators group on the 

server. 

 
The service account is often 

used when Qlik Sense needs to 

access the file system, 

databases and user directory 

connectors.  For this reason, a 

domain account is 

recommended. 

 
* Do not use fully qualified machine name unless you understand the 

implications of doing so. 

 
This is a critical step!  If it is 

not completed correctly, you 

will not be able to access the 

server. 

 

Use the environment specific 

guidelines below to enter the address 

of you Qlik Sense server machine. 

 
Amazon instances should 

use the machine name 

without the domain 

name 

 
Azure instances should 

use the machine name 

with the domain name 

 
On premise physical or 

virtual machines should 

use the machine name 

without the domain 

name 

 

Examples 
IP Address: 10.1.123.234 

Machine Name: WIN-Q3NOL8VH88G 

Fully Qualified Machine Name: WIN-

Q3NOL8VH88G.CUSTOMER.COM 

 

 

• Click Install 

• When complete, click Finish. 

 

Note: If a patch is available for this version, download the latest patch version and install it after 

successfully completing the initial installation. The patch install should be a Next > Next > Next > 

Finish with no additional configuration needed. 
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Configuration  

Launch Qlik Management Console Setup 

It is now time to configure the Qlik Sense installation using the Qlik Management Console (QMC).  

Launch QMC using the icon on your server’s desktop or via a browser using the server address 

provided during the installation.  For example, https://ipaddress/qmc or https://machinename/qmc.   

 

 

If the QMC doesn’t start the 

first time, give it 30 seconds.  

The Qlik Sense services are 

configured for delayed start.  

  

 

You may get a security 

warning.  If so, click through it.  

  

If you are prompted to login 

to the QMC, login with the 

same user and password you 

used to Remote Desktop to 

the server.  

 

 

Apply License 

 

You will be prompted to enter the 

site license information.  

Complete the form and click Get 

LEF and preview the license 

from server. 
If the server does 

not have access to 

the Internet, you will 

need to obtain an 

LEF file from a Qlik 

representative 

 

 

When the site license has been 

successfully applied, you will see 

a confirmation message. 

 

https://ipaddress/qmc
https://machinename/qmc
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Token Allocation 

Tokens must be allocated to 

users in order for them to access 

Qlik Sense. 

• Navigate to Start > 

License and Tokens > 

User Access 

Allocations 

• Click the Allocate button 

• Select the User ID you 

are logged in with and 

click Allocate 
 

This is so the 

administrator always 

has a license 

 

 

In addition to manual allocation 

of tokens, Users can be granted 

a token via a rule. 

• Navigate to Start > 

License and Tokens > 

User Access Rules 

• Click Create New 

• Click Basic 

• Populate the BASIC rule 

with user name like 

value * 

• Click Apply 

 
This rule grants a 

token to any user 

connecting to Qlik 

Sense.  This is useful 

for a PoC but rarely 

used in production. 
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Proxy Setup 

This section describes steps to 

allow HTTP access and support 

access using alternate URL 

formats.  

• Navigate to Start > 

Proxies > Central > 

Edit 

• Click Ports 

• Check Allow HTTP 

• Click Apply 

 
This allows users to 

access Qlik Sense 

using HTTP instead 

of HTTPS and will 

avoid browser 

security warnings 

 

 

• Navigate to Start > 

Virtual Proxies > 

Central Proxy (Default) 

> Edit 

• Click Advanced 

• Scroll down to Host 

white list 

• Click Add new value 

• Add IP Address and 

Machine name of your 

server 

• Click Apply 

 
Adding these values 

to the Host white list 

allows Qlik Sense to 

accept URLS of these 

formats 

 

AWS Instances: Add the external IP 

address, Public DNS, and public Domain 

found in EC2 > Instances > machine > Public 

IP / Public DNS fields  

• Public IP Example: 54.196.234.38  

• Public DNS Example: ec2-54-196-234-

38.compute-1.amazonaws.com  

• Public Domain: compute-

1.amazonaws.com  

 

Azure Instances: Add the hostname and the 

Public DNS  

• Hostname Example: WIN-Q3N0L8VHHHG  

• Public DNS Example: WIN-

Q3N0L8VHHHG.cloudapp.net  

 

Servers on a domain: Add the fully qualified 

domain name and domain name  

• Fully Qualified Domain Example: WIN-

Q3N0L8VHHHG.CUSTOMER.COM  

• Domain Example: CUSTOMER.COM  

 

If the customer has created any DNS entries 

(e.g., qlikbi.company.com), add this to the 

whitelist, too.  Customers having done this 

may ask to import their own SSL certificate.  

See Appendix: Client Provided Browser 

Certificate.  
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Validation 

At this point, you should be able to login to the QMC and HUB directly on the server.  Use the 

shortcuts created on the desktop to validate that the QMC and HUB open successfully.  Qlik Sense is 

setup correctly if the browser gives no security warnings.  

 

Now open Qlik Sense QMC and Hub from a desktop or laptop. The URL used to access Qlik Sense 

QMC and Hub will be as follows: 

• http://<ipaddress>/QMC or http://<machinename>/QMC or http://<publicdns>/QMC 

• http://<ipaddress>/Hub or http://<machinename>/Hub or http://<publicdns>/Hub 

 

EC2 installations – use the Public DNS  

Example: http://ec2-54-196-234-38.compute-1.amazonaws.com/hub  

Note: Getting rid of the HTTPS security warnings in EC2 requires additional configuration (DNS 

and customer SSL certificates) and is beyond the scope of this PoC installation guide.  Use 

HTTP in your URLs instead of HTTPS or click through the security warning when launching 

Qlik Sense.  

  

Azure installations – use the Public DNS  

Example: http://WIN-Q3N0L8VHHHG.cloudapp.net  

Note: Getting rid of the HTTPS security warnings in Azure requires additional configuration 

(DNS and customer SSL certificates) and is beyond the scope of this PoC installation guide.  

Use HTTP in your URLs instead of HTTPS or click through the security warning when 

launching Qlik Sense.  

 

On premise installations – use machine name  

Example: https://WIN-Q3N0L8VHHHG/hub  

Note: If you can access the hub via machine name, you will not get security warnings.    

If this is not possible, use HTTP in your URLs instead of HTTPS or click through the 

security warning when you launch Qlik Sense.  

  
Import an Application  

1. Open the Qlik Sense Management Console  

2. Click Start > Apps > Import 

3. Click Browse 

4. Navigate to the Qlik Sense application you would like to import into the server.  The default 

location for Qlik Sense Desktop applications is C:\Users\<user>\Documents\Qlik\Sense\Apps. 

5. Click Import 

6. Once the import is complete, highlight the application and click Publish, select a Stream and 
click OK.   

  

http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://ec2-54-196-234-38.compute-1.amazonaws.com/hub
http://win-q3n0l8vhhhg.cloudapp.net/
http://win-q3n0l8vhhhg.cloudapp.net/
http://win-q3n0l8vhhhg.cloudapp.net/
http://win-q3n0l8vhhhg.cloudapp.net/
https://win-q3n0l8vhhhg/hub
https://win-q3n0l8vhhhg/hub
https://win-q3n0l8vhhhg/hub
https://win-q3n0l8vhhhg/hub
https://win-q3n0l8vhhhg/hub
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Apple iOS Mobile Safari Browser Access  

Customers wishing access the Qlik Sense server from an iOS device should recognize that as of iOS 

version 8, untrusted certificates are not allowed.  This means that the self-signed certificates that Qlik 

Sense uses out of the box are not sufficient to enable Hub access on iOS devices.  

 

Option #1 – Use HTTP   

This is the simplest option for Proof of Concepts.  See the section titled Proxy Setup to learn how to 

enable HTTP.  Direct users on iOS mobile devices to navigate to the server via HTTP and not 

HTTPS.  

Option #2 – Use a trusted certificate  

Install a customer provided certificate with private key from a trusted root certificate authority (e.g. 

Symantec, GoDaddy, Thawte, DigiCert, or many others) and add this certificate’s security thumbprint 

to the thumbprint text box in the Proxy configuration.  See the section titled Client Provided Browser 

Certificate to learn how to enable this.  

  

On premise installations – Customer provide a certificate that can be used with the 

server. 

Example:  *.company.com  

Example:  qliksense.company.com  

  

 

 

AWS and Azure – Installing a trusted certificate in EC2 or Azure requires additional 
configuration and is beyond the scope of this PoC installation guide.  Unless the 
customer is able to register a domain, purchase a certificate, and associate with the 
Qlik Sense instance in EC2 or Azure, use HTTP in your URLs instead of HTTPS or 
click through the security warning when launching Qlik Sense.  
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APPENDIX I - iOS Mobile App Setup and Configuration 

The iOS Mobile App will not be available in the Apple App Store until after the Sept 2017 

release. If there is a requirement to download the app in advance of the official release, 

please request access through this link. An iOS app called ‘TestFlight’ will also need to 

be downloaded from the App Store in order to work in conjunction with the Beta version.  

Please allow a 48-72 hour turnaround time to receive the email invitation.   

 

Desktop Authentication Link Setup 

For the iOS Client to know where to connect, we generate a desktop authentication link via: 

• Start > Virtual Proxies > “Central Proxy (Default)” > Desktop Authentication Link 

o Host URL is the same as how you access Qlik Sense in the browser, without /hub 

o Friendly Name is the name that shows up on the iOS device 

o Click Generate, Click Apply, and you get a URL like this:  

qliksense://enterpriseurl?action=add&url=http%3A%2F%2F34.211.33.62&name=QLIKAWS&

version=0.1&signature=008a750e10a8a8fe4194a1f9257e64baa35e9d2fc1094e50f534c335b

e131d5d 

Security Rule Setup 

For an app to be downloadable, the basic requirement is that a user must have ‘Export’ permissions 
on App_* via the security rules and be able to read the app. 

Create a Custom Property called “MobileOffline” and apply it to an application.   

Note that this custom property isn’t strictly required.  It just makes the security rule easier 
to manage. 

 

• In the QMC, go to Start > Custom Properties > Create New > Name = ‘Mobile Offline’, Resource 
Types = ‘Apps’, Custom Property Values = ‘True’ 

https://www.surveymonkey.com/r/DW7W766
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• In the QMC, go to Start > Apps > <select an app> > Custom Properties, Set MobileOffline = True 

 

Create a Security Rule called “_Mobile Offline” 

• Start > Security Rules > Create New > Create Rule from Template = “App Access” 

• Name = ‘_Mobile Offline’ 

• Resource Filter = ‘App_*; 

• Actions = Access OfflineConditions = resource.HasPrivilege ("read") and 

resource.@MobileOffline="True” 

• Context = Only in Hub 

mailto:resource.@MobileOffline=%22True
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Connect to the Qlik Sense Enterprise Server 

• Using Mobile Safari on the iPad, connect to the Qlik Sense Enterprise Server Hub. 

• Touch the ellipses on the top right, and select the Desktop Authentication link.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• When prompted, select “Open in Qlik Sense”. The iOS native app should automatically open 

with the friendly name of the Desktop Authentication Link you previously entered in the QMC. 

 

• Tap ‘Open’ 
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• Select the Qlik Sense Enterprise friendly name on the landing page.  

• You will be directed to a forms login page. Here enter the username and password of the user 

account you wish to use. This example uses the user account created earlier in this document.  

• Username: .\QlikUser1 

• Password: QlikSense! 

 

• The Hub should now open and show available applications. Note the “download” icon on the top 

right of any application specified to be Offline=True via the custom property previously created in 

the QMC. Touch the ellipses in the bottom right of the application you want to use offline. 
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• A sidebar will pop in. Select the “Download” icon to download the app. 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Once the app has completed downloading, you will now see Online/Offline tabs and the ability to 

open an app offline. Select the “Open Offline” button to begin using the offline capability in the 

iOS app.  
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APPENDIX II - Amazon EC2 – Launch an Instance  

  

If you are able to provide the EC2 instance for the customer, the best way to get started 

quickly is to request an EC2 instance through ServiceNow. From there you can choose 

predefined AMIs for a quick start. Detailed instructions on how to do so can be found 

here: link. 

  

Security Groups  

Create a security group called Qlik Sense with the rules in the screenshot below.  This is found in EC2 

> Security Groups in the left navigation of the EC2 control panel.  Then click Create Security 

Group.  

 

 

Name     Qlik Sense  

Inbound Rules   HTTP, HTTPS, RDP, Custom TCP Rule (4244), Custom TCP Rule (4248)   

Key Pair  

Create a key pair called Qlik Sense via EC2 > Key Pairs > Click Create Key Pair.  Save this file 

(Qlik Sense.pem) somewhere and don’t lose it!  

  

 

  

  

https://confluence.qliktech.com/display/plus/How+to+request+an+Amazon+EC2+instance
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Launch the Instance  

• EC2 > Instances > Click Launch Instance  

• Choose Windows Server 2012 R2 Base instance, 64 bit  

 

• Choose an Instance Type 

o R3.2xlarge is a good choice with 8 cores / 60 GB RAM  

o R3.4xlarge is a good choice with 16 cores / 122 GB RAM  

o Other larger instances are available.  Some of the larger servers require an email to 

AWS support first.  

 

• Click Review and Launch  

o You will get a warning about security groups.  Change from the default security 

group to Qlik Sense 

• Launch  

o You will get a warning about key pairs.  Choose the Qlik Sense key pair you have 

created and saved.  

 

Elastic IP  

• Create an elastic IP via EC2 > Elastic IPs > Allocate New Address > Yes, Allocate  

• Select the new Elastic IP address, and click Associate Address  

• Choose the running instance and click Associate  

• You will associate this with your instance so that the server IP address doesn’t change if you 

stop and start the instance.  

RDP  

• Go back to the EC2 console and wait for the new instance to say “running” and “2/2 checks 

passed”.  
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• Click EC2 > Instances > Choose your instance > Connect  

o Click Download Remote Desktop File > Saves a RDP link you can use to connect 

o Click Get Password > Choose your QlikSense.pem file > Click Decrypt password  

o Save this somewhere for reference  

• At this point you should have a Remote Desktop session on the server.  If you can’t connect, 

review this section for proper setup of security groups and key pairs.   
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APPENDIX III - Microsoft Azure – Launch an Instance  

It is really easy to get an Azure account at http://portal.azure.com/ and click on Free Trial 

(or buy now).  You can sign up and try this on your own!  Just make sure to shut down 

any machines you launch so as not to incur an unnecessary charges.  

  

 

• Choose New > 

Compute > Windows 

Server 2012 R2 

Datacenter 

• Click Create 

• Enter a Username and 

Password for your 

instance (for Remote 

Desktop) 

• Enter a Resource 

group (can be 

anything, suggest 

project or customer 

name) 

• Choose a location 

• Click OK 

• Choose an instance 

size.  DS3 v2 or DS4 

v2 is recommended for 

basic workloads.  DS13 

v2 or DS14 v2 is 

recommended for large 

workloads.  Note the 

pricing of each before 

deciding. 

 

 

• Review the settings 

and click OK and OK 

again. 

• Now wait… this can 

take up to 30 minutes.  

You will see the picture 

on the right. 

 

 

• Once the VM is online, 

you will set a security 

group to allow traffic to 

the VM. 

• Resource Group 

(looks like a box) 

• Network Security 

Group (looks like a 

shield) 

• Inbound Security 

Rules 

• Click Add, then add 

inbound security rules 

 

 

 

 

 

 

 

 

 

 

http://portal.azure.com/
http://portal.azure.com/
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in the table to the right 

(leave unlisted settings 

as is) 

 

Name Protocol Destination Port 

HTTP TCP 80 

HTTPS TCP 443 

HTTP-Auth 

(type this) 

TCP 4248 

HTTPS-Auth 

(type this) 

TCP 4244 

 

• Finally, RDP to it by 

clicking on Connect 
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APPENDIX IV - Windows Firewall  

This section details how to disable or open specific ports that Qlik Sense needs open.  

  

On the Qlik Sense server, click Start and search for Advanced Firewall. Click on Windows Firewall 

with Advanced Security 

  

  

The simplest solution is to disable windows firewall completely, under Properties.  If this isn’t possible, 

continue with the following steps to open specific ports.    

  

1. Click on ‘Inbound Rules’ in the left panel, then click on ‘New Rule’ in the right panel.  
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2. Select ‘Port’ as the rule type.  

  

3. In the ‘Specific local ports’ field, enter 80, 443, 4244, 4248. This will allow you to access the Hub 

and QMC.  

  

4. Ensure that ‘Allow the connection’ is selected and click ‘Next’.  
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5. Ensure that all options are ticked and click ‘Next’.  

  

6. Give the rule a name such as ‘Qlik Sense’ and then click ‘Finish’. This will now allow traffic on 

those ports through the firewall to the operating system.  

 

7. Close Windows Firewall.  
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APPENDIX V - IE Enhanced Security Configuration  

This section details how to disable IE Enhanced Security Configuration on Windows Server 2008 and 
2012.  It is important to disable this in the case the customer will be accessing and using “Web File” 
data as a data source.  IE ESC blocks that traffic.  

Windows 2008  

• From the Start Menu, search for 

Server Manager and open it.  

 

• Click the root of the tree titled  

“Server Manager”  

 

• Click “Configure IE ESC”  

 



 

 
Page 33  

  

• Under Administrators, Click “Off”  

• Under Users, Click “Off”  

• Click OK  

 

 

Windows 2012 

• On the taskbar, click Server 

Manager 

 

• Click “Local Server”  

 

• Next to IE Enhanced Security 

Configuration, click “On”  
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• Next to Administrators, click “Off”  

• Next to Users, click “Off”  

• Click “OK”  
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APPENDIX VI - Client Provided Browser Certificate  

This section details how to import a client provided browser certificate into Qlik Sense.  

Generate Certificate Signing Request for Trusted Certificate  

If you don’t already have a certificate from a Trusted Certificate Authority, you may use these 

instructions to help generate the CSR. https://community.qlik.com/docs/DOC-15740  

  

Import Certificate to Windows Certificate Store  

• Click Start > type MMC > Right Click > Run as Administrator…  

 

• Click File > Add / Remove Snap In…  

• Click Certificates > Click Add > choose My User Account  

• Click Certificates > Add > choose Computer Account > choose Local Computer  

• Navigate to each folder listed below and import the customer provided certificate  

o Certificates - Current User > Trusted Root Certification Authorities > Certificates  

o Certificates (Local Computer) > Trusted Root Certification Authorities > Certificates  

o Certificates (Local Computer) > Personal > Certificates  

  

Validate Existence of Private Key  

• Double click on 

the imported 

certificate to view 

its properties. 

 

 

 

o       

  

  

  

  

  

  

  

  

  

https://community.qlik.com/docs/DOC-15740
https://community.qlik.com/docs/DOC-15740
https://community.qlik.com/docs/DOC-15740
https://community.qlik.com/docs/DOC-15740
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• Validate the 

private key exists 

with this 

certificate.  If not, 

ask the person 

who provided you 

the certificate. 

 

 

Import Certificate Thumbprint to Qlik Sense Proxy  

• Navigate to the Details tab 

and copy the Thumbprint 

value.  Make sure to copy all 

leading and trailing spaces. 
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• Open QMC > Proxies > 

Central Proxy > Edit 

• On the right hand side of the 

screen, click Security to 

enable additional properties. 

 

• Paste the browser 

thumbprint, including all 

spaces.  

 

• Click Apply to restart the 

Proxy. 

 

  

As a precaution, also enable HTTP traffic (see Proxy Setup section) if you haven’t 

already.  This will ensure that if this process has issues there is still a way to access the  

QMC.  
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APPENDIX VII - Qlik Sense Uninstall  

  

This section describes how to perform a clean uninstall of Qlik Sense.    

  

• Click Start > type 

Programs and Features 

and run Programs and 

Features 

 

• Find Qlik Sense in the 

list and click Uninstall 

 

• Check the two 

checkboxes to remove 

data and certificates. 

• Enter the password of 

the service account 

running the Qlik Sense 

services. 

• Note: This WILL delete 

everything.  Backup apps 

first if you need to. 
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APPENDIX VIII - Known Conflicts  

There are known port conflicts with IIS, Skype, VMWare Workstation, Tableau and SQL Server.  All of 

which may use port 443.  Check whether this software is installed and disable the port or software.  

 

https://technet.microsoft.com/en-us/library/jj635851(v=ws.11).aspx 

 

 

https://support.skype.com/en/faq/FA148/which-ports-need-to-be-open-to-use-

skypefor-windows-desktop  

 

 

https://www.computersnyou.com/266/how-to-solve-vmware-is-using-port-443/  

 

 

http://www.tableausoftware.com/manually-uninstalling 

 

 

 

http://sqlmag.com/sql-server/sql-server-tcp-and-udp-ports  

 

 

 

 

 

Get permission to disable the windows services or uninstall the offending software.  

 

  

 

 

  

https://technet.microsoft.com/en-us/library/jj635851(v=ws.11).aspx
https://support.skype.com/en/faq/FA148/which-ports-need-to-be-open-to-use-skype-for-windows-desktop
https://support.skype.com/en/faq/FA148/which-ports-need-to-be-open-to-use-skype-for-windows-desktop
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https://support.skype.com/en/faq/FA148/which-ports-need-to-be-open-to-use-skype-for-windows-desktop
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APPENDIX IX - Troubleshooting  

Log Files  

Log files are found in C:\ProgramData\Qlik\Sense\Log.  In Particular,  

Repository\System and \Trace, and Proxy\System and \Trace are valuable to review if you have 

issues.  

    

Connection Lost  

If you experience a “Connection Lost” or a blank error message when opening hub, make sure you 

are using a URL that matches the way you installed.    

o IP address  - https://10.1.123.234/hub o 

machine name – https://WIN-Q3N0L8VHHHG  

Review the section Proxy Setup.  

  

HTTP 500 Error  

If the QMC and Hub do not come up and the proxy shows a HTTP 500 error, it is likely certificate 

related.  Check the proxy logs under C:\ProgramData\Qlik\Sense\Log\Proxy\System.  A message 

about refusing connection to https://localhost:4242 is indicative of a certificate issue.  Shutdown the 

services and uninstall the certificates as described in the Uninstall section.  Then start the services.  If 

that doesn’t work, perform a complete uninstall and reinstall.  

  

Could not start services in a timely manner 

If the windows services fail to start, stating that the services did not start in a ‘timely manner’, it is 

possible to extend the timeout period: 

 

• Click Start, click Run, type regedit, and then click OK. 

• Locate and then click the following registry subkey: 

- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control 

• In the right pane, locate the ServicesPipeTimeout entry. 

 

• **Note**: If the ServicesPipeTimeout entry does not exist, you must create it. To do this, 

follow these steps: 

- On the Edit menu, point to New, and then click DWORD Value. 

- Type ServicesPipeTimeout, and then press ENTER.  

• Right-click ServicesPipeTimeout, and then click Modify. 

• Click Decimal, type 60000, and then click OK. 

- This value represents the time in milliseconds before a service times out. 

• Restart the computer. 

 

 

https://localhost:4242/
https://localhost:4242/

