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What is QlikView?

QlikView is a program that makes it possible to retrieve and assimilate data from dif-
ferent sources. Once loaded into the program, the data is presented in a way that is 
easy to understand and work with. 

To make selections in QlikView, you don’t need any previous knowledge of data-
bases or search routines: you simply click on the item of which you want to know 
more. The clicked item turns green, and the program immediately presents all the 
items associated with the selected one. 

Graphics and tables can be created to get an even better overview of data. Any 
graphic or table can be printed or exported to other programs. 

Flavors of QlikView
QlikView comes in three flavours called QlikView Enterprise, QlikView Profesisonal 
and QlikView Analyzer. If you are running QlikView Enterprise all parts of this tuto-
rial will be relevant for you. If you are running QlikView Professional only the first 
part “Working with QlikView” is relevant. For those running QlikView Analyzer 
only the very first lesson may be relevant.
introduction 11
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About the Tutorial

The Tutorial consists of three parts: Working with QlikView, Creating a QlikView 
document, and Advanced Features. All the parts contain lessons that take you step by 
step through various features.

To go through the steps in this Tutorial, you need the folder TutorialFiles, which has 
been installed together with the program. If you have not yet installed QlikView, 
please follow the installation instructions in the Reference Manual. If you have 
installed QlikView without the tutorial files, run the installation program once more, 
but this time only install the tutorial files.

Before you start working with the lessons, read the two following sections of this 
introduction, Conventions and Basic. Conventions informs you about the terms used 
in the Tutorial, whereas Basics familiarizes you with basic actions such as starting 
QlikView, opening, saving and closing an application, and using the help program. 

The first part, Working with QlikView, shows you how to work with an existing appli-
cation. This part introduces the components of a QlikView application and demon-
strates the use and creation of these components. In addition, Working with QlikView 
thoroughly describes how to search in QlikView. If you do not want to load your own 
data, this part is all you need to review.

The second part, Creating a QlikView application, presents the procedure of loading 
data into QlikView. You will learn how to load data from different sources, how Qlik-
View builds associations between different sets of data and how to link external 
information to the data. If you are going to build applications, this part is crucial for 
you.

Finally, Advanced Features can be seen as a continuation of both the previous parts. 
Here you will learn how to build more complicated graphs, as well as how to use 
more advanced features in the script. Access restriction, semantic links and number 
format are examples of topics to be discussed.

As mentioned before the last two parts are only relevant to users of QlikView Enter-
prise.
introduction 13
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Conventions

Before you start using QlikView, it is important to understand the terms and nota-
tional conventions used in the Tutorial. In this section some of the terms will be 
explained.

General conventions
• The word "choose" is used for carrying out a menu command or a command 

button in the tool bar or in a dialog.

• The word "select" is used for highlighting an object in a list or on a sheet that 
you want your next action to affect. It is also used for highlighting field val-
ues, thereby making logical selections within the data.

• Numbered lists (e.g. 1, 2, 3, ...) indicate procedures with two or more 
sequential steps.

• Bulleted lists, such as this one, provide information, and do not indicate pro-
cedural steps.

Mouse conventions
• You can either use a single-button or multi-button mouse with QlikView. We 

recommend the use of a multi-button mouse.

• If you have a multi-button mouse, QlikView assumes that you have config-
ured the left mouse button as the primary mouse button and the right mouse 
button as the secondary mouse button. (This is default in Windows.)

• "Point at..." means move the mouse and thus the cursor until the tip of the 
cursor points at the referred object.

• "Click..." means point at the referred object, then press and immediately 
release the mouse button without moving the mouse.

• "Double-click..." means click the mouse button twice in rapid succession.

• "Right-click" means click with the right mouse button.
introduction 15



Keyboard conventions
• Key names appear in small capital letters, e.g. "Press ENTER".

• The RETURN key and the ENTER key perform the same action in QlikView.

• A plus sign "+" used between two key names indicates that you must press 
both keys at the same time. E.g., CTRL+S means that you should press the 
CTRL-key while pressing S.

• A comma sign "," used between two key names indicates that you must press 
the keys sequentially.
16



Basics

Starting QlikView
You start QlikView by double-clicking the QlikView icon in the QlikView 
group (created during the installation procedure). You will also find QlikView 
on the Start menu, under Programs.

It is also possible to start QlikView by double-clicking the icon of a QlikView file. 
After QlikView has started, the file will be opened.

Opening an existing file
Use the Open command on the File menu or the Open button on the toolbar to 
open an existing file. If the file was one of the latest QlikView documents 
used, you can also open it by choosing the file name from the File menu.

Several files can be open simultaneously. If this is the case, you can activate another 
file by choosing it from the list on the Window menu, or by using the key combina-
tion CTRL+TAB.

Saving a document
Use the Save command on the File menu or the Save button on the toolbar to 
save an open document. When developing applications, you should save peri-
odically so that you do not lose your work in the event of hardware or software 
problems or a power failure. 

There are two save commands on the File menu: Save and Save As. Use the Save 
As command to save your document under a new file name.

Note It is usually a good idea to save the document before making any major 
changes or a lengthy operation.
introduction 17



Closing a document
Each document appears in its own window. You can close a document at any time by 
using the Close command in the File menu. If you have made any changes, QlikView 
will display a message asking whether you want to save the changes or not. Selec-
tions are considered as changes. Choose the Yes button to save, the No button to 
close the document without saving, or the Cancel button to cancel the closing proce-
dure.

QlikView Help
QlikView Help is a conventional Help program. To find out how to use the 
Help program, choose Using Help from the Help menu. For specific help on 
QlikView, choose Contents from the Help menu and browse through the top-
ics.

Context sensitive help can be obtained by pressing the F1 key or by pressing the Con-
text help button in the toolbar.

Using Documents on a QlikView Server
All variants of QlikView can be used to access documents on a QlikView Server. 
This is done via the Open in Server command on the File menu. However, since we 
cannot assume that you have access to any QlikView Server this tutorial deals only 
with the use of local documents. It could however be pointed out, that when working 
with documents from QlikView Server no commands for changing the layout or 
updating the data are available.
18



WORKING WITH QLIKVIEW

• Making selections in QlikView

• Working with sheets and sheet objects 

• Creating sheets and sheet objects

• Exporting and printing data
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Introduction

This part of the Tutorial will show you how to work with an existing QlikView docu-
ment. Once familiar with the basic terminology, you’ll learn how to make selections 
in QlikView. Subsequently, the components of the QlikView document will be 
described one by one: you’ll learn how to modify and work with the different sheet 
objects to get the results you are looking for.

To go through the steps in this Tutorial, you need the folder Tutorial which has been 
installed together with the program. It has a subfolder named WorkingWithQV, which 
contains two QlikView files: Tutorial.qvw and TutorialFinal.qvw.

Tutorial.qvw is the one you’ll work with. If you follow all the steps correctly, your 
final document will look like TutorialFinal.qvw.
working with qlikview 21
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MAKING QUERIES IN QLIKVIEW
LESSON 1 MAKING QUERIES IN 
QLIKVIEW

In this lesson you’ll get an overview of the basic components of a QlikView docu-
ment and learn how to make queries in QlikView. 

Opening the document
1 Start QlikView by double-clicking the QlikView icon (for other ways 

of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file Tutorial.qvw under Tutorial\WorkingWithQV, then click 
Open.

You have now opened a QlikView document. The opening screen should look simi-
larto Table 1 on page 24.

At the top of the screen you will now have the QlikView menu bar; below this, a tool-
bar. One or more tabs are shown under the toolbar. Each tab is attached to a sheet. 

On each sheet there are a number of sheet objects. The most basic sheet object is the 
list box. Each list box represents a column (field) of the loaded database table, and 
contains a number of (field) values. Statistics boxes, charts, multi boxes and table 
boxes are sheet objects that can be created to get a better overview of data. Buttons 
are used for performing certain commands.
working with qlikview 23
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Selections
In QlikView, the main way of making queries is through the selection of field values. 
When you make a selection, the program instantaneously shows all the field values in 
the document that are related to the selected field value. 

To make a query, or a search, in the database, you just click on something you want to 
know more about.

Figure 1.  Basic QlikView Terminology
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MAKING QUERIES IN QLIKVIEW
1 Click on the tab Geography.

2 Place the mouse cursor on the value Belgium in 
the list box Country and click.

The color of the cell turns green. In QlikView terms, the 
value is selected. This means that this is the item of which 
you want to know more. The result of the search is dis-
played instantaneously in all the other sheet objects. You 
immediately see which of the values in the other list 
boxes are compatible with the selection and which are 
not.

A value that is compatible with the selection is called 
optional. The cells of optional field values are white. 

Selected and optional values will in this Manual together 
be referred to as possible values. 

A cell whose contents are 
incompatible (whose value does not occur in combination 
with that of the selected item) is called excluded. The 
cells of excluded values are gray. 

To facilitate the overview of the query result, the contents 
of the list boxes have been sorted, not only alphabetically, 
but also by their state: optional values are put at the 
beginning of the list, excluded values at the end. 
working with qlikview 25



3 To undo your selection, simply click on the 
selected cell again, or click on another cell in the 
same list box. This selection will replace your 
previous selection. 

4 To select more than one item in the same list box, 
hold the CTRL key down while selecting addi-
tional values. If the items you are selecting are 
adjacent to your first selection, you can instead 
hold the left mouse button down while dragging 
the mouse cursor. 

This multiple selection within a field results in QlikView 
showing the combinations belonging to any of the field 
values (logical or) as optional values.

Combining selections
An optional value in another list box can be 
selected in combination with a previously 
selected value. When you select an optional value from a list box and then 
select another optional value from another list box, QlikView will show the 
combinations belonging to both selections (logical and) as options.

1 Clear your selections by clicking the Clear Selections but-
ton in the toolbar.

2 Click on the tab Sales.

3 Suppose you want to know which salesman has sold products to 
Captain Cook’s Surfing School in Monaco. Go to the list box Cus-
tomer and search for the value Captain Cook’s Surfing School.

4 Select the value by clicking it.

5 Seven values in the list box Country are white, i.e. compatible with 
the selection. Select Monaco. 

You now see that Joe Cheng is the salesman you are looking for. The value 
Joe Cheng is the only one compatible with both Captain Cook’s Surfing 
School and Monaco. 

By making consecutive selections this way, it is thus possible to step by step 
get closer to the answer you are looking for.
26



MAKING QUERIES IN QLIKVIEW
Keeping track of your selections
When you make many selections at the same time it can sometimes be hard 
to keep track of them. In order to help you with this QlikView has two good 
tools, the Current Selections Box and the Current Selections Window.

In the lower right corner of the Geography sheet you will find a Current 
Selections Box. This sheet object lists all fields in which selections have 
been made and the values selected. If too many values are selected, only the 
number of selected values is shown.

1 Make some additional selections in the list boxes and watch how 
they are reflected in the Current Selections Object.

Not all QlikView documents have Current Selections Objects on all sheets. 
If you want to keep track of your selections anyway, you can use the Current 
Selections Window.

2 Click the Current Selections button in the toolbar.

A new window will now appear on top of the QlikView window. This 
window resembles the Current Selections Box quite a bit, but can be moved 
around as you please and will stay in place even if you change sheet or start 
working with another document.

3 Make some selections and watch how they are reflected in the Cur-
rent Selections Window.

4 Close the Current Selections Window by once again clicking 
the Current Selections button in the toolbar.

Moving selections 
The current selections in an active list box can be moved by means of key-
board keys:

1 Clear your selections by clicking the Clear Selections but-
ton in the toolbar.

2 Go to the Geography sheet.

3 Click on the header of the list box Country to make the list box 
active.

4 Select the value Afghanistan. The values related to this value are 
now shown in the other list boxes.

5 Use the  key of your keyboard to move the current selection one 
step downwards in the list box. Note that the other sheet objects are 
updated to show the result of the new selection.
working with qlikview 27



To move the selection upwards, choose the  key. Pressing an arrow key 
when no selection is made is equivalent to scrolling the active list box. 

Text searches and numeric searches

Text searches
Another way to search in data is to make a text search. This is usually the 
best way to search in long lists.

1 On the Geography sheet, clear your selections by choosing Clear 
Selections from the Selections menu.

2 Click on the header of the 
list box Country to make it 
active (blue).

3 Type the letter "s". Now the 
list box contains only coun-
tries containing the letter 
"s". The search string 
appears in a separate win-
dow, between two wild-
cards representing zero or more characters.

Instead of just start typing you may also choose Search from 
the Edit menu or click the Search icon in the toolbar.

4 Add the letter "w" to the search string. Now the list box contains 
only countries containing the combination "sw". 

Hitting the ENTER key will select all the countries with names containing 
"sw". It is also possible to click on the country you wish to select. 

Numeric searches
Similarly, if the search is made in a field containing numeric data, you can 
start your search string with greater than ">" or less than "<" and then enter a 
number. Suppose you want to select all countries with an area below 100 
sq.km.:

1 Clear your selections by clicking the Clear Selections button in the 
toolbar.
28



MAKING QUERIES IN QLIKVIEW
2 Click on the header of 
the list box Area(km.sq).

3 Type <100. The string 
appears in a separate 
window.

4 Only numbers below 100 
are now optional in the 
list box. Press ENTER to 
select them.

The sheet objects are updated to reflect the result of the selection.

Stepping back or forward in the list of 
selections

QlikView remembers the last 100 selections. By clicking the Step Back button in the 
toolbar, you go back to your previous selection:

1 Click the Step Back button in the toolbar. Note that your previous 
selection is displayed.

2 Click Step Back again to go back another step.

To move forward in the list of selections, do the following:

3 Click the Step Forward button in the toolbar and study the result.

This way, you can go back and forth in the list of selections as you wish. Note 
that the Step Back and Step Forward buttons only apply to selections: other 
changes, like the removal of an object or the change of a setting, are not affected.

Locking and unlocking selections
The logic of QlikView by default replaces a previous selection with the new selection 
if the previous selection is in conflict with the new selection. 

1 Select an excluded (gray) value. Note that your old selection disappears.

To prevent this, selections may be locked. Locked cells are blue. A selection in con-
flict with a locked selection will not be performed.

2 Choose Lock Selections from the Selections menu or from the tool-
bar. This will lock all selections, preventing them from being cleared 
by mistake.
working with qlikview 29



3 Try to select an excluded value in another list box and note that it is not pos-
sible.

4 To unlock all selections, choose Unlock Selections from the Selec-
tions menu or from the toolbar.

It is also possible to lock fields individually:

5 Click with the right mouse button on the list box containing the selection, 
then choose the Lock command from the float menu. This will lock the 
selected field values of this specific field. If there are no selected items in the 
list, the Lock command in the float menu is inactive (dimmed).

6 To unlock the selection in one field, choose Unlock from the float menu (or 
the Object menu) of the list box containing it.

Selection bookmarks
It is possible to save a set of selections for later use:

1 Select one or several values, then choose Add Bookmark from the Book-
marks menu.

The default name for the created book-
mark is that of the current date (displayed 
in the Create Bookmark dialog, see the 
picture). In addition, the first bookmark 
created on a specific day gets number 1, 
the second number 2, etc. However, you 
can change the default name to a more explanatory text:

2 Type an appropriate bookmark name in the dialog, then click OK.

3 Go to the Bookmark menu again and note that your bookmark has appeared 
in the list of created bookmarks. 

To show the saved set of selections again, simply select the bookmark in the list.

A maximum of ten bookmarks can be displayed in the list. To see futher bookmarks, 
to get more details on a specific bookmark or to delete a bookmark, choose More 
from the Bookmarks menu.

Bookmarks can also be created and selected via a bookmark object in the layout. 
More about this in Lesson 10 page 111.

Now that you’ve learned how to make selections in QlikView, it is time to describe 
the components of the document more thoroughly. The most basic component is the 
sheet, which will be introduced in the next lesson.
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MAKING QUERIES IN QLIKVIEW
Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save As from the File menu to save a 
copy of the document. 

2 Type MyTutorial.qvw or something similar in the 
File name box, then click Save.

QlikView saves the copy. MyTutorial.qvw now contains 
all the changes you’ve made since you opened the docu-
ment, whereas the original document (Tutorial.qvw) 
remains unchanged. 

You can now close the file:

3 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

4 Choose Exit from the File menu.
working with qlikview 31
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SHEETS
LESSON 2 SHEETS
This lesson introduces the sheet, which is the most basic component of the QlikView 
document. You’ll learn how to create a sheet, how to add list boxes to it, and how to 
move it. The lesson ends with an overview of the available sheet objects.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Select the file you created in the previous chapter, named MyTutorial.qvw or 
something similar, directly from the File menu.

You have now opened the document.

Presentation
Holding all the different objects, the 
sheet can be considered the most basic 
component in QlikView. A document 
usually contains several sheets, which is 
useful when one wants to achieve a more 
structured layout. Any sheet object can 
be put on any sheet. The sheets will, 
however, still be logically connected, i.e. 
a selection made on one sheet will affect 
all sheet objects on all other sheets.

Logical connections between sheets
Each sheet has a tab attached to it. Containing the name of the sheet, the tab helps 
you find the sheet you are looking for. By clicking on a tab, you activate the sheet 
attached to it. 

There are two sheets in your document: Geography and Sales. Geography is the 
active sheet.

1 Click on the tab Sales.
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The tab name changes from normal to bold, and the sheet attached to it is shown.

2 Select the value Albania in the list box Country. 

The cell of the selected value turns green and you immediately see all the values of 
all other fields that are compatible with the selection (white). You see that the fictive 
company has one customer in Albania, Moe’s Laundromat, and that John Lemon is 
responsible for the sales. 

The sheets are logically connected, i.e. a selection made on one sheet will affect all 
sheet objects on all other sheets. 

3 Go to the sheet Geography by clicking on its tab.

The sheet Geography, on which you learn more about the geographical data related to 
the value Albania, also contains a Country list box. Note that the value Albania is 
selected (green) in this list box too, although you made your selection on the sheet 
Sales. 

4 Go back to the sheet Sales. 

5 Select the item Cesar Sandu (currently excluded, i.e. gray) in the list box 
Salesman.

You immediately see that Cesar Sandu has been active in France, Germany, and Mon-
golia. The item Albania, which is not compatible with the selected item Cesar Sandu, 
has been excluded. 

6 Go to the sheet Geography.

The data displayed in the sheet objects has been updated to show the result of the new 
selection: France, Germany and Mongolia, as well as the items related to these coun-
tries, are shown as optional. 

Note the green dot on the tab Sales. This is a selection indicator, helping the user to 
keep track of selections made on other sheets. Especially in large documents contain-
ing many selections, this kind of reference to sheets where the selections can be 
changed is indispensable. If referring to a locked selection, the selection indicator is 
blue.
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Adding a sheet

1 Choose Add Sheet from the Layout menu. A new sheet appears.

2 Click on the empty sheet with the right mouse button and choose Properties 
from the menu that appears. The Sheet Properties dialog will now appear.

3 Change the title from Sheet 3 to Customer.  

4 Click on the Fields tab.

5 The dialog page now appearing contains a list of the available fields. Select 
Customer, then click the Add > button. The field has now been moved to the 
column of displayed fields, which means that it will appear as a list box on 
your sheet. 

6 You can also add fields to the column of displayed fields by double-clicking 
them. Double-click the field name CustomerID.

7 Click OK to close the dialog.

Figure 2.  The new sheet.
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You have now created a new sheet containing two list boxes. Due to the selection 
made on the sheet Sales, only a few values are optional. You learn that Alf Jequitaine, 
Atlantic Marketing and The Mongolian Barbecue House are customers of the 
selected salesman Cesar Sandu.

Moving a sheet
Your new sheet Customer, containing the list boxes Cus-
tomer and CustomerID, is placed on the right-hand side of 
the sheet Sales. Suppose you want it in the middle: 

1 Click on the tab of your newly created sheet with 
the right mouse button. From the float menu that 
opens, choose Promote Tab.

The new sheet has now been placed between the sheets 
Geography and Sales.

2 Clear all selections by clicking the Clear Selec-
tions button in the toolbar.

Adding sheet objects
The following sheet objects can be used in QlikView:

• List boxes

• Statistics boxes

• Multi boxes

• Table boxes

• Charts (including pivot tables and straight tables)

• Input boxes

• Slider objects

• Current Selections boxes

• Bookmark objects

• Buttons

• Text objects

• Line/Arrow objects
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• Custom objects

All the sheet objects except buttons, text objects and line/arrow objects can be used 
for making selections in the data. All sheet objects may be used for viewing the result 
of selections. 

In the following lessons, the most important sheet objects will be presented one by 
one. The first sheet objects that you’ll get acquainted with are the list boxes and sta-
tistics boxes.

Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 3 LIST BOXES AND STATISTICS 
BOXES

This lesson introduces the list box and the statistics box. Once you’ve learned how to 
add, copy, move, size and remove a list box, you’ll modify its appearance and its way 
of displaying data. The sort order, the number format and the border are examples of 
properties that you will change. At the end of the lesson, you will learn how to create 
and use a statistics box.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file you worked with in the previous lesson, named 
MyTutorial.qvw or something similar, then click Open.

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

You have now opened the document.
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The list box
The list box, which is the most basic object on the 
screen, contains a list of all the values of a specific 
field.

All the data belonging to the field can be found in the 
list box. If there is not enough space in the visible list 
box, a scroll bar is displayed on the right. 

If a value occurs several times in one and the same 
field, it will only be displayed once in the list box.

Adding a list box
The Customer sheet created in the previous les-
son contains two list boxes, Customer and Cus-
tomerID. Suppose you want to add a list box 
containing countries. The usual way of doing 
this is the following:

1 Make sure that the sheet Customer is 
active, then choose Select Fields from 
the Layout menu. 

2 Double-click the field Country to move it to the column of dis-
played fields. 

3 Click OK.

The field Country now appears as a list box on your sheet Customer.

Copying a list box
In case you want to add a list box that is found on another sheet, you can 
simply copy it. The list box Country, e.g., is found on the sheet Geography: 

1 Click on the tab of the sheet Geography to make it active.

2 Press the CTRL key and keep it depressed while placing the cursor 
on the header of the list box Country.  

3 Press the mouse button and drag the list box to the tab Customer. 
While dragging, make sure that a small plus sign appears; if it does 
not, this means that you have released the CTRL key. 

4 When the cursor turns into a round arrow on the tab Customer, 
release the mouse button, then the CTRL key.
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5 Go to the sheet Customer to make sure that the list box Country has 
appeared. Its position on the sheet should be the same as on the 
sheet from which it was copied.

Naturally, it is also possible make a copy of a list box on the same sheet. In 
that case, instead of dragging the list box to another tab, simply drag it to the 
desired position on the active sheet.

If you prefer the standard Windows Copy and Paste commands, they can be 
used as well. You find them in the Edit menu. The standard Windows short-
cuts CTRL+C and CTRL+V also work.

Moving a list box
To move a list box you follow the same steps as above (copying), but with-
out pressing the CTRL button. 

1 On the sheet Customer, move the new list box Country to the right 
side of the other list boxes.

To move a list box step by step, use CTRL+arrow. For bigger steps, use 
CTRL+SHIFT+arrow.
working with qlikview 41



Moving several list boxes simultaneously

To move several list boxes at the same time, start by selecting them. This is done in 
the following way:

1 On the sheet Customer, place the mouse cursor in the bottom right 
corner, then press it and drag a rectangle enclosing all the list boxes 
on the sheet. Note that the headers of the list boxes turn blue. This 
means that they are selected, i.e. active.

2 Place the mouse cursor on the header of one of the list boxes, then 
press the mouse button and drag. All the selected list boxes are 
moved.

It is also possible to select several list boxes by SHIFT-clicking their headers.

Figure 3.  Activating several sheet objects
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Sizing a list box

You can size list boxes (and other sheet objects) by dragging the window frame of the 
object.

1 Click on the header of the list box Customer (still on the 
sheet Customer) to make it the only active list box. If the 
other list boxes remain active, they will be sized as well. 

2 Move the pointer to one of the corners of the list box until 
the appearance of the pointer changes (Figure 4).

3 Press the mouse button and drag.

The list box Customer now overlaps the first Country list box. 
You’ll deal with this in the next section.

Adjusting the layout
The layout of the sheet Customer needs to be improved. To make the Coun-
try list box entirely visible again, you could simply move it, then move the 
other two list boxes accordingly. There is, however, an easier way of adjust-
ing the layout:     

1 Position the mouse cursor in the bottom right corner of the sheet, 
then press the mouse button and draw a rectangle on the sheet. All 
the list boxes within the rectangle are now selected.

2 In the Layout menu, place the mouse cursor on the Align/Distribute 
command. The cascade menu that opens contains several com-
mands. Choose Adjust Left.

Figure 4.  Sizing a list box
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The list boxes are now separated by equally sized spaces. If there is not 
enough space between the list boxes, drag the rightmost listbox further to the 
right, then choose Adjust Left again. 

Displaying and using the design toolbar
If you use a QlikView document only for making selections, the main tool-
bar is sufficient: it contains the most common commands for working with a 
document. However, as soon as you modify the layout, add objects etc., the 
design toolbar may be helpful. The design toolbar contains commands for 
adding sheet objects, moving sheets, and adjusting the layout.

Suppose that you want to top align the list boxes of your sheet: 

1 If the list boxes are not already selected, select them by choosing 
Activate All from the Edit menu.

2 Click the Top Align button from the design toolbar.

Feel free to further adjust the layout of your document.

Removing a list box
If you have followed all the steps above, there are two Country list boxes on 
your sheet Customer. You only need one:

1 Click on one of the Country list 
boxes of the sheet Customer with the 
right mouse button.

2 From the float menu that appears, 
choose Remove.

3 QlikView issues a message asking 
you if you are sure about removing 
the list box. Click Yes.

The list box disappears from the screen. Rear-
range the remaining list boxes.

Another possibility is to choose the Remove 
command from the Object menu. The Object 
menu is equivalent to the float menu of the 
active sheet object (the one whose header is 
blue) or, if there is no sheet object, of the 
active sheet. If several sheet objects are 
active, the object menu contains the com-
mands that are common to the active objects. A further possibility for 
removing a sheet object is by pressing the DELETE key.
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Minimizing and restoring
List boxes and other sheet objects can be minimized if, for some reason, you 
don’t want them on the screen now but might need them again later. 

Note the  symbol in the upper right corner of the chart and the table box 
on your Geography sheet. This symbol indicates that the sheet object can be 
minimized. To make a list box minimizable, do the following: 

1 Click on the list box with the right mouse button and choose Prop-
erties... from the float menu.

2 Go to the Layout page and mark the check box Allow Minimize, 
then click OK.

The minimize symbol should now have appeared in the top right corner of 
the list box.

3 Click the symbol or double-click on the header of the list box.

The list box turns into an icon, which is placed in the bot-
tom left corner of the sheet. The icon can be moved 
freely. 

4 Restore the list box by double-clicking the icon.  

It is also possible to minimize a list box by choosing Minimize from the float 
menu, and to restore it by choosing Restore from the menu.

Changing the properties
Every sheet object has a properties dialog, containing several pages with a 
number of settings. You will now modify some of the list boxes using the 
settings in the properties dialog.

Showing frequency
Suppose you are interested in knowing how many sales have been 
performed during different years.

1 Clear your selections by clicking the Clear Selec-
tions button in the toolbar.

2 Go to the sheet Sales.

3 Click on the list box Sales with the right mouse button and 
choose Properties... from the float menu.

4 On the General page of the List Box 
Properties dialog, select the Show 
Frequency check box by clicking in 
it.
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5 Choose OK.

Each value in the list box is now followed by its number of occur-
rences. We can e.g. see that 14 sales for $900 have been made.

Changing the number and order of columns
To display the contents of a list box in several columns, do the fol-
lowing:

1 Clear your selections. 

2 Click on the list box Day with the right mouse button, then 
choose Properties... from the float menu.

3 Go to the Presentation page.

4 Deselect Single Column, then click OK. 

5 Drag the border of the list box Day until its contents are dis-
played in several columns

The values are ordered by column, i.e. vertically. You may prefer to 
have the values of the Day list box ordered by row:

6 Click on the list box Day with the right mouse button, then 
choose Properties... from the float menu. 

7 Go to the Presentation page.

8 Deselect Order by Column, then click 
OK. The field values, instead of being 
ordered by column (vertically), are now 
ordered by row (horizontally). Your list 
box should now look like the one to the 
right.

Changing the sort order
A number of different sort orders are available for each list box. 

Numeric fields are usually sorted by numeric value, whereas fields 
containing text tend to be sorted in alphabetical order (Text).

In addition, list boxes whose values are not all visible (list boxes 
with scroll bars) are set to Sort by State, which means that the val-
ues are sorted according to their logical state (selected, optional, 
excluded). This way, selected and optional values are always visible 
in the document.

1 Click on the list box Sales with the right mouse button, and 
choose Properties....
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2 Choose the Sort page by clicking on its tab.

The list box Sales, as we see, is 
sorted by State and Numeric 
value, Ascending. The order of 
the sort options in the list corre-
sponds to the priority sort order. 
Thus, as long as no selection is 
made, the values in the list box 
Sales are sorted by numeric 
value; as soon as a selection is 
made, however, the state of the 
values determines the sort order. 

3 Keep the option Numeric value selected, but change the 
order to Descending by choosing it from the drop-down 
box (click the arrow to the right).

4 Click OK.

The highest number is now at the top. As soon as a selection is 
made, however, the selected (green) value(s) or optional (white) val-
ues will be placed at the top.

5 Make a selection in the list box and study the result.

6 Clear your selections.
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Changing the number format

Numeric data can be of different types and can be formatted in different 
ways. 

1 Click on the Sales list box with the right mouse button, and 
choose Properties..., Number.

The number format of the field Sales is disabled because all number 
formats are inherited from the documents by default. To set the 
number format for the Sales list box in US dollars do the following:

2 Click in the Override Document Settings check box in 
order to create a separate number format for this list box.

3 Select the option Money, then click OK.

Note that the values in the list box Sales (see Figure 5) are now dif-
ferently formatted (you may need to size it first): a comma has 
appeared as thousands separator and the values are preceded by a $. 
Two decimals have been added.  

4 Open the Properties dialog again.

Figure 5.  The dialog page on which the number format is set
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5 Study the Number dialog page. The current format is dis-
played in the Format box, and below this a preview is 
given. The format can be changed manually. Erase the two 
decimals (the zeros) and view the result of the change in the 
Preview box.

6 Click OK to close the dialog.

Aligning the values
Text is usually left-aligned, numbers right-aligned. This setting can 
be changed on the Presentation page.

1 Click on the list box Year with the right mouse button, then 
choose Properties... from the float menu.

2 Go to the Presentation page.

3 In the Alignment group, click 
Left for numbers.

4 Click OK.

Changing the border
Every sheet object has a border that can be given a number of differ-
ent appearances.

1 Click on a list box with the right mouse button, and choose 
Properties..., Layout.

2 Pick a border format of your choice.

3 Click OK.

If you want all the sheet objects in the document to have the same 
border, change the setting in the Document Properties dialog (see 
page 116).

Changing the font
All sheet objects contain text written in a certain font. To change the 
font of a single object, open the Font page in the dialog of the par-
ticular object. To change the font of the entire document, open the 
Font page of the Document Properties dialog (see page 116). 
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The statistics box
The statistics box is a compact way of showing a numeric field 
in which the separate records are not interesting, but e.g. the sum 
or average is. 

A number of different statistical functions can be used in a statis-
tics box. It is also possible to make selections in the statistics box by clicking on 
some of the functions, e.g. Min, Max, Median, etc.

The sheet Geography in your document contains a statistics box based on the field 
Area(km.sq). 

As long as no selections are made in the document, the values shown in the statistics 
box are calculated using all the possible values of the corresponding list box. As soon 
as you click a value, however, the statistics box is updated just like the other sheet 
objects. 

1 Select the items Albania, Algeria, Andorra and Angola in the list box Coun-
try and see how the values in the statistics box change.

Statistics boxes can be moved, sized, copied and closed just like ordinary list boxes.

Creating a statistics box
1 Make sure that no selection is made by clicking the Clear 

Selections button in the toolbar.

2 Make the list box Sales on the Sales sheet active by clicking on its 
header.

3 Click on the list box with the right mouse button, and choose Create 
statistics box from the float menu. 

A statistics box with the same name as the active list box now appears on the 
screen. You might need to size it to see all the numbers properly.

You immediately see that the company has sold products for a total amount 
of 2,317,233 USD, that 713 sales have been performed, etc.

Another possibility is to choose New Sheet Object, Statistics Box 
from the Layout menu or to click the Create Statistics Box button in 
the toolbar. In that case, the Properties dialog of the statistics box is 
opened. This dialog looks similar to that of the list box, but only contains 
three pages. On the General page, you select the statistical functions you 
wish to use.
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Making selections in a statistics box
You can make selections in a statistics box by clicking on the non calculated 
functions, e.g. Min, Max, and Median.

1 Click the function Max to find the customer who made the purchase.

The selection is made in the list box to which the statistical value 
belongs. 

2 Clear all selections by clicking the Clear Selections button 
in the toolbar.

The list box and the statistics box are only two of the sheet objects available. 
In the next three lessons, different kinds of charts and tables - calculated 
objects allowing you to get an even better overview of your data - will be 
introduced.

Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to 
your document. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a 
while, you can also exit the program:

3 Choose Exit from the File menu.
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LESSON 4 BAR CHARTS AND PIE 
CHARTS

Due to the variety of chart subtypes, and considering the great number of available 
settings, the Tutorial provides three lessons on charts. This lesson will start by giving 
you a general introduction to working with charts; subsequently, you’ll create a sim-
ple bar chart. Once familiar with the basics, you’ll modify the properties of the chart 
and finally turn it into a pie chart.

Introduction
Charts and tables are sheet objects that can show numbers very compactly. You can 
e.g. show sums of money, distributed over different fields such as year, month, 
account number, etc. Numbers that are calculated using several records in the input 
tables (sums, averages, min, max) can only be shown in charts or statistics boxes. 

Charts, pivot tables and straight tables are logically the same thing, even though they 
look different. Hence, we will from here on simply refer to them as charts. Charts can 
thus be shown as bar charts, pie charts, scatter charts, line charts, combo charts (bar/
line), radar charts, grid charts, gauge charts, straight tables or pivot tables. All the 
chart types are shown below. 

Bar chart Pie chart
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Combo chart Scatter chart

Line chart Straight table

Pivot table Radar chart
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Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file MyTutorial.qvw, then click Open. 

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

Making selections in a chart
Until now, we have only studied selections in list boxes. It is however also possible to 
select data in charts.

1 Go to the Geography sheet.

Grid chart Gauge chart

Block chart
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The Geography sheet contains a bar chart showing the ten largest countries.

2 Place the cursor in the chart, then press the mouse button and select a few 
bars by "painting" the area (dragging the cursor). When this is done, release 
the mouse button.

3 The countries represented by the 
bars you painted have been 
selected. Check this in the list 
box Country.

It is also possible to make selections by 
clicking on the labels in the chart:

4 Select one or several countries by 
clicking on their labels.

To undo the selections made in the chart, 
simply click in the outer chart area.

Moving and sizing
Charts can be moved, sized and copied in the same way as list boxes. 

1 Place the cursor on the header of the chart, then press the mouse button and 
drag the chart to the desired position. 

2 Size the chart by dragging its frame. 

Copying, minimizing, maximizing and restoring
You copy the chart in the same way as the list box:

1 Press the CTRL key and keep it depressed while placing the cursor on the 
header of the chart.  

2 Press the mouse button and drag the chart aside. While dragging, make sure 
that a small plus sign appears; if it does not, this means that you have 
released the CTRL key. 

It is possible to minimize charts to save space. Do the following: 

3 Click on the chart with the right mouse button, then choose Minimize.

The chart turns into an icon and is placed at the bottom of the screen. The icon can be 
moved freely.
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Another way of minimizing a chart is to double-click its header or 
to click the  symbol. To restore a chart, click on it with the right 
mouse button and choose Restore, or double-click the minimized 
chart icon.

It is also possible to maximize charts. This is done by clicking the  symbol. A max-
imized chart is restored in the same way as a minimized one, i.e. by choosing 
Restore or double-clicking the header. Another possibility is to click .

Changing chart type with fast type change icon
Some charts in QlikView are prepared for being displayed as more than one type. 
This is shown as a little icon, either in the chart’s header or in the chart itself. The 
icon is a miniature of the next chart type that will appear if you click on it.

1 Take a look at the bar chart in the Geography sheet. In the chart header to the 
left of the minimize icon you will find a fast type change icon.

2 Click the icon with the left mouse button. The chart will turn into a line 
chart.

3 This chart has been prepared for changing between three types of charts: bar, 
line and pie. If you click again the chart will turn into a pie chart.

4 Now click with the right mouse button on the fast type change icon. A drop-
down menu will appear with all three possible chart types. Click the bar 
chart icon and we are back where we started.

All charts can be turned into any of the seven chart types available by going through 
the chart’s Properties dialog. More about this later.

Creating a simple bar chart
The toolbars contain two buttons for creating charts. The one in the main (upper) 
toolbar allows you to create a chart in two simple steps, whereas the one in the design 
toolbar makes it possible to set a great number of properties from the very beginning. 
Regardless of which one you choose, you will get a full-blown chart whose settings 
can be modified at any time. 

Two things are important to think about when making charts:

• What do you want to look at? (What should the sizes of the bars in the bar 
chart correspond to?) The answer, in this case, is the Sales. This is set as Y-
axis Dimension in the second box.
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• What do you want to group it by? (Which field values do you want to use as 
labels for the bars in the bar chart?) The answer, in this case, is per Country. 
This is set as X-axis Dimension in the first box.

You’ll start by creating a simple chart showing the sum of sales per country.

1 Go to the sheet Sales, and make the list box Country active by clicking its 
header.

2 Click the Create QuickChart button in the main toolbar. 

3 The first page of the QuickChart wizard appears. It contains three 
icons representing different charts. Click on the icon representing the bar 
chart.

4 The second page of the QuickChart wizard opens. 

5 Select the field Country in the combo box X-axis Dimension and the field 
Sales in the box Y-axis Dimension.

6 In the Function group below the boxes, you can choose between the func-
tions Sum and Frequency. If you keep the preselected option Frequency, 
this will result in the chart displaying the number (total count) of sales per-
formed in each country. This is not what you want. Select the option Sum to 
get the sum of sales per country.

7 Click OK.

The chart should now have appeared on your screen. Its layout is by no means opti-
mal: among other things, the great number of bars in the chart makes it difficult to get 
an overview. You’ll soon be able to change this. However, you can already use the 
chart to make selections or to view the result of selections:

8 Select Ann Lindquist in the list box Salesmen.
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The chart immediately displays the countries to which Ann Lindquist has sold prod-
ucts, as well as the amounts of money involved. 

Figure 6.  The countries to which Ann Lindquist has sold products.
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Creating a bar chart using the full chart wizard

1 While on the sheet Sales, click the Create Chart button in the design 
toolbar. The first page of the chart wizard appears.

2 On this page you can choose the type of chart you would like to work with. 
The bar chart option is preselected; leave it that way.

3 Type Sales in the box Window Title.

4 Choose Next>.

The second page of the wizard, Dimensions, on which you can set the dimensions to 
be shown on the x-axis, is now open.

The left list contains all the fields or groups (you’ll learn more about groups on 
page 185) available. 

5 Select the field Country, then click Add> to move it to the list of displayed 
fields.

6 Click Next >.

Figure 7.  The Dimensions page
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The Edit Expression dialog automatically opens. Here you set one or more expres-
sions to be displayed on the y-axis. You can enter an expression directly into the 
Expression edit box, but it is also possible to use the predefined functions in the 
Expression group.

7 In the Aggregation Functions and Fields group, click the arrow belonging 
to the first drop-down list and select Sum. Then click the arrow belonging to 
the second drop-down list (containing the field names) and select Sales.

8 Click Paste. 

9 The name of the expression appears in the Expression edit box. 

10 Type Sales into the Label box. This is the name that will appear on the y-
axis.

11 Click OK. The sum of the company’s sales is calculated and will be dis-
played on the y-axis.

By clicking OK, you get back to the Chart Properties dialog. Note that the expres-
sion you just defined has appeared on the Expressions page. 

Figure 8.  The Edit Expression dialog
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You have now selected one variable and one expression, i.e. performed the basic 
steps of the creation of a chart. 

12 Click Finish.

The chart has now appeared on your screen. Compare it with the one created  in the 
previous section. You will notice that there are no numbers displayed on top of the 
the bars. This is due to different property settings. Below you will learn how to mod-
ify the properties to change the appearance of your chart.   

13 Clear your selections.

Removing a chart
You only need one of the charts you created. 

1 Click on the first chart with the right mouse button, then choose Remove 
from the float menu.

2 QlikView issues a message asking you if you really want to remove the 
chart. Click Yes.

The chart disappears from the screen.

Changing a few properties
The chart wizard that helped you create the chart contains eleven pages, of which you 
only used three. No need to worry: all the pages of the chart wizard are also found in 
the Properties dialog of the chart, which can be opened at any time. You’ll now use a 
few of the settings found on the remaining pages.

Changing the sort order
The chart is currently sorted in alphabetical order. You may prefer to put the 
main customer country furthest to the left: 

1 Click on the chart with the right mouse button, then choose Proper-
ties... from the float menu. 

2 Go to the Sort page.

3 Select the option Y-value to sort the countries according to their 
sums of sales.

4 Select Descending to put the highest bars to the left.

5 Click OK.
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Limiting the number of bars
The chart you have created does not display any labels unless only a small 
range of values is selected. You can limit the maximum number of bars to be 
displayed:

1 Click in the chart with the right 
mouse button, then choose 
Properties... from the float 
menu.

2 Go to the Presentation dialog 
page by clicking its tab.

3 Mark the check box Max Visi-
ble Number. The number 10 is preselected. Leave it that way.

4 Click Apply. 
The number of country names having decreased, they are now displayed in 
the chart. 

Displaying numbers on the bars
The next thing we want to do is to display numbers on top of the bars in our 
chart.

1 Open the Expressions page in the properties dialog.

2 Select Numbers on Data Point.

3 Click OK.

You have now added the y-value numbers on top of the bars.
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Changing the number format

Displaying the numbers on top of the bars is very useful, but when a large range of 
values is shown, there is not enough room for all the numbers. You can solve the 
problem by changing the number format: 

1 Open the Number page in the Properties... dialog.

2 Expressions default is preselected here. Change it to Fixed to.

3 Change the value in the Decimals box to 0 (if it isn’t set to 0 already).

4 Enter 1,000 $ in the box Thousand Symbol.

5 Click OK. 

The numbers on top of the bars now have much more space. 

Cloning and detaching your chart
You can clone (copy) a chart in the same way as a list box (by CTRL-dragging), but 
there is also another way of doing it: 

1 Click on the chart with the right mouse button to open the float menu.

2 Click Clone.

A second chart, identical with the first one, appears on the screen.

Figure 9.  A bar chart showing the sum of sales for different countries sorted by y-
value
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3 Move the chart in order to see all the sheet objects.

4 Click on the new chart with the right mouse button 
to open the float menu.

5 Choose Detach.

A detached chart is not updated as selections are made. This 
can be useful when you want to keep the overview while 
making selections.

6 Make a few selections. See how the original chart 
is updated, whereas the detached chart stays the 
same.

7 Attach the chart again by choosing Attach from the float menu. 

8 Clear your selections by clicking the Clear Selections button in the 
toolbar.

Turning the bar chart into a pie chart 

There are several different chart types to choose between, each one with properties 
that suit certain purposes. You’ll now turn the second bar chart into a pie chart. 

1 Click on the chart with the right mouse button, then choose Properties... 
from the float menu.

Figure 10.  The resulting pie chart
working with qlikview 65



2 On the General page, select the option Pie chart.

3 On the General page it is also possible to change the chart title. Change it to 
Sum of Sales.

4 Go to the Presentation page.

5 Mark the check box Numbers in Legend (corresponds to Numbers on Data 
Points for bar charts).  

6 Click OK.

The result is a pie chart where each slice represents the sales in a particular country.

Changing the color settings

Go to the previously created bar chart. Note that the bars have the same color (green). 
This can be changed on the Colors page:

1 Click on the bar chart with the right mouse button, then 
choose Properties... from the float menu.

2 Go to the Colors page.

Figure 11.  The dialog where the colors used in the bar chart are set.
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3 Select the check box Multicolored.

4 Choose OK.

Compare the colors used in the bar chart with those of the pie chart. 
You see that the same colors are used for the same countries. This 
default setting is very useful in that it enhances the consistency 
between different charts and sheets.

The 18 colors of the color map can be customized: on the Color 
page, simply click a color that you would like to change and pick the 
color of your choice from the map that opens.

Showing the percentage
Since the pie chart illustrates proportions, one might be more interested in 
knowing the percentage than the actual sum of sales. 

1 Click on the pie chart with the right mouse button, then choose 
Properties....

2 Go to the Expressions page. 

3 Mark the check box Relative. 

4 Click OK.

The percentage numbers now appear in the legend.

You don’t need the pie chart on the screen at the moment, but you might 
need it again later. To save space, minimize the chart: 

5 Click on the pie chart with the right mouse button, then choose Min-
imize.

The chart turns into an icon and is placed at the bottom of the screen.

In the next lesson, you’ll add another dimension to an existing bar chart and 
create pivot tables and straight tables. 
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Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 5 PIVOT TABLES AND 
STRAIGHT TABLES

In this lesson, you will continue creating and using charts. After adding a dimension 
to an existing bar chart, you will turn it into a pivot table. Subsequently, you’ll create 
a straight table containing the same information to compare these two ways of pre-
senting data.  

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file MyTutorial.qvw, then click Open. 

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

You have now opened the document.
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Adding a dimension to an existing bar chart

Until now you have worked with only one dimension and one expression. Charts can 
be very complex, though. They can show several dimensions and/or expressions 
simultaneously or sequentially, etc. 

You’ll start by creating a chart with two variables and one expression. It will still 
show the sum of sales per country, but grouped over different years:

1 Clone the bar chart that you created in the previous lesson (Sales sheet).

2 Open its object (float) menu, then choose Properties....

3 On the General page, change the chart title to Sales per Year.

4 On the Dimensions page, move Year to the list of displayed fields.

5 On the Style page, set Subtype to Stacked.

6 On the Presentation page, set 5 as maximum number.

7 Click OK to finish the chart.

A bar still represents the sum of sales of a specific country, but it is now divided into 
different color sections representing different years.

Figure 12.  A bar chart with two dimensions
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Turning the chart into a multidimensional pivot 
table

Displaying data graphically is very illustrative, but you can’t show too much infor-
mation at the same time without losing clarity. To display calculated data for several 
dimensions, your choice of chart may be a pivot table: 

1 Open the Properties dialog of the bar chart you just created by choosing the 
corresponding command from the float menu.

2 On the General page, select Pivot table.

3 Choose OK.

The pivot table shows the data in cross table format: the first field (Country) is dis-
played as a regular column, whereas the values of the second field (Year) constitute 
the headers of the remaining columns. The columns contain the values of the expres-
sion (Sales).  

Dragging dimensions

The pivot table is a very flexible sheet object, allowing you to freely drag the differ-
ent dimensions and expressions to any position on the vertical or horizontal axis. In 
this case, e.g., you would probably prefer to present the dimension Year on the verti-
cal axis. Do the following:

1 Position the mouse cursor on the field Year.   

Figure 13.  Dragging the Year column to the vertical axis
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2 Press the mouse button and drag the field to the desired 
position, e.g. to the right-hand side of the field Country. 
The selected column and its target are highlighted in blue 
while you are dragging.

3 Release the mouse button.

The dimension Year, as well as the expression values, are now dis-
played on the vertical axis.

Adding a dimension
To add another dimension, do the following:

1 Open the Properties dialog and go to the Dimensions 
page.

2 Double-click the dimension Salesman to move it to the list 
of displayed fields, then click OK. 

The dimension appears on the horizontal axis.

3 Place the dimension Salesman next to Year by dragging it 
the way you did above.

The pivot table should now look like below:

Figure 14.  The resulting pivot table
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Expanding and collapsing

The pivot table provides yet another useful feature: the possibility of expanding and 
collapsing dimensions on value level. By collapsing the values you’re currently not 
interested in, you considerably enhance the overview of your data.

You have probably noted the small signs   and  displayed in the 
top right-hand corners of the values in the columns. A minus sign 
indicates that the dimension is expanded, whereas a plus sign indi-
cates that it is collapsed. At the moment, all the columns are fully 
expanded, i.e. all the values of the following column are shown.

1 Click in the Year column with the right mouse button, then 
choose Collapse all.

All the values of the dimension Salesman, previously shown, are 
now hidden. Suppose that you are only interested in the sales per-
formed in Belgium:

2 Right-click in the Country column, then choose Collapse 
all to show only this column.

3 Click the plus sign of the value Belgium.

4 Click the plus sign of the values 1994 and 1995.

Figure 15.  The pivot table showing details for Belgium
working with qlikview 73



You have now expanded only those values of the following columns 
that are related to the value Belgium. Details on salesmen are only 
visible for 1994 and 1995.

Adjusting the columns
The country column of the pivot table is not wide enough for certain values.

1 Place the cursor on the line separating the country column from the 
year column.

2 When the cursor looks like 
the one shown in the fig-
ure below, press the mouse 
button and drag.

3 All the columns can be 
sized this way. To adjust 
the rightmost column, 
place the cursor within the 
border (to the left of the 
scroll bar) and drag. 

You can also adjust the columns 
using the command Equal Colum-
nwidth in the float menu.

Showing partial sums
At the moment, the table shows the sales for Belgium during different years. 
Suppose you wish to know the sum of sales during all the years together. Do 
the following:

1 Choose Properties... from the float menu. 

2 Go to the Presentation page.

3 In the Dimensions and Expressions list, select the variable Year.

4 Mark the check box Show Partial Sums. 

5 Click OK.

The pivot table now shows partial sums on year level.
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Creating a straight table

In opposition to the pivot table, the straight table cannot display sub-totals or serve as 
a cross table. On the other hand, any of the columns of the straight table can be sorted 
and each of its rows contains one combination of dimension(s)+expression(s).  

1 Minimize the pivot chart on the Sales sheet to increase the free space.

2 In the Layout menu, point to New Sheet Object, then choose Chart.

3 In the wizard that opens, select Straight table.

4 Type Salesman in the box Window title.

5 Click Next>.

6 On the Dimensions page, move Year, Country and Salesman to the column 
of displayed fields.

7 Click Next>.

8 The Edit Expression dialog opens.

9 Compose the expression Sum of Sales by selecting the corresponding items 
from the lists in the combo boxes (Aggregation Functions and Fields 
group). 

10 Click Paste.

11 Type Sales in the Label box.

Figure 16.  The resulting straight table
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12 Click OK.

13 Click Finish.

You now have a straight table containing the same information as the pivot table. 
Compare the two tables. Notice that in the straight table, the total sum of sales is 
shown at the top, that each row represents a possible combination of data (in the pivot 
table, data is grouped by field values), and that no partial sums are given.

Sorting the table
The straight table provides excellent possibilities 
for sorting columns. 

Currently, the column Year is placed furthest to 
the left, and the table is sorted according to the 
sort order specified for this field (Sort page). 
You can see this from the little arrow sort indica-
tor in the column header. You can change the sort 
order of the table with two simple clicks of the 
mouse:

1 Click on the column Salesman with the 
right mouse button to open the float 
menu.

2 Choose Sort.

The order of the columns remains the same, but 
it is now the sort order defined for the field 
Salesman that determines the order of the values in the table. Note how the 
sort indicator has moved to the Salesman column.

The sort priority can also be set on the Sort page of the Properties dialog.
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Moving a column

Suppose you want the field Salesman furthest to the left. Do the following:

1 Press the mouse button while on the column header Sales-
man.

2 Drag the column to the desired position. Both the selected 
column and its target are highlighted in blue while you are 
dragging.

3 Release the mouse button.

The field Salesman is now placed furthest to the left.

Visual cues
You can use visual cues to highlight expression values in the table. Values 
belonging to different value categories can be given separate colors and/or 
font styles. 

1 Click on the straight table with the right mouse button, then choose 
Properties... from the float menu.

2 Go to the Visual Cues page.

3 Sales is the expression available. Select it in the text box.

There are four value categories to choose between: upper, normal, lower and 
text. Suppose you want to highlight all the expression values above 10,000:

Figure 17.  Dragging the Salesman column
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4 Type 10000 in the Upper > edit box.

Next to the edit box, you find two color buttons and three check boxes. This 
is where you set the appearance of the text and/or the background of the val-
ues you wish to highlight.  

5 Suppose you want to apply a green color to the values belonging to 
the upper value category. Click the Text button, then choose a green 
color from the color map.

6 Choose OK.

7 In addition, check the Bold check box. 

8 Click OK.

All the expression values above 10,000 are now highlighted.

Selections in table charts
It is of course possible to make selections in pivot tables and straight tables 
as well. Clicking those columns (or rows in a pivot table) which contain 
chart dimensions imply direct selection of the values clicked on.

1 Click the value 1992 in the Year column. The effect is the same as 
selecting 1992 in the list box Year.

2 Clear your selections.

Clicking a column containing a chart expression implies an indirect selection 
of those values in the dimension columns (rows) that are used to calculate 
that expression value.

3 Click the value $11,379 in the column Sales. You have now selected 
the value 1995 in Year, the value Pakistan in Country and Ann 
Lindquist in Salesman.

4 Clear you selections.

If you need to make more complex or multiple selections in a table chart 
there is yet another option, called drop-down select. This feature makes it 
possible to turn a dimension column into a list box with full selection and 
search possibilities.

1 Click the Salesman straight table to activate it. Then select Proper-
ties... from the float menu.

2 Go to the Presentation page.

3 Mark Year in the list of Columns and check the check box Drop-
down Select.
78



PIVOT TABLES AND STRAIGHT TABLES
4 Repeat for the Country and Salesman columns.

5 Click OK.

You will now find that all three dimension columns have a drop-down icon 
to the left in the column header.

6 Click the leftmost icon and a 
temporary list box with all the 
years will appear. Hold down 
the CTRL key and click the 
years 1992,1995 and 1997. 
Then release the CTRL key. The 
three years will be selected and 
the drop-down list is closed.

7 Click the drop-down icon in 
the Country column. When the 
drop-down list appears, type "sw". This text search will result in 
Botwana, Swaziland, Sweden and Switzerland. Press ENTER and the 
two countries are selected while the drop-down list appears.

8 Clear your selections.

Moving the pivot table and the straight table to a new sheet
1 The Sales sheet is getting too crowded. To improve the overview, 

you’ll create a new sheet for the tables:

2 Choose Add Sheet from the Layout menu.

3 On the General page, enter Tables in the Title box, then click Next>.

4 Click Finish.

5 Go back to the Sales sheet.

6 Move the pivot table to the new sheet (if you have forgotten how to 
move sheet objects, see page 41).

7 Move the straight table to the new sheet.

8 Go to the Tables sheet to adjust the layout.

There is now room for further charts on the Sales sheet. In the next lesson, 
you’ll work with line charts, combo charts, scatter charts and drill-down 
charts. The next lesson also contains information on printing and exporting 
charts.  
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Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 6 MORE CHART TYPES
This lesson introduces further chart types. The line chart is useful for showing trends 
or changes. Working with a combo chart, you can combine the features of the bar 
chart with those of the line chart. As for scatter charts, they show pairs of values from 
two expressions. Gauge charts are used for displaying one specific value. The last 
chart type to be introduced is the drill-down chart, a hierarchic bar chart created out 
of a field group. At the end of the lesson, you’ll print and export a chart.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file MyTutorial.qvw, then click Open. 

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.
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Creating a line chart

Instead of being displayed as bars, data can be presented as lines between value 
points, as value points only or as both lines and value points. Line charts are useful 
for showing changes or trends. 

You’ll create a line chart illustrating how the sales per customer have changed over 
the years. 

1 Go to the Sales sheet.

2 Click the Create Chart button in the toolbar.

3 Select Line Chart, and choose Customer as Window Title.

4 Click Next>.

5 On the Dimensions page, move the fields Year and Customer to the column 
of displayed fields. 

6 Click Next> to create an expression in the Edit Expression dialog.

7 In the Aggregation Functions and Fields group, create the expression 
Sum(Sales), then click Paste.  

8 Click OK.

9 Click Finish.

When no values are selected, the chart looks a bit overcrowded; as soon as you make 
a selection, though, the trends will appear very clearly.

Figure 18.  A line chart showing the sales fluctuation for the customer Atlantic Mar-
keting
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10 Clear previous selections by clicking the Clear Selections button in the 
toolbar.

11 Select Atlantic Marketing in the list box Customer and study the result (see 
the figure above).

12 Undo your selection by clicking on the list box Customer with the right 
mouse button and choosing Clear from the float menu.

13 Select John Doe in the list box Salesman.

One now gets a clear picture of Mr. Doe’s doings. We see that he has had business 
contacts with Carlsborg since 1991, and that Mary Kay has meant a lot to his career 
so far. We also see that he wasn’t very successful with Captain Cook’s Surfing 
School. 

Suppose you want to know if Captain Cook’s Surfing School is still our customer 
after all.

14 Deselect John Doe by clicking the value again.

15 Select Captain Cook’s Surfing School in the list box Customer.

No need to worry: the surfing school is still our customer, even though it purchased 
less during 1996 and 1997. In the pivot table that we moved to the Tables sheet you 
can study the exact data.  

16 Clear your selections.
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Adding an expression to a bar chart

The Geography sheet contains a bar chart showing area per country. Suppose you 
would like to see how area and population are related to each other. 

Start by adding an expression to the existing bar chart. 

1 Click on the chart with the right mouse button, then choose Properties... 
from the float menu.

2 On the General page, change the window title to Area/Population.

3 Select the check box Chart title, and type Area/Population in this box too.

4 On the Expressions page, click Add to get to the Edit Expression dialog.

5 Compose Sum of Population (mio) in the Aggregation Functions and 
Fields group, then click Paste.

6 Type Population into the Label box.

7 Click OK.

8 Click Apply.

Drag the dialog box aside and study the chart. You have set both population and area 
as expressions, but only the area is shown. The reason for this is that both expressions 
are shown on a single axis, and that the magnitude of the numbers of the two expres-
sions differs so much that the population is not visible.

9 Go to the Axes page.

10 Select Population in the Expressions box, then click Right under Position.

Figure 19.  A bar chart showing the ten largest countries and their population
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11 Click OK.

The chart shows the ten largest countries and their population (if no selections are 
made).

Turning the bar chart into a combo chart

You will now turn the bar chart into a combo chart. In a combo chart, you can com-
bine the features of the bar chart with those of the line chart, e.g. by showing one 
expression as bars and the second as lines and/or symbols.  

1 Open the Properties dialog. 

2 On the General page, select Combo Chart.

3 Go to the Expressions page.

The expressions Area and Population are listed in the Expressions box. 

4 Select Area, then mark the Bar check box under Plot Options. The boxes 
named Line and Symbol must not be marked.

5 Now select Population in the Expressions box, then mark the check boxes 
Symbol and Line, leaving the check box Bar deselected.

6 Click OK.

Instead of displaying both expressions as bars, the chart now shows the population as 
symbols and lines.

Figure 20.  A combo chart showing how the population and the area of different 
countries are related to each other.
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Turning the combo chart into a scatter chart

When showing data where each instance has two numbers, like in this case (each 
country has an area and a population), you might find the scatter chart a useful repre-
sentation form:

1 Click on the combo chart with the right mouse button, then open the Proper-
ties dialog. 

2 On the General page, select Scatter Chart.

3 Click OK.

The dimension (Country) is represented by the symbols, and the expressions (Popu-
lation and Area) are displayed on the axes. You immediately see that six of the coun-
tries are placed far out to the right on the x-axis, which means that their areas are far 
above the average. One of the countries also has a huge population.

4 Select those countries by "painting" the area in the chart using the mouse 
button.

You see that the countries are Russia, Canada, China, USA, Brazil, and Australia.

Creating a scatter chart from scratch
You will now create a similar scatter chart, showing population and population 
growth:

Figure 21.  A scatter chart showing how population and area are related to each 
other.
86



MORE CHART TYPES
1 Click the Create Chart button in the toolbar.

2 Choose Population as both Window Title 
and Chart Title, and select the option Scat-
ter Chart.

3 Choose Next>.

4 On the Dimensions page, move Country to 
the column of displayed fields.

5 Choose Next>.

6 The Expressions page of the scatter chart 
differs somewhat from that of the other 
charts. Choose Pop. Growth in the X combo 
box, and Population (mio) in the Y combo box.  

7 Click Finish.

Your new scatter chart is finished. Move it, size it, and try it by making selections.

8 Minimize the chart.

9 Clear your selections.

Creating a gauge chart
Quite often you want to view the changing value of a single measurement as you 
change your selections. For this purpose the gauge chart is ideal. QlikView offers a 
wide range of gauge charts for graphic visualization of values. In this section we will 
create a simple circular gauge chart indicating average gross margin for whatever set 
of customers and/or periods etc. that we have selected.

1 Go to the Sales sheet.

2 Click the Create Chart button in the toolbar.

3 Select Gauge Chart, and type in Gross margin as Chart Title and Window 
Title.

4 Click Next>.

5 On the Dimensions page, we do nothing at all, as most gauge charts are best 
calculated without any dimension resulting in one single value over the 
entire data set.

6 Click Next> to create an expression in the Edit Expression dialog.
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7 In the Aggregated Functions group, create the expression Avg([Gross Mar-
gin]), then click Paste.

8 Click Next> twice.

9 On the Style page, make sure that the first icon under Look (circular gauge) 
is selected.

10 Click Next>.

11 On the Presentation page, enter the value 3000 under Max in the Gauge 
settings group.

12 Click Finish. A semi-circular gauge with two segments, one green and one 
red will appear.

Let’s do a bit of analysis!

13 Click the Clear button in the toolbar. The gauge now shows average gross 
margin for all customers.

14 Select Atlantic Marketing in the Customer list box. This is a good customer!

15 Select the Asian Trade House instead. Room for improvement!

Figure 22.  The gauge chart created above when Atlantic Marketing is selected in the 
Customer list box.
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Working with a drill-down chart

A dimension used in a chart is usually equivalent to a single field, e.g. Year. How-
ever, you will sometimes encounter charts created out of field groups. These charts 
can be of two types, drill-down or cyclic. In a drill-down chart, the field group 
defined usually consists of fields forming a natural hierarchy, e.g. Year, Quarter, 
Month.

The Sales sheet in your document contains a minimized drill-down chart.

1 Go to the Sales sheet.

2 Restore the minimized Drill-Down chart - found in the left-hand corner of 
the screen - by double-clicking it.

The chart, showing the sum of sales per year, looks like any other bar chart. However, 
as soon as you make a selection causing the field Year to have only one possible 
value, you discover its drill-down character:

3 Select the bar 1995 in the chart.

An ordinary chart would now display one bar, representing the sum of sales for 1995. 
This chart, however, shows the sum of sales for each quarter of the year 1995 (the 
second field in the field list defined being Quarter).

4 Select the bar representing the fourth quarter.

The chart turns to showing the sales for each month of the selected quarter. Month is 
the third, and last, field in the field group.

Figure 23.  A drill-down chart
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Note the selections in the Current Selection box in the lower right corner of the sheet. 
Keeping track of selections is very important when working with drill-down charts.

5 To go back in the hierarchy, click in the outer chart area, or on the 
drill-down button next to the field name. 

As soon as more than one value becomes possible in the fields further up in the hier-
archy, the chart is automatically drilled back up.

The creation of field groups will be discussed in Advanced Features (page 185).

You should now be familiar with all the different chart types: bar chart, line chart, 
combo chart, scatter chart, pie chart, pivot table, straight table and gauge chart as well 
as drill-down chart. The last section of this lesson will show you how to copy charts 
to Clipboard and how to print them.

Copying to Clipboard and printing
All sheet objects can be copied as images to the clipboard. Charts and tables can be 
printed. It is also possible to export the data contents of charts and tables to the clip-
board. 

Copying a sheet object to Clipboard
1 Click with the right mouse button on a chart to open the float menu. 

2 Choose Copy Image to Clipboard.

3 To view the result, open a blank document in e.g. Word, and click 
Paste. 

4 Close Word.

Printing
1 Go back to QlikView.

2 Click on a chart with the right mouse button, then click Print....

The Print... dialog opens. The General page of this dialog contains the basic 
print options. The Layout page is used for setting margins and for deciding 
whether a selection stamp should be printed or not. On the Header/Footer 
page you may specify header and footer for the printed pages. For detailed 
information, see the Reference Manual, Book II.

3 Click Print....

It is also possible to choose the Print... command from the File menu or from 
the toolbar. 
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MORE CHART TYPES
In the next lesson, the presentation tour goes on with the multi box and the 
table box.

Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 7 MULTI BOXES, TABLE BOXES 
AND INPUT BOXES

This lesson features the multi box, which allows you to show data in a very compact 
way; the input box, which can be used for interactive input of data; and the table box 
which presents data in table format.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file MyTutorial.qvw, then click Open. 

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

You have now opened the document.

The multi box
The multi box, or multiple drop-
down list box, is a sheet object that 
shows several fields simultaneously 
in a very compact way. 

The multi box makes it possible to 
show a great number of fields on a 
single sheet without losing the over-
view.

How results of selections are shown in multi boxes
The Geography sheet contains a multi box showing country information.

For each field in the multi box, there is a selection indicator telling you if the 
values of the field are selected, optional or excluded.

A value will be shown in the multi box only if it is the single possible 
(optional or selected) one.
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1 Clear all your selections by clicking the Clear Selections button in 
the toolbar.

The selection indicators of the multi box are now all white, which means that 
all the fields contain optional values.

2 Select Dollar in the Currency list box.

Most of the fields still have white selection indicators, which means that they 
contain several optional values. Dollar and Not known being the only possi-
ble values in their respective fields, they are shown in the multi box.  

3 Select Austra-
lia in the Coun-
try list box. 

Values appear in all the 
fields. The multi box 
allows you to display a 
great amount of infor-
mation in a limited space. 

Creating a multi box
1 Go to the Customer sheet.

2 Clear your selections.

3 Click the Create Multi box button in the toolbar or choose 
New Sheet Object, Multi box from the Layout menu.

The General page of the Multi Box Properties dialog box now appears. 
Here you can choose the fields to display in the multi box.

4 Type Customer info in the Title box.

5 Select Customer in the column listing available fields, then click 
Add>.

The field Customer is moved to the column of displayed fields, which means 
that it will appear in the multi box. Select a few more fields:

6 Select Address by clicking the field in the list.

7 Press CTRL while clicking the fields City, Country, and Zip.
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8 Click Add>.

9 Click OK.

The multi box appears on your 
sheet.

Making selections in the 
multi box

You make selections in a multi box in the following way:

1 Clear your selections.

2 Open the field Customer by clicking the arrow.

3 Select Gaston HiTech. 

There are optional values in all the boxes. 

4 Open the field Country by clicking the arrow.

5 Belgium and France are 
optional. The French 
address is the one you 
need: click France.

The requested information 
appears in the remaining fields of 
the multi box.

The properties of the multi box 
can be changed just like those of 
other sheet objects. 

6 Click on the multi box 
with the right mouse but-
ton to open the float menu.

The float menu appearing contains the same commands as that of the list 
box. The commands in the second group (Select Possible etc.) apply to the 
field you have clicked on, while the next three operate on all the fields of the 
multi box. If you click on the title bar of the multi box, the field-specific 
commands are not shown.

7 Choose Properties....

The properties dialog of the multi box contains six pages, which look similar 
to those of the list box.
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Promoting a field
Maybe you would prefer to let the field Zip precede Country.

1 Select Zip in the column of displayed fields.

2 Below the list, there are two buttons: Promote and Demote. Click 
Promote. 

3 Click OK.

The field Zip has been moved one step up in the multi box.

4 Clear your selections.

The table box
The table box is a sheet 
object that shows several 
fields simultaneously. The 
contents are record-oriented 
in the same way as a normal 
table, i.e. the contents of 
one row are logically con-
nected. The columns of the table box can be fetched from different input tables, 
which allows the user to create a new table from the logically possible combinations 
of the input tables.

At the first glance, the table box may look similar to the straight table: both are 
record-oriented, i.e. each row contains a possible combination of data. However, 
there are fundamental differences between the two sheet objects, the most important 
one being that table boxes cannot show calculated values. 

Making selections in a table box
The sheet Geography contains a table box, found below the multi box you 
worked with in the previous section.

Just like the other sheet objects, the table box immediately reflects selections 
made in other sheet objects.

1 Select a few countries in the list box Country and study the result.

You can make selections in a table box by clicking any of the available field 
values or by "painting" an area:

2 Select a range of values in the table box. See how the contents 
change.

3 Clear your selections.
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Creating a table box
1 Go to the sheet Customer.

The sheet contains a multi box with the fields Customer, Address, City, Zip, 
and Country. You will now create a table box with the same fields:

2 Click the Create Table Box button in the toolbar.

3 The General page of the Table Box Properties dialog is 
now open. Enter the text Customer info in the Title box. 

4 Double-click the fields mentioned above to move them to the col-
umn of displayed fields, then click OK.

A table box containing the selected fields now appears on your screen. Size 
it until you see all the columns, and move it to an appropriate position. 

As you see, the field values found in one and the same row are logically con-
nected just like in a straight table. 

Changing properties
Adjusting columns

The columns of the table box can be adjusted just like those of the 
other tables:

1 Place the cursor on one of the vertical lines, then drag. 

To adjust the rightmost column, place the cursor as far to the right as 
you can, but within the border and the scroll bar.

To assign the same size to all the columns, do the following:

Figure 24.  A table box containing the same information as the multi box created in 
the previous lesson.
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2 Click on one of the columns with the right mouse button.

3 Choose Equal Columnwidth from the float menu.

Note The float menu (and the Object menu, which is equivalent to the 
float menu of the currently active object) of the table box has 
different appearances depending on whether you click on the header 
or on a field. Field-specific commands such as Select Possible, 
Sort etc. are either non-existent or dimmed when you click on the 
header of the table box.

Sorting the table box
Just like the straight table, the table box provides excellent possibil-
ities for sorting. 

1 Right-click on the column header of the column Country, 
then choose Sort from the float menu.

Customer is still the first column of the table box, but the values are 
now sorted according to the sort order of the field Country. Note 
how the sort indicator in the table header changed position. Since 
this sheet mainly contains customer information, it makes more 
sense to have the table sorted by customer, though. 

2 Double-click the header of the column Customer.

The table is now again sorted according to the sort order of the field 
Customer.

The sort orders of the different fields can be set on the Sort page of 
the Table Box Properties dialog. Here you can also change the sort 
priority of the columns by means of the Promote and Demote but-
tons.

Printing or exporting a table box
Printing

Suppose you want to print a list of all the French customers.

1 Clear all previous selections by clicking Clear Selections 
in the toolbar.

2 In the Country list box of the Customer sheet, select 
France. The table box now shows all the customers that 
have offices in France.
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3 Click on the table box with the right mouse button, then 
choose Print....

The Print dialog opens. 

4 Click Print....

It is also possible to choose the Print... command from the 
Object menu, from the File menu or from the toolbar.

Exporting
Instead of printing the table box, you can export its contents to a 
file:

1 Click on the table box with the right mouse button, then 
choose Export... from the float menu.

In the dialog that opens, .qvo is preselected as type of file. This is a 
QlikView-specific type, which can be freely associated with any 
program.

2 Type Customers in France.qvo or something similar in the 
File name box.

3 Click Save.

To view the result of your export, do the following:

4 Open the Explorer from your Start menu.

5 Find the file, then double-click it.

6 In the dialog that opens, you can specify the program you 
want to use to open the file. Select e.g. Excel in the list, 
then click OK.

Microsoft Excel now opens your file Customers in France.qvo.

7 Close Excel and go back to QlikView.

Using an input box
Sometimes there is a need to enter data interactively into the QlikView document. 
The data in the fields (list boxes etc.) cannot be changed interactively. However Qlik-
View has something called variables, which can be changed at any time. The typical 
way of entering data in a variable is through the Input Box. 

Entering data in an input box
In this chapter we will use an input box to enter a forecasted sales increase 
and see the result in a chart.
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1 Clear all selections.

2 Go to the Geography sheet. 
There you will find an input 
box. 

3 Move the input box to the Sales sheet by dragging it to the Sales 
sheet tab.

4 Go to the Sales sheet. The input box should now be found on that 
sheet.

5 Restore the chart Forecasted sales next year, which can be found as 
an icon in the bottom of the sheet. Double-click the icon to restore 
it.

This chart shows sales for all years but also has an extra bar to the right 
showing a forecast for the next year. The expression in the chart calculates 
this as sales in the last year increased with a percent factor in a variable 
called Increase. This is the variable which is shown in the input box. It is 
currently set to 10 percent. Since we are optimistic about sales, we will now 
raise the forecast to 20 percent sales increase.

6 Click with the mouse in the area to the right of the "=" in the input 
box. The figure "10" will be marked. You are now in edit mode for 
the input box.

7 Type "20" and press ENTER.

The value of the variable has changed and the chart will be recalculated. You 
can see how the Forecast bar grew higher compared to the bars to the left.
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Input box constraints

In principle variables in input boxes can hold any data. The document designer often 
sets limits to what is allowed to enter. In the example in front of you e.g. a non-
numeric value would not make sense. This input box therefor has a constraint only 
allowing input of numbers between -50 and 50.

1 Click in the input box and enter the value 99.

The input box will not accept this value as it falls outside the set constraints. An error 
message will be shown.

2 Click OK.

You will remain in edit mode in the input box with the old value marked.

3 Type "3" and press ENTER and we are back where we started.

In the next lesson, you’ll get acquainted with the button, the text object and line/
arrow object.

Figure 25.  The Constraints page of the Input box dialog
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Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 8 BUTTONS, TEXT OBJECTS 
AND LINE/ARROW OBJECTS

In this lesson, you will learn how to create buttons and text objects. Buttons are used 
for carrying out commands in an easy way, or for exporting data. Text objects also 
have several areas of document; among other things, you can improve the appearance 
of your document by combining text objects of different colors to form sheet back-
grounds. Line/arrow objects are used to draw lines and arrows to enhance the clarity 
of the document.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file MyTutorial.qvw, then click Open. 

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

You have now opened the document.

The button
Buttons can be used in QlikView to perform commands or actions, e.g. 
exporting data to files or launching other documents. There are three 
types of buttons: the shortcut button, the launch/export button and the 
macro button. Macro buttons are not described in the Tutorial.

Using a shortcut button
All the commands available for a shortcut button can also be performed in 
other ways in QlikView, but it is often very convenient to use a shortcut but-
ton. The Geography sheet contains a shortcut button with the text Clear 
selections.

1 Go to the Geography sheet.

2 Select one or several countries.
working with qlikview 103



3 Find the shortcut button Clear selections in the center of the screen 
and click it.

Your selections have disappeared.

Creating a shortcut button

You will now create a similar shortcut button on the Customer sheet.

1 Click the Create Button icon in the toolbar.

2 On the General page of the Button Properties dialog that appears, 
type the text Clear all selections in the Text box. 

3 Click Shortcut under Function. 

The tabs Launch and Export, which were originally present, have 
been replaced by the Shortcut tab.

4 Click the Shortcut tab.

On the Shortcut page, you can choose the command to be per-
formed, as well as the field on which it should operate. Since the 

Figure 26.  The Shortcut page of the Button Properties dialog
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command that you wish to perform operates on all fields, the con-
tents of the Field box will be disregarded.

5 In the Function box, choose the function Clear all selec-
tions including locked.

6 Click OK.

7 Try your new button.

You can move the button by placing the cursor on it and dragging 
while holding the mouse button down.

Creating an Export button
You have already learned how to export data from a table box. It is also pos-
sible to use a button to export data from specific fields.

1 Go to the Sales sheet.

2 Click the Create Button icon in the toolbar.

3 Type the text Export in the Text box.

4 Launch/Export is preselected under Function. Go to the Export 
page. 

The Fields 
column con-
tains a list of 
all the fields 
in the docu-
ment. By dou-
ble-clicking 
fields in this 
column, you 
add them to the column Export Lines.

5 Add the fields Country, Customer, Salesman, Sales, and Year to the 
column Export Lines. 

6 Click OK.

7 Select a few values, then click the Export button. 

The possible values in the specified fields have been copied to the clipboard. 
To see the result, open e.g. Excel, and click Paste.

Exporting to a file
You can also export the data to a file, like you did with in the table 
box example:
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1 Open the Properties dialog again, and go to the Export 
page.

2 In the group named Export to, select File instead of Clip-
board. 

3 The Export File dialog automatically opens. Find an appro-
priate location, then type a file name with the extension .csv 
(Comma Separated Value) in the File name box, e.g. 
Export.csv.

4 Select Comma Delimited in the text box Save as type.

5 Click Save.

The path to the file appears in the File box on the Export page. 
Every time you click the export button, all combinations of the pos-
sible values of the specified fields will be copied to this file.

Launching the application
If you want the application to be launched as soon as you click the 
export button, you can specify this on the Launch page. 

1 Go to the Launch page.

2 Mark the Application check box, and find the program 
with which you want to open the export file. Choose Excel, 
which should be found under Program Files. 

3 Click Open.

4 Click OK.

Select a few values again, then click the Export button. If everything 
works as it should, Excel will now open the file Export.csv, contain-
ing your exported data.

5 Close Excel.

6 Clear your selections.

The text object
Text objects can be used in several different ways, e.g. for displaying explanatory text 
for the different parts of your document, or for creating multi-colored sheet back-
grounds. In this section, you will do the latter.
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Setting a background color using the sheet properties dia-
log

Your document consists of four sheets: Geography, Customer, Sales, and 
Tables. The sheets all have gray backgrounds. The easiest way of applying a 
different background color to a sheet is the following:

1 Click on the sheet Geography with the right mouse button and 
choose Sheet Properties.... 

2 On the General page select Sheet Settings in the Background 
group, mark the Color check box and press the color button.

3 Pick a navy blue color from the color map, then click OK and close 
the properties dialog.

The Geography sheet now has a navy blue background. Instead of a simple 
color, you can also show a picture. However, the color you set this way will 
always cover the entire sheet.

Setting a background using text objects

Suppose you would like the background of the sheet Customer to have two colors, 
navy blue and gray.

1 Click the Create Text Object button in the design 
toolbar.

The Text Object Properties dialog opens. The upper part of it con-
tains an area in which you can type text. In this case the box should 
remain empty, since we only want color, not text.

Figure 27.  The new background of the sheet Customer
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2 Make sure that the Opaque Fixed option is marked in the 
Background group, then click the Color button.

3 Pick a navy blue color from the map, then click OK and 
close the properties dialog.

There should now be a small navy blue square somewhere on your 
sheet. This is your text object. You can move and size it freely. 

4 Move and size the text object until it covers the upper part 
of the sheet, including the list boxes Customer ID, Country 
and Customer, as well as the multi box Customer info.

If you would like the lower half of the sheet to have a different color 
as well, repeat the procedure described above to create another text 
object with the color of your choice.

Feel free to add colored text objects to the remaining sheets. Make 
sure that the text objects are positioned in the bottom layer (Layout 
page), so that they don’t accidentally obscure other sheet objects. 
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The line/arrow object

Line/arrow objects can be used e.g. for dividing the sheet layout or for pointing out a 
certain sheet object etc. We will use a horizontal line to emphasize the sectioning of 
the sheet established by the text object background we just created.

1 Select the sheet Customer.

2 Click the Create Line/Arrow button in the design toolbar.

The General page of the Line/Arrow Properties dialog appears.

3 Choose Horizontal orientation.

4 Choose a fixed white color.

5 Choose a Line Weight of 5 and a continuous line as Line Style. 

6 Choose line without arrow as Arrow Style.

7 Click OK.

A white horizontal line will now appear on the sheet.

Figure 28.  The line further enhances the division of the sheet.
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8 Move the line with the mouse so that it lies over the border between the two 
background colors.

9 Size the line to the left and to the right so that it covers the entire width of the 
sheet.

Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 9 SLIDER OBJECTS, CURRENT 
SELECTION OBJECTS AND 
BOOKMARK OBJECTS

This lesson features three additional types of sheet objects which can be used to make 
QlikView applications more user friendly. The slider objects offers a graphical way 
of manipulating selections in a field or data in a variable. The current selections box 
and bookmark objects makes it possible to move menu functionality to a more visible 
position in the QlikView layout.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file you worked with in the previous lesson, named 
MyTutorial.qvw or something similar, then click Open.

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

You have now opened the document.

Creating a slider object
The slider objects offer a graphical way of manipulating selections in a field or data 
in a variable. It is a very versatile object but in this lesson we will only demonstrate 
one of its uses by connecting a slider to a field.

1 Go to the Sales sheet.

2 Clear your selections.

3 Click the Create Slider button in the toolbar or choose New Sheet Object, 
Slider... from the Layout menu.

4 The General page of the Slider Properties dialog box now appears. Slider 
objects can be used to control a field or one or two variables. In this example 
we will use it for controlling selections in the field Month.
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5 Choose Month in the Field drop-down box.

6 Choose Multi Value in the Mode group.

7 Click OK.

The slider object appears on your sheet.

8 Select months 7, 8 and 9 in the Months list box. A thumb will appear in the 
slider object.

9 Point at the thumb and drag it. Notice the pop-up showing the months corre-
sponding to the current position of the thumb.

10 Release the mouse button. The selections in the list box will shift in line with 
the slider position.

11 Position the cursor on one of the slider thumb’s short ends. Click and drag. 
The range of selections will narrow or widen accordingly.

12 Release the mouse button and the new selection takes effect.

13 Clear selections. The thumb disappears from the slider object.

14 Click inside the slider area (between the arrows) and paint a selection with 
the mouse. The thumb will reappear.

Using a slider object
The slider objects offer a graphical way of manipulation selections in a field or data 
in a variable. A slider object has the following components:

The exact looks, colors etc of a slider object may vary with object settings.

The slider object may of course, just like any other sheet object, have border and cap-
tion. With the appropriate settings in the Layout page of Slider Object Properties it 
may also be minimized, maximized etc.

Thumb TackSlider Background

Scale Background

Scroll Arrows

Ticks
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The thumb tack shows the value or values currently selected by the slider object. The 
thumb tack can be moved by pointing at it with the mouse and keeping the left mouse 
button depressed while dragging the mouse in either direction. By moving the thumb 
tack you will also move the selection value(s). By pointing the mouse and dragging at 
one of the edges of the thumb tack in a multi-value slider you may expand or limit the 
selection.

When moving or changing the selection with the thumb tack a pop-up window will 
show the current value(s). The new selection will not apply until the slider is 
released.

The selection can be moved one unit up or down by clicking on the scroll arrows or 
by using the arrow keys. The selection can also be moved one width of the thumbtack 
up or down by clicking in the slider background or by using the PAGEDN/PAGEUP 
keys.

If a slider is linked to a field where there is not exactly one selected value (for single 
value mode slider) or exactly one continuous range of selected values (for multi value 
mode slider), no thumb tack will be shown. It is then possible to click a value (single 
value mode) or paint a range (multi value mode) in the slider background. The same 
applies when a slider is linked to a variable without numeric value.

Note Slider objects linked to a field are typically best used without having list 
boxes displaying the same field. As described above the slider thumb tack 
may disappear due to non slider-compatible selections. The best way to 
avoid this problem is to lock the field while keeping the Override Locked 
Field settings for the slider object. This setting will allow the slider object to 
change selections in the field while prohibiting other types of objects to do 
the same. This works also when the user uses the Clear command.

Creating a bookmark object
It is sometimes convenient and user friendly to move the handling of bookmarks 
from menus and toolbar and down to the QlikView layout. This is why we have the 
bookmark object.

In a bookmark object you can select between existing bookmarks in a dropdown list 
and, depending on configuration, add new and delete old bookmarks.

Let’s create a bookmark object:

1 Go to the Sales sheet.

2 Clear your selections.
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3 Click the Create Bookmark object button in the toolbar or choose New 
Sheet Object, Bookmark object... from the Layout menu.

4 The General page of the Bookmark objects Properties dialog box now 
appears. In this case we do not need to change any of the default settings.

5 Click OK.

The bookmark now appears on your sheet.

6 Make a few selections in some list boxes and then click the Add Bookmark 
button.

7 Type a name for the new bookmark in the dialog that appears. Then click 
OK.

8 Clear your selections.

9 Select your bookmark in the dropdown list in the bookmark object.

In the last lesson of this part, you will learn how to change settings on document 
level, how to set user preferences and how to reload data.

Saving, closing and exiting
If you don’t want to return to the next lesson right away, you can close the document. 
You should also save the document, since the following lessons are based on the 
work you have done so far.

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your document. You can now 
close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you can also exit the 
program:

3 Choose Exit from the File menu.
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LESSON 10 DOCUMENT PROPERTIES, 
USER PREFERENCES AND 
RELOAD

In the previous lessons, you have been working with the different sheet objects; 
among other things, you have been changing the appearance and behavior of the 
objects using their respective properties dialogs. In this lesson, which is the final les-
son of the part Working with QlikView, you’ll learn how to change the properties of 
all the objects of the document at the same time.

Furthermore, a dialog containing settings that affect not only the current document, 
but all the work performed in QlikView, will be introduced.

At the end of the lesson, you’ll learn how to update your document, i.e. how to reload 
data from the data sources. 

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file MyTutorial.qvw, then click Open. 

If MyTutorial.qvw is among the most recently used files, you can also open it directly 
from the File menu.

You have now opened the document.

Setting Document Properties
Until now, you have been changing the properties of individual sheet objects. How-
ever, you will often find yourself in a situation where you would like to give the same 
appearance to all the sheet objects of the document or format several fields at the 
same time. This is when the Document Properties dialog is useful. You can also use 
this dialog to attribute an opening sound or an opening picture to your document.
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Setting an opening picture and an opening sound
On the Opening page, you can further improve your document by choosing 
a picture and/or a sound to be shown or played, respectively, when the docu-
ment is opened: 

1 Go to the Opening page that you find in the Document Properties 
in the Settings menu.

2 Select the check box Image. 

3 Select the file Opening.bmp in the dialog that opens, then click 
Open.

4 By check-marking one of the three following options, you decide 
how the picture will be closed. Select Close After 10 Seconds, but 
change the number to 5.

5 Check-mark the option Sound.

6 Select the file tada.wav in the dialog that opens, then click Open.

7 Click OK.

If you have done everything correctly, you will now get a demonstration of 
the opening sound and the opening picture. 

8 Save the document.

Setting properties
Several of the pages in the Document Properties dialog contain settings 
identical with those of the List Box Properties dialog. The difference is that 
when you change the settings in the Document Properties dialog, all the 
sheet objects containing the selected field are affected. The settings are 
either applied immediately (settings on Number, Font, and Layout pages), 
or  when new sheet objects are created (settings on Sort and Presentation 
pages). 
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Sorting all future list boxes containing the field Area

1 Choose Document Properties from the Settings menu.

2 Go to the Sort page.

You recognize the sort options from the List Box Properties dialog. 
The Fields box on the left contains a list of all the fields in the doc-
ument. Here you can select one or several fields to set their sort 
order:

3 Select Area(km.sq). 

You see that the field is sorted by numeric value, descending. Sup-
pose you want the field sorted by numeric value, ascending instead:

4 Select Ascending.

5 Click OK. 

6 Create a new list box containing the field Area and note its 
sort order.

t

Figure 29.  The Sort page of the Document properties dialog.
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Applying the same border to all the sheet objects
The Layout page of the Document Properties dialog is identical 
with the corresponding page in the List Box Properties dialog. 
However, a setting changed here will affect the entire document. Let 
us give objects (except buttons, text objects and line/arrow objects) 
a walled border with slightly rounded corners.

1 Choose Document Properties from the Settings menu.

2 Go to the Layout page.

3 Check Use Borders.

4 Choose the style Walled.

5 Check Rounded Shapes.

6 Make sure that Corner Radius is set to 7 pixels, Square-
ness to 2 and that all four corners are marked.

7 In the Apply to list, select all objects except buttons, text 
objects and line/arrow.

8 Click OK.

The change is implemented throughout the entire document.

9 Save the document.
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User Preferences

The User Preferences dialog, found in the Settings menu, contains a number of set-
tings concerning your way of working with QlikView. Settings changed here remain 
the same regardless of the application you work with. 

Take a few minutes to browse through the settings in the User Preferences dialog.   

For information on the available commands, see the Reference Manual.

Reloading data
The procedure of loading data into QlikView is beyond the scope of this first part of 
the Tutorial. However, even if you will not build your own documents, knowing how 
to reload, i.e. update, the data contained in the document is of great importance. This 
is done in a very easy way:    

Figure 30.  The User Preferences dialog
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1 Click the Reload button in the toolbar (or choose Reload from the 
File menu). 

If the source data has changed, all your sheet objects are instantly updated to reflect 
the changes (in this case, no new data has been added). QlikView thus offers an 
extremely easy way of keeping your document up to date.

You have now come to the end of the part Working with QlikView. If you are going to 
build your own documents, or if you are just curious to find out where the data you 
worked with came from and how the values in the boxes were originally associated, 
you should continue with the following part. 

Saving, closing and exiting
1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

The folder WorkingWithQV contained not only the file 
Tutorial.qvw that you’ve been working with, but also a 
file called TutorialFinal. If you want to, you can open 
this file to compare it with the one you just saved.

If you won’t be working with QlikView for a while, you 
can exit the program:

3 Choose Exit from the File menu.
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• Concatenating tables
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Introduction

In the previous part of the Tutorial, you learned how to work with an existing appli-
cation. The document already contained data in the form of fields, which you dis-
played in list boxes and other sheet objects. In this part, you will learn how to create a 
QlikView document from scratch. Loading data and associating data tables are two of 
the main topics to be treated. Like in the previous part, there will be a step-by-step 
presentation of the procedures. 

The files used in this part are found in the ..Tutorial\Application\Examples directory. 
The sample represents a customer database of a fictive company.

Note that new documents can only be created if you are using QlikView Enterprise.
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LOADING DATA INTO QLIKVIEW
LESSON 11 LOADING DATA INTO 
QLIKVIEW

A QlikView document is created by retrieving data from a source, e.g. from a rela-
tional database or from text files containing data tables. This retrieval is done by writ-
ing and executing a script, in which the database, the tables and the fields to be 
retrieved are specified. The script can be generated automatically with the tools 
included in QlikView. Note that QlikView in itself is not a database; it is thus not pos-
sible to add new data to a database or alter data in a database with QlikView.

In this lesson, you’ll create a simple document consisting of one data table.

Figure 31.  Data can be imported from typed files, or from databases via the ODBC 
or OLEDB interface. The imported data, together with the made layout, can be saved 
as a QlikView document.

  Text file  Database

   Script

Select Load

Open

Save
QlikView file
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Looking at a delimited text file

The simplest way to store a data table is in a text file. In this type of file, each record 
is represented by a row, and the fields (columns) are separated by characters, e.g. 
commas (or semicolons, tabs, etc.). Field names are preferably stored in the first row. 
The type of file that will be used in the examples is the csv (comma separated value) 
file, which uses comma as delimiter. You’ll start by looking at a csv file in a text edi-
tor:

1 Start a text editor, e.g. Notepad (found in the Windows Accessories group).

2 Open the file Country1.csv from the ..\TutorialFiles\Application\Examples 
directory (choose All Files in the Files of Type box). 

It should look similar to the file in Figure 32. The contents of the file are logically a 
table, where each row, or record, describes a country and its properties. The columns 
are separated by commas, and the first line contains the column (field) names.

3 Close the text editor.

Figure 32.  One representation of a table - a comma separated file viewed in a simple 
text editor.
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Comma separated value files and text files with other delimiters, such as tab or semi-
colon, can often be imported to, and exported from, spreadsheet programs. In such a 
program (e.g. Excel) the same file looks like the one in Figure 33. If you have a 
spreadsheet program, it might be easier to work in this than in a text editor when cre-
ating the tables. 

Note QlikView treats Excel files (.xls) in the same way as text files, which means 
that you can load them directly into the script without saving them in another 
format.

Loading the text file
The first thing to do when loading the file into QlikView is to create an empty docu-
ment.

1 Start QlikView (see the Basics chapter if you have forgotten).

2 Choose New from the File menu or from the toolbar.

The next thing to do is to create a script that specifies the files to load:

3 Choose Edit Script from the File menu or from the toolbar. 

Figure 33.  The comma separated file viewed in a spreadsheet program.
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The Edit Script dialog now opens. It is in this dialog that the script will be created. A 
number of rows starting with SET have already been generated in the script pane to 
the upper right. You will learn about their meaning later (Advanced Features 
page 209). Each statement is represented by a box in the statement graph pane to the 
left.

At the bottom of the dialog you will find a row of tabs containing functions for script 
generation. 

4 Choose Table Files on the Data tab. This opens the Open Local Files dialog 
box, in which you can browse for the file you wish to load. Make sure that 
the control Files of Type is set to Table Files.

Figure 34.  The Edit Script dialog
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5 Find the file Country1.csv (the one you opened in the text editor before), 
select it and choose Open. The file is now opened in the file wizard, which 
interprets the contents of the file and helps you to load the data into the script 
in a correct way. In the file wizard, your file looks like in Figure 35 below.

The file wizard interprets the file to be a comma separated (delimited) file using the 
ANSI character set. This is a correct interpretation. Furthermore, the file is said to 
have embedded labels, which means that the first row contains field names. When 
studying the text box at the bottom of the wizard, you see that this is also correct: 
Country, Capital etc., marked gray, are indeed field names. Finally, the wizard states 
that the header size is 0 characters, which means that the file contains no initial infor-
mation to be omitted.   

6 Since the program has made a correct interpretation of the file, you can click 
Finish. 

7 A script similar to the one below has been generated in the Edit Script dia-
log:

Figure 35.  Interpretation of the file Country1.csv in the file wizard
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Load Country,
Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country] 

from c:\qlikview\tutorialfiles\
application\examples\country1.csv 
(ansi, txt, delimiter is ',', embedded labels);

Study the script. Note that the words set, load and from are highlighted. This means 
that they are keywords, i.e. have a special meaning in the QlikView script. You can 
change the colors by choosing Configure from the Settings menu (of the Edit Script 
dialog). For further details, see the Reference Manual.

After load, the fields of the selected file are listed. Some of the field names are 
enclosed by square brackets; this is necessary when a field name contains spaces. The 
word from is followed by the path to the file (C:\program files\QlikView\...) and the 
file name, Country1.csv. The path may be different from the one shown here if you 
installed QlikView and the tutorial files in another directory. The final parenthesis 
contains additional information about the file, specifying that ANSI is the character 
set used (standard for Windows files), that the file is a text file, that the character sep-
arating the field values is a comma, that the first row of the file contains field names. 
You recognize the terms from the file wizard.

Note The type of path used here, beginning with c:\ or some other character 
specifying a hard disk, is called absolute. An absolute path gives an exact 
specification of the location of the file. However, in case you move the file to 
another location (e.g. to a user directory or to another hard disk), the 
program will no longer be able to find the file and run the script. To prevent 
this, you can mark the check box Relative Paths in the Edit Script dialog. 
This should be done before loading the file, but it is also possible to delete 
the path directly in the script. When using relative paths, QlikView will look 
for files relative to the directory where the current QlikView document is 
stored. A statement using a relative path is preceded by a directory 
statement in the QlikView script. Learn more about the directory statement 
in the Reference Manual. 

8 Choose Run. The data is now loaded into QlikView, and a dialog box 
in which it is possible to select the fields to be displayed (Figure 36) is 
opened.
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9 Select the fields Area (km.sq.), Capital, Currency and Population(mio) by 
CTRL-clicking their names, then choose Add> to include them in the list of 
displayed fields. Another possibility is to double-click the field names. This 
will immediately put them in the list of displayed fields. The field names 
starting by "$" are system fields (they are only shown if the check box Show 
System Fields is selected). You’ll learn about them later (page 171).

10 Choose OK to close the dialog. All the fields in the column Displayed 
Fields will be displayed as list boxes on the active QlikView sheet. 

If you want to add or remove fields, you can open the Sheet Properties dialog again 
at any time. This is done by clicking on the sheet with the right mouse button and 
choosing Properties from the float menu.

If you have followed all the steps correctly, you should now have a display similar to 
that in Figure 37. This document is ready to be used, although the layout can be 
improved. 

Figure 36.  The Fields page in the Sheet Properties dialog. Here you select 
the fields to display on the current sheet.
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11 Click on a capital, and you will find e.g. the currency used in that city. 

Note Note that all the information refers to the countries, since every record in the 
table that was loaded represents a country. Thus, clicking on Paris does not 
mean that you get the population of Paris. It is still the population of France 
that is shown.

12 Clear your selections.

You have created a simple QlikView document, consisting of a single table. In the 
next lesson, you’ll add two more tables and learn about QlikView’s powerful capabil-
ity of associating tables.

Figure 37.  A simple QlikView document
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Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save As from the File menu to save the 
document.

2 Find an appropriate location for the file: we 
suggest ...Tutorial\Application.

3 Type Application.qvw or something similar in 
the File name box, then click Save.

QlikView saves the file using the new name. You can 
now close the file:

4 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

5 Choose Exit from the File menu.
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LESSON 12 ASSOCIATING DATA FROM 
MANY TABLES

In the previous lesson, you created a basic document by loading one table into Qlik-
View. However, what you usually want to do is to load and associate data from a 
great number of tables. In this lesson you’ll be familiarized with QlikView’s way of  
automatically associating related tables. You’ll also learn how to rename fields in 
order to assure or prevent associations. 

Associations
If you have two tables listing different things, e.g. if  you have one list of customers 
and one list of invoices, and the two tables have a field (column) in common, e.g. the 
customer number, this usually means that there is a relationship between the two 
tables. 

If such a relationship exists, associations are made between the fields that are com-
mon to the tables: QlikView assumes that the two fields are one and the same thing, 
and the two fields are treated as one. Such a field connecting two or more tables is 
called a key.

There are two basic rules for associations:

• For two fields to be associated, they need to have the exact same name (case 
sensitive). Thus, e.g., Name and name are not the same and are not associ-
ated. 

• If a certain field has the exact same value in several different input tables, 
QlikView will treat it as one value and also assume that the records (rows) 
containing the value should be associated. For two field values to be associ-
ated, they either need to

– have exactly the same spelling (case sensitive), or

– have exactly the same numeric value

Thus: Name and name are not the same and are not associated. The numbers 123 and 
00123 are the same and are associated.
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For a further illustration of the basic rules, study the following example:

The fields named Number are assumed to be one and the same according to the first 
rule. Table 1 and Table 2 are associated via this field. Table 1 and Table 3 are associ-
ated in the same way via the field Name.

The field Number has the value 2 in both Table 1 and Table 2, which means that Phil 
is assumed to be associated with the age 42.

The value 2 in Table 1 is associated with the value ab in the field ID in Table 3 via the 
value Phil of the field Name. John in Table 1, however, is not the same as john in 
Table 3, so there will be no association.

An association thus means that links are built between the fields in the tables, so that 
logical connections can be studied. This way several tables from one or several data-
bases can be included in the QlikView logic simultaneously. 

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

Figure 38.  

Figure 39.  

Table 1: Table 2: Table 3:

Name Number Number Age Name ID

John 1
Phil 2
Betty 5

 3
 4
 2

28
35
42

Phil
John

ab
xy

Table 1: Table 2: Table 3:

Name Number Number Age Name ID

John 1
Phil 2
Betty 5

 3
 4
 2

28
35
42

Phil
john

ab
xy
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1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file created in the previous lesson (Application.qvw or something 
similar), then click Open. 

Loading and associating a second table
Your document contains a table with country-specific information. In this lesson, 
you’ll load an additional table representing a list of customers. The country table and 
the customer table will be associated through the common field Country. The cus-
tomers being registered in different countries, the relation between country properties 
and customer can be studied as a result of the association.

The new table is found in an Excel file, but you can load it in the same easy way as a 
text file.

1 Choose Edit Script from the File menu or from the toolbar.

2 Place the cursor at the end of the script.

3 Choose Table files.

4 Select Customer.xls from the ...Tutorial\Application\Examples directory and 
choose Open. This opens the file wizard (Figure 35 on page 129).

5 Note that Excel is set as type this time, and that the Table box contains the 
name of the worksheet. This Excel document contains only one worksheet; if 
there had been several sheets or named tables, the Table box would have 
given you the possibility of choosing from which one of them data should be 
retrieved. Click Finish. Your script will now look similar to the one below 
(to improve clarity, we will from now on show relative paths, since the direc-
tory will stay the same): 
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Load Country,
Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country]

from country1.csv (ansi, txt, delimiter is 
',',embedded labels);
Load [Customer ID],

Customer,
Address,
City,
Zip,
Country

from customer.xls (ansi, biff, embedded labels, table 
is [Customer$]);

Study the script. You see that both Country1.csv and Customer.xls contain a field 
named Country. According to the association rules described above, QlikView will 
associate the two tables via this field.

6 Choose Run.

7 The dialog in which you choose the fields to display now appears. All fields, 
except the field Country from the file Customer.xls have been added to the 
column of available fields. The field Country is shown in the list of dis-
played fields. The field Country has been associated with the previously 
loaded fields with the same fieldname.

8 Add the field Customer to the column of displayed fields. 

9 Choose OK.

10 Save your document.

It is now possible to click on a capital and find the customers that reside in the 
country of this capital; at the same time, they are found in the customer register. This 
is possible although the fields Customer and Capital are found in different tables. 
The only prerequisite is that there is a field, Country, common to both tables.  

11 Click Alma-Ata, the capital of Kazakstan, and note that the fictive company 
has two customers in Kazakstan.

12 Clear your selections.
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You have now built a simple QlikView document containing data from two tables. 
Several tables can be linked (associated) this way, which makes it possible to study 
complex relationships in data from many tables. 

Renaming fields
In the previous section, you learned that associations between tables are made via 
fields that are common to the tables, so called keys. As we have seen, the criterion for 
two fields to be associated (to be treated as one and the same field) is that they have 
the same name. It thus becomes clear that field names are of great importance, and 
that the renaming of fields is a common procedure when building the QlikView data 
structure: in real life, fields that should be associated do not always have exactly the 
same name in different tables.

The directory contains additional files (tables) that are relevant to your document. 
Suppose you want to associate the file Transact.csv, a file containing information 
about transactions, sales, etc. concerning the customers in the document: 

1 Choose Edit Script from the File menu or from the toolbar.

2 Place the cursor at the end of the script.

3 Choose Table Files.

4 Select Transact.csv and choose Open. This opens the file wizard (Figure 35 
on page 129).

5 Make sure that Delimited is set as type, Comma as delimiter and that the 
check box Embedded Labels is selected.  

Until now, you have only accepted the settings proposed to you by the file wizard. 
Now we will make use of some of the possibilities to change the way QlikView reads 
the data files.

In the file Customer.xls  that we loaded before, there was a field named Customer ID. 
Note that the new file contains a field named ID Customer. These two fields should 
be associated, i.e. treated as one. To make this happen, however, you need to rename 
one of the fields.

6 The file wizard provides excellent possibilities for renaming fields. Simply 
click in the table header of ID Customer, then type the new name, Customer 
ID. Make sure not to forget the space between the words: any misspelling 
prevents QlikView from interpreting the fields as being one and the same. 

7 Press ENTER. The name of the field has been changed.

8 Click Finish.
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The automatically generated script looks similar to the one below:
Load Country,

Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country]

from country1.csv (ansi, txt, delimiter is ',',  
embedded labels);

Load [Customer ID],
Customer,
Address,
City,
Zip,
Country,

from customer.xls (ansi, biff, embedded labels, table 
is [Customer$]);

Load  [Transaction ID],
Year,
Month,
Day,
[Salesman ID],
[Product ID],
[SerialNo],
[ID Customer] as [Customer ID],
[List Price],
Sales,
[Gross Margin] 

from transact.csv (ansi, txt, delimiter is ',', 
embedded labels);

Note the line [ID Customer] as [Customer ID]: it has appeared as a result of the 
change you made in the file wizard, and means that the field ID Customer will be 
loaded into QlikView with the name Customer ID (thus assuring the necessary asso-
ciation).

9 Choose Run.

10 The Fields page of the Sheet Properties dialog appears. Add a field from 
the file Transact.csv to the column of displayed fields, e.g. Sales.

11 Click OK. 
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12  Save your document.

Three different tables have been loaded, containing information about coun-
tries, customers and transactions, respectively. By associating the tables in the way 
described, QlikView allows you to find all the relevant information from all the 
tables at the same time - by means of a single click.  

13 Select Finland in the list box Country. The program immediately provides 
the geographical data stored in the country tables - but also displays the 
names of the customers residing in Finland, as well as the sales values 
related to them.

14 Clear your selections.

Note It is easy to associate tables in QlikView, and it is possible to link fields and 
tables that should not be linked. If this is done, QlikView will not give you 
relevant answers. Think carefully before assigning field names to fields of 
different tables, thereby defining the associations.

You should now have acquired some basic knowledge about loading and associating 
tables. In the following lesson, you’ll learn how to merge tables containing the same 
type of information. 

Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the document. You should also save the 
document, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your docu-
ment. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 13 CONCATENATING TABLES
In the previous lessons, you learned to load data into QlikView and to associate dif-
ferent tables having fields in common. However, instead of being associated, tables 
can also be merged. If two input tables are lists of the same thing, but contain differ-
ent values, e.g. if one is a list of countries in Europe and the other one a list of coun-
tries in North and South America, the second table can be seen as a continuation of 
the first. The tables should then be concatenated. 

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file Application.qvw, then click Open. 

Automatic concatenation
If two tables that have exactly the same set of fields are entered, QlikView automati-
cally treats the second table as a continuation of the first. This is called concatenation 
of tables. 

Any number of tables can be concatenated into one table.

Your QlikView document retrieved data from a file with a limited number of coun-
tries. The ...Tutorial\Application\Examples directory contains a second file listing 
countries, whose field names correspond exactly to those of the already loaded 
Country1.csv. When you load the second file, the two tables will be automatically 
concatenated.

1 Choose Edit Script from the File menu or from the toolbar.
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2 Position the cursor after 
the load statement loading 
the file Country1.csv (all 
statements end with a 
semicolon) and press 
ENTER to get an empty 
row. The order of the load 
statements is arbitrary, but 
you get a better overview 
of your script by keeping 
the country files together.

3 Click Table Files.

4 Select Country2.csv, then choose Open. This opens the file wizard 
(Figure 35 on page 129).

5 Make sure that Delimited is set as type, Comma as delimiter and that the 
check box Embedded Labels is selected.

6 You don’t need to rename any fields this time, so click Finish. You should 
now have a script similar to the following: 
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Load  Country,
Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country]

from country1.csv (ansi, txt, delimiter is ',', 
embedded labels);
Load Country,

Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country]

from country2.csv (ansi, txt, delimiter is ',', 
embedded labels);
Load [Customer ID],

Customer,
Address,
City,
Zip,
Country,

from customer.xls (ansi, biff, embedded labels, 
table is [Customer$]);
Load [Transaction ID],

Year,
Month,
Day,
[Salesman ID],
[Product ID],
[Serial No],
[ID Customer] as [Customer ID],
[List Price],
Sales,
Gross Margin 

from transact.csv (ansi, txt, delimiter is ',',
embedded labels);

Note that the sets of fields in Country1.csv and Country2.csv are exactly the same. 
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7 Choose Run. The Fields page in the Sheet Properties dialog box (Figure 36 
on page 131) is opened. The fields you selected last time are already in the 
column of displayed fields. No new fields have appeared in the list of avail-
able fields, since the field values of Country2.csv have been added to the 
corresponding fields of Country1.csv.  

8 Choose OK to close the dialog.

At a first glance, your document will look very much like it did before; however, 
there are more entries in most list boxes. Some list boxes may have become wider or 
obtained scroll bars due to longer field contents.

9 Save your document.

Forced concatenation
Sometimes you want to concatenate tables also when they have different sets of 
fields. QlikView will then not automatically concatenate the two tables: you need to 
use the concatenate statement, which concatenates a table with the last created logi-
cal table.

In the previous section two tables with identical sets of fields, Country1.csv and 
Country2.csv, were concatenated. There is also a third file, Country3.csv, that con-
tains only a subset of the fields. All three files are lists of countries. Furthermore, 
they contain different countries, so it is certainly relevant to concatenate the three 
files into one logical table.  

The values of the missing fields in the concatenated table will be NULL, i.e. Qlik-
View will treat these fields as having no value. 

Do the following:

1 Choose Edit Script from the File menu or from the toolbar.

2 Position the cursor after the statement loading Country2.csv. This 
time the order of the statements is not arbitrary, since the concatenate state-
ment forces concatenation with the last created logical table in the script.  

3 Choose Table Files.

4 Select country3.csv and choose Open. This opens the file wizard (Figure 35 
on page 129).

5 Make sure that the wizard has made a correct interpretation, then click Fin-
ish. This generates a script similar to the one below:
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Load Country,
Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country] 

from country1.csv (ansi, txt, delimiter is ',', 
embedded labels);
Load Country,

Capital,
[Area(km.sq)],
[Population(mio)],
[Pop. Growth],
Currency,
Inflation,
[Official name of Country]

from country2.csv (ansi, txt, delimiter is ',', 
embedded labels);
Load Country,

[Official name of Country],
[Area(km.sq)]

from country3.csv (ansi, txt, delimiter is ',', 
embedded labels);
Load [Customer ID],

Customer,
Address,
City,
Zip,
Country,

from customer.xls (ansi, biff, embedded labels, table 
is [Customer$]);
Load [Transaction ID],

Year,
Month,
Day,
[Salesman ID],
[Product ID],
[Serial No],
[ID Customer] as [Customer ID],
[List Price],
Sales,
Gross Margin 

from transact.csv (ansi, txt, delimiter is ',', 
embedded labels);
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Study the script. The three fields in the file Country3.csv are all found in  
Country1.csv, which constitutes the last created logical table. However, since the set 
of fields is not exactly the same, you need to add the word concatenate for the tables 
to be merged:

6 Position the cursor in front of the load statement that loads Country3.csv and 
type Concatenate. If the spelling is correct, the word concatenate will turn 
blue just like load and from etc., since it is also a keyword. Make sure there 
is a space between the two words:

...
Concatenate Load Country,

Official name of Country],
[Area(km.sq)],

from country3.csv (ansi, txt, delimiter is ',', 
embedded labels);
...

7 Choose Run. 

Your application should not have changed very much. There are, however, a few 
more countries. 

8 Click the OK button.

9 Select the country Seychelles. 

Seychelles is a country that is listed in the third file, and you can now see that only 
the list box Area contains optional data. 

10 Clear your selections.

11 To get a clear picture of the contents of the concatenated table, create a table 
box containing the fields of the country files, i.e. Country, Capital, Area 
(km.sq), Population(mio), Pop.Growth, Currency, Inflation, Official name of 
Country.  

12 Use the scroll bar to browse through the data of your table box. You’ll note 
that some of the rows are not complete, but contain a ’-’ instead of a value. 
This is the case for all the countries from the third country file, containing 
only a subset of the fields: the values of the missing fields are treated as 
NULL. 

Three logical tables have been loaded so far:

Country1 (concatenation of Country1, Country2 and Country3) is a table listing 
countries. Each row contains information concerning a specific country.
148



CONCATENATING TABLES
Customer is a table listing customers. Each row contains information concerning a 
specific customer. This table is associated to the table above through the field Coun-
try, which is found in both tables.

Transact is a table listing transactions. Each row contains information concerning 
one sold unit. This table is associated to the table above through the field Custom-
erID, which is found in both tables.

When a selection is made in one of the tables, QlikView analyzes how the result of 
the selection affects the next logical table. When this table is analyzed, QlikView 
continues with the next logical table, etc.: the result of the selection propagates 
through the chain of tables involved.

Note Structures with circular references, i.e. when the chain becomes a ring, 
should usually be avoided. These are sometimes a sign of an incorrect data 
model, in which two similar fields that have slightly different interpretations 
are treated as one and the same field. If QlikView discovers the circular 
reference during the execution of the script, the tables will be set to loosely 
coupled. For further information, see the Reference Manual.

Using the Table Viewer
The tables and their associations can be shown graphically in the built-in Table 
Viewer.

1 Choose Table Viewer from the File menu.

Figure 40.  The associations made in the example that loads the tables Country1, 
Customer and Transact
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The three tables loaded so far will appear. Each association is shown with a line con-
necting the associated fields in the respective tables.

2 Click on the header of the table Country1. All tables directly associated with 
this table (only one actually) will be highlighted.

3 Click on the field Customer ID in one of the tables where it appears. Notice 
that the field name will be highlighted in all tables where it appears.

As you get more complex table structures it may be useful to know that the tables can 
be moved over the background using the mouse. The same goes for the connector 
points on the lines connecting the tables.

The table view can be copied to the clipboard for inclusion in documentation or 
printed with the help of toolbar buttons available.

4 Close the Table Viewer by clicking OK.

The logical structure can also be studied by looking at the system fields. The part 
Advanced Features provides a lesson in which you can further analyze the structure 
of your application. See page 172.

Improving the layout
This part of the Tutorial being devoted to the creation of scripts, we have neglected 
the layout so far. However, creating a layout that is easy to work with and that pro-
vides a good overview of the information is extremely important in order to fully uti-
lize the possibilities of QlikView.

Having data from three different domains at your disposal, you could create a layout 
with three different sheets, named Geography, Customer and Sales or something sim-
ilar. Add list boxes and other sheet objects, move them and size them until you have 
an application that is easy to work with. If there are steps you don’t remember, go 
back to the first part of the Tutorial, Working with QlikView, to get help. 
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Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the application. You should also save the 
application, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your appli-
cation. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
creating a document 151



152



LINKING EXTERNAL INFORMATION TO A DOCUMENT
LESSON 14 LINKING EXTERNAL 
INFORMATION TO A 
DOCUMENT

Besides associating and concatenating tables that contain data, it is also possible to 
link information to field values in the data. The links are defined in information 
tables which must be loaded in a special way. In this lesson you’ll link flags to spe-
cific values in the Country list box.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file Application.qvw, then click Open. 

Looking at an info file
Let’s start by looking at the file containing the information to link.

1 Open a text editor, e.g. Notepad, and choose Open from the File menu.

2 In the box Files of type, select All files.
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3 Open the file Flagsoecd.csv in the ...\Tutorial\Application\Examples direc-
tory. It should look like Figure 41.

It is a two-column table, in which different values of the field Country are associated 
with different files. Each value must be put on a separate row. The file associated 
with a field value will be shown, played, executed, etc. depending on the file type. 
Some file types, e.g. files of the bmp (images) or wav (sounds) type are handled 
internally in QlikView. For other file types, the associated program is used to open 
the document. 

Note To associate a file type (with no association) with a program, open the 
Explorer (for Windows 98, Windows NT, Windows 2000 and Windows XP). 
Select a file of the concerned type in the structure and double-click it. This 
opens a list of available programs. Pick an appropriate program, preferably 
Notepad or Excel, then click OK. All files with this extension will from now 
on be opened with the program you selected. (Another possibility is to 
choose View, Folder Options from the Explorer menu and go to the File 
Types page.)

4 Close the editor.

Loading the info file
The next step is to load the info file into QlikView.

1 Choose Edit Script, and click Table Files.

2 Select the file Flagsoecd.csv and click Open. This opens the file wizard.

Figure 41.  An information table defining that the specified bmp files should be linked 
to the listed country values.
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3 Like for the files already loaded, Delimited is set as type, Comma as delim-
iter. Embedded Labels is selected as label.

4 Click Finish.

The statement generated will load the file Flagsoecd.csv as a regular data file. How-
ever, this is not what you want to do: you would like QlikView to use Flagsoecd.csv 
to link information to specific field values. This is done in the following way:

5 Change the script by manually adding the word info before the load state-
ment. The word info being a keyword in the script, it will turn blue. The 
script should look similar to the following:

...
Load [Transaction ID],

Year,
Month,
Day,
[Salesman ID],
[Product ID],
[Serial No],
[ID Customer] as [Customer ID],
[List Price],
Sales,
Gross Margin 

from transact.csv (ansi, txt, delimiter is ',', 
embedded labels);

Info Load Country,
I

from flagsoecd.csv (ansi, txt, delimiter is ',', 
embedded labels);

6 Choose Run.

7 The Fields page is opened. No new fields have been added. Click OK. 

8 Save your application.

Viewing the linked information
To view the information you’ve linked, do the following:

1 Select Germany from the list of countries.

2 A small info symbol appears in the upper right-hand cor-
ner of the list box. Click it. 

An independent window containing Germany’s flag now appears 
in the application.
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3 Close the window..

4 Select France from the list of countries.

5 Click the info symbol to make the specified picture appear 
(Figure 42).

6 Close the flag and clear all selections.

This way, pictures and multimedia presentations can be shown in the right contexts, 
other applications can be started, and specific documents opened. You can link 
almost any type of file to field values. It is also possible to simply type words in the 
second field of the info table instead of specifying a path to a file. In that case, Qlik-
View will show the text in an internal text viewer. 

To learn more about creating and viewing info files, see the Reference Manual.

Embedding external info
In many cases it is good that pictures etc. do not have to be stored inside a QlikView 
document and take up space in memory and on disk. However, if you want to be able 

Figure 42.  The French flag associated with the field value France
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to send a QlikView document to other people without worrying about sending the 
picture files as well, there is an option to embed the info in the QlikView file.

1 Choose Edit Script again.

2 Find the statement which starts by info load.

3 Precede that statement with the word bundle, so that it now starts bundle 
info load.

4 Run the script.

The flag pictures are now stored inside the QlikView document itself and do not need 
to be moved with the QlikView document.

Until now, you have only worked with comma separated text files and an Excel file, 
which you’ve been able to load directly into QlikView. In the next lesson, you’ll get 
to know other types of files, and you’ll also learn how to load files via ODBC.

Saving, closing and exiting
If you don’t want to turn to the next lesson right away, 
you can close the application. You should also save the 
application, since the following lessons are based on the 
work you’ve done so far. 

1 Choose Save from the File menu.

QlikView saves the changes you’ve made to your appli-
cation. You can now close the file:

2 Choose Close from the File menu.

If you won’t be working with QlikView for a while, you 
can also exit the program:

3 Choose Exit from the File menu.
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LESSON 15 LOADING ADDITIONAL FILES
All the files you’ve loaded so far have been text files or Excel files containing field 
names in the first row. In this lesson, you’ll learn how to load a tab separated text file 
without field names. Moreover, you’ll get an introduction to loading files via the 
ODBC interface.

Opening the document
If you closed the document and exited QlikView after the previous lesson, you need 
to open it again.

1 Start QlikView by double-clicking the QlikView icon (for other ways 
of starting the program see page 17).

2 Choose Open from the File menu.

3 Select the file Application.qvw, then click Open. 
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Loading a tab separated file without labels

The ...\TutorialFiles\Application\Examples directory contains a file with information 
on the markets to which the different countries belong. Just like the files you’ve 
loaded so far, Markets.tab is a text file; however, instead of being separated by com-
mas, its field values are tab delimited. Furthermore, the file does not contain any 
labels (field names). The loading procedure is similar to the one you’ve encountered 
in the previous lessons:

1 Go to the Sales sheet.

2 Choose Edit Script from the File menu or from the toolbar.

3 Position the cursor at the end of the script.

4 Click Table Files.

5 Select Markets.tab, then choose Open. This opens the Table wizard (see 
above).

6 Delimited is still set as type, but this time Tab is selected as delimiter. Fur-
thermore, Labels should be set to None because the first row contains ordi-
nary field values, not field names. Change Labels to None in the drop-down 
list if does not already have this setting.

Figure 43.  The interpretation of the file markets.tab in the file wizard.
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For QlikView to find relations between the new file and those that have already been 
loaded,  you need to give the fields appropriate names. Naming the first field Market 
seems like a good choice; the second one should be named Country to be associated 
with the Country fields of the files Country1.csv and Customer.xls. This is done in 
the following way:

7 Click in the header of the first column where it says @1. Type Market and 
press ENTER. Click in the header of the second column where it says @2. 
Type Country and press ENTER

8 Click Finish. Your script now looks similar to the one below:
...

Info Load Country,
I

from infofile.csv (ansi, txt, delimiter is ',', 
embedded labels);
Load @1 as Market,

@2 as Country
from markets.tab (ansi, txt, delimiter is '\t', no 
labels);

Study the script. Note the contents of the final parenthesis: the delimiter is not 
comma (','), but tab ('\t'), and the text no labels appears instead of the usual embed-
ded labels.

9 Click Run to execute the script.

10 Move the new field Market to the column of displayed fields, then click OK. 

If you have followed all the steps correctly, you can now study the sales development 
for different markets during different years.

Loading a file via ODBC
Until now you have always loaded files directly into QlikView. However, if you want 
to access general databases or files that are not stored in a format that QlikView can 
read, you need to use the ODBC (Open DataBase Connectivity) interface. 

To follow this example, you need to have ODBC installed. If you do not, read the 
information on installing ODBC in the Reference Manual.

In the ...Tutorial\Application\Examples directory you’ll find an Access file named 
Salesman.mdb, which contains the names of the salesmen who performed the sales 
described in the file Transact.csv. The names of the salesmen are of great importance 
to you, so you would like to associate Salesman.mdb to the existing data of your 
application. 
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One possible way of doing this is to simply save the file as a character separated text 
file, i.e. a file that QlikView can read.

However, it is also possible to load the file via ODBC, which is what you’ll do in this 
example. 

1 Open the Edit Script dialog.

2 Instead of clicking Table Files, you must now click the Connect button to 
establish a connection with the data source.

3 The Data Link Properties dialog opens. Make sure that the OLE DB Pro-
vider for ODBC Drivers is selected, then click Next to get to the Connection 
page.

4 Since you are working with a generic data source not yet defined, select the 
option Use connection string, then click the Build button.

5 Go to the tab Machine Data Source.

6 Select MS Access Database, then click OK.

7 From the Login dialog that opens, click the Database... button.

8 Browse for the file. Once you find the correct location, the salesman file 
should be the only one available in the left list. Select it, then click OK to 
close the dialog.

9 Click OK to close the remaining dialogs.

Your script now contains a connect statement, connecting you to the selected data 
source. The next step is to select the tables (in this case there is only one, but if you 
access a database you usually have a great number of tables to choose from) and 
fields to load:
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10 Click the Select button.

The Create Select Statement dialog is now opened. The Fields box lists the avail-
able fields, whereas the Database Tables box contains the available tables. At the 
bottom of the dialog, you get a preview of the statement (a standard SQL select 
statement, which will appear in your script as soon as you click OK). 

By default, a star is selected in the SELECT group. The star is equivalent to all fields. 
You want to load all fields, but for consistency reasons you’ll select them to make 
their names appear in the script:

11 Click on the field Salesman ID, then press the SHIFT key and hold it down 
while clicking the last field name. Verify that all the fields are selected by 
studying the preview.

12 Click OK. Your script should now look similar to the following:

Figure 44.  The Create Select Statement dialog.
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...
Load @1 as Market,

@2 as Country
from markets.tab (ansi, txt, delimiter is '\t', no 
labels);
CONNECT TO 'MS Access Database;
DBQ=c:\QlikView\TutorialFiles\Application\       
Examples\SALESMAN.mdb;';
SQL SELECT `Salesman ID`, Salesman, `Distributor ID` 
FROM SALESMAN;

The salesman table is associated with the existing data via the field Salesman ID, 
which it has in common with Transact.csv. 

13 Click Run.

14 Add the new field Salesman to the Sales sheet and study the relations by 
making a few selections.

15 Clear your selections.

You have now finished the second part of the Tutorial. In addition to the basic knowl-
edge about selections, sheets and sheet objects acquired in the first part (Working with 
QlikView), you have learned how different kinds of files are loaded into the associa-
tive QlikView database and how the logical structure is created.  

The final part of the Tutorial, Advanced Features, lets you further explore the possi-
bilities of QlikView. It differs from the first two parts in that it contains independent 
lessons (i.e. the procedures performed are not based on the work done in previous les-
sons), thereby allowing you to immediately go to the lesson that interests you the 
most.
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Saving, closing and exiting
Unless you wish to go on with the next part right away, 
you can now close the application.

1 Choose Close from the File menu.

QlikView issues a message asking you if you want to 
save the changes. Click Yes.

2 If you wish, you can open the file Application-
Final found in the Application folder to com-
pare this file withw the one you’ve created.

If you won’t be working with QlikView for a while, you 
can exit the program:

3 Choose Exit from the File menu.
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• More about associations

• Field groups and cyclic display in charts

• Cross tables

• And-mode

• Semantic links

• Number format

• Access restriction



168



Introduction

This final part of the Tutorial deepens the knowledge you’ve already acquired and 
lets you further explore the possibilities of QlikView. Among other things, you’ll 
learn how to modify the script to load different types of table formats in an optimal 
way, how to create semantic links and how to use access restriction. Moreover, 
Advanced Features provides a chapter on the interpretation and formatting of num-
bers. Although most of the functions presented are related to the script, we have also 
devoted a chapter to advanced layout features: you’ll learn to create hierarchic and 
cyclic field groups and to use cyclic expressions in charts.

Advanced Features differs from the first two parts in that its lessons are independent 
(i.e. the procedures performed are not based on the work done in previous lessons), 
which allows you to immediately go to the lesson that interests you the most.

The files used in this part are found in the ...Tutoria\Advanced directory.
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MORE ABOUT ASSOCIATIONS
LESSON 16 MORE ABOUT ASSOCIATIONS
The Fields page appearing after every script execution contains a check box named 
Show System Fields. If this check box is selected, the column listing available fields 
includes six fields preceded by a dollar sign ($). These fields, called system fields, are 
very useful for obtaining an overview of the logical structure of a QlikView docu-
ment.

The first section of this lesson describes the system fields and shows how they can be 
displayed on a system sheet. The second part shows an example of how you can solve 
a common problem using the system fields: display of frequency information in asso-
ciating fields. 

Creating a system sheet
1 Start QlikView.

2 Choose Open from the File menu.

3 Select the file Advanced.qvw found in the Advanced folder, then click Open. 

4 Choose Add Sheet... from the Layout menu.

5 Name the sheet System, then click Next>.

6 Move the system fields (the ones preceded by a dollar sign, $) to the column 
of displayed fields. If the system fields are not visible, mark the check box 
Show System Fields. 

The system fields show

• the names of the fields retrieved ($Field), 

• the names of the tables loaded ($Table), 

• the number of rows and columns in a table ($Rows and $Fields), 

• the column number for a specific field ($FieldNo), and 

• the names of the info tables loaded ($Info). 

7 Click Finish.

8 Size the list boxes until you see all the field names and all the field values, 
then rearrange the boxes.
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Using the system sheet

Your system sheet is now ready, but to further improve it, choose frequency display 
for the list box $Field:

1 Open the Properties dialog and go to the General page.

2 Select the check box Show in the Frequency group, then go to the Sort 
page.

3 Select Frequency, Descending, then click OK.

The values in the field $Field are now followed by numbers indicating their number 
of occurrences in the tables. The list box being sorted by frequency, the field with the 
greatest number of occurrences is placed at the top. The result is as follows:

Figure 45.  The System sheet
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You see that the field Country occurs in three tables, Customer ID and Salesman ID 
in two tables, and all the other fields in only one table. The three fields appearing 
more than once are the fields used to associate the tables of the document. The rela-
tions are illustrated in the figure below:

4 Click Country in the $Field box. 

The program now shows that the field Country occurs in the tables Country1 (a logi-
cal table consisting of three concatenated country tables), Customer and Markets. 
The other list boxes provide additional information on the number of rows and fields 
of the concerned tables, and of the column numbers of the field in the respective 
tables. 

Moreover, the list box $Info on the system sheet shows the info table associated with 
the field Country.

As soon as only one table or info table is possible (selected or optional) in a list box, 

a small info symbol  is displayed in the top right-hand corner of the list box. 
Clicking this will allow you to edit the table directly:

5 Click one of the optional tables in the list box $Table.

6 The info symbol appears in the top right-hand corner. Click it.

7 The original table is now opened by the associated program. Study it, then 
close the program to get back to QlikView.

8 Clear your selections.

Note If the file type of the table (usually the extension csv) is not associated with 
an appropriate text editor, the table will not be opened. To associate a file 
type with a program, open the Windows Explorer. Select a file of the 
concerned type in the structure and double-click it. This opens a list of 

Figure 46.  The logical structure
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available programs. Pick an appropriate program, preferably Notepad or 
Excel, then click OK. (Another possibility is to choose View, Folder Options 
from the Explorer menu and go to the File Types page.)

When working with large sets of data with complicated structures, it is impossible to 
keep the entire data structure in mind. The system sheet is then of crucial importance. 

Creating a system table
Besides displaying the system fields in list boxes, you can also illustrate the relations 
by creating a system table:  

1 Right-click on the sheet and open the cascade menu New Sheet Object 
where you select System Table.

The system table now appears on your system sheet. Size it. Study it. You’ll find that 
the first column, listing all the fields found in the document, is followed by one col-
umn for each loaded table. If a table contains the field listed in the leftmost column, 
the field also occurs in the table column; if not, a ’-’ (indicating a NULL value) is dis-
played. You easily see which of the fields are keys, i.e. common to more than one 
table. The system table thus clearly shows how the tables of the document are associ-
ated. It can be a useful complement to the Table Viewer described in Lesson 13 on 
page 149. 

Figure 47.  The system table
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One of many examples of situations where the use of system variables is indispens-
able is the one below.

Showing frequency in associating fields
Suppose you work with the customer sheet and want to see how many customers you 
have in different countries, i.e. how many times the countries occur in the data.

1 Go to the Customer sheet of your document.  

2 Click on the list box Country with the right mouse button, then click Proper-
ties.

3 Go to the General page.

The check box Show Frequency is disabled, i.e. it is not pos-
sible to show frequency for this field. Why?

By studying the System sheet, you clearly see that the field 
Country occurs in more than one table. As a matter of fact, 
three of the loaded tables contain a field named Country. Country1 and Market, con-
taining geographical information and a list of the markets to which different countries 
belong, respectively, list each country only once. The Customer table, however, con-
tains more than one occurrence of countries in which several customers reside. The 
three Country fields being treated as one due to the associations, it is impossible for 
the program to know which of the tables it should use for calculating data frequen-
cies.

Since making guesses could lead to erroneous results, QlikView has been designed 
not to allow certain operations when the data interpretation is ambiguous for associat-
ing fields. 

What you are actually interested in is the frequency of the countries in the customer 
table. To obtain the information you need, load the field Country a second time under 
a new name from the table Customer.csv:

4 Close the List Box Properties dialog.

5 Open the Edit Script dialog.

6 Find the statement loading Customer.csv and position the cursor after the last 
field (Country), then type ", Country as CustomerCountry". The load 
statement now looks similar to the following:
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Load [Customer ID],
Customer,
Address,
City,
Zip,
Country, Country as CustomerCountry

from c:\qlikview\tutorialfiles\application\
examples\customer.csv 
(ansi, txt, delimiter is ',', embedded labels, header 
is 0);

You need to keep the field Country, otherwise there will be no key field and thus no 
association with previously loaded tables.

7 Click Run.

8 Move the new field CustomerCountry to the list of displayed fields, then 
click OK.

Your Customer sheet now contains a second country list box, listing only the coun-
tries in which there are customers. Having a name that is not common to any other 
field name in the document, this second field is not an associating field. It is thus pos-
sible to show frequency information.

9 Click on the CustomerCountry list box with the right mouse button, then 
choose Properties.

10 On the General page, select the check box Show in the Frequency group, 
then go to the Sort page.

11 Select Frequency, then click OK.

The countries are now displayed in frequency order. You may have to size the list box 
to see the numbers.

Since it actually makes more sense to have the field CustomerCountry on this sheet 
than the Country field (you aren’t interested in the countries in which you have no 
customers), do the following: 

12 Remove the list box Country.

When selecting countries on the Customer sheet, there will now always be at least 
one customer optional.

13 Adjust the layout.

14 Save the file as System.qvw.

Associating fields have yet two limitations besides the inability to show frequency: 
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• Statistics boxes based on an associating field shows n/a for most statistical 
entities.

• In charts using an associating field, it is not possible to create expressions 
containing functions that depend on frequency information (e.g. sum, count 
functions, average) unless the distinct modifier is turned on. 

15 Close the file. If you wish, compare it with the file SystemFinal.qvw found in 
the Advanced folder.

16  If you won’t be working with QlikView for a while, you can now exit the 
program.

For more information, see the Reference Manual.
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LOAD INLINE
LESSON 17 LOAD INLINE
In some cases, you may want to add data by typing it directly in the script rather than 
loading it from a file or a database. In this lesson you’ll learn how to do this with 
load inline.

Load inline can also be used for mapping (associating new information with already 
existing information via a field name), which constitutes the second section of this 
lesson. 

Adding a record with load inline
1 Start QlikView and open the file Inline.qvw found in the ...Tuto-

rial\Advanced directory.

The document has been created from two tables, Customer.csv and Transact.csv. Sup-
pose you want to add a customer to the document, but without changing the original 
files. Do the following: 

2 Open the Edit Script dialog.

3 Position the cursor at the end of the script, then type the following lines:
Load * Inline [
Customer ID,Customer, Address, City, Zip, Country
1181, Alexander’s Catering Service, Fisherman’s Drive 
4, Portsmouth, BH 354 RW, Great Britain];

The first line lists the field names of Customer.csv (the table to which you want to add 
the record), whereas the second line contains the record that is to be added.  The star 
symbol is equivalent to "all fields".

Note Due to limited space, the record in the above example does not fit in one 
line. When reproducing this inline clause in the script, however, it is 
important that you put the entire record in one single line: Portsmouth etc. 
should thus follow directly after Fisherman’s Drive 4.  See the file 
InlineFinal.qvw in the Advanced folder.

4 Choose Run.

5 Choose OK to close the dialog.

6 No new field has been added, but there are new field values in some of the 
list boxes. Click Alexander’s Catering Service in the customer list and study 
the result.
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The data enclosed by the parenthesis after inline is treated like an ordinary table. 
Having the same set of fields as the customer table, the inline table has been concate-
nated with the customer table. You can easily check this by studying the System 
sheet: only two tables are displayed in the $Table list box (the concatenated table is 
always given the name of the first input table, which, in this case, is Customer).

Save the document as MyInline.qvw or something similar.

Naturally, inline tables can be used for other purposes than for adding records to 
existing tables. If, for instance, you wish to load very small tables, it may be easier to 
create these directly in the script than to create and load an external file.

Mapping data with load inline
The document Inline.qvw contains a field with the months of the year written as num-
bers. Suppose you want to create a chart with the names of the months spelled out, 
and another chart showing sales per quarter. This is easily solved with data mapping. 

Data mapping means associating new information to already existing information via 
a field name. Typical examples of data mapping could be connecting an account 
number to an account name or splitting a date into three fields for year, month and 
day, respectively. The data mapping can be done using an external file or straight in 
the script using load inline.

In this example, you’ll use load inline to map month numbers against month names 
and quarters.

This time we will use the built-in inline wizard to create the load inline statement, 
usually a much more convenient method than typing directly in the script.

1 Open the Edit Script dialog.

2 Position the cursor at the end of the script.

3 Click on Inline Wizard... under Data in Script on the Data tab.

4 The dialog that opens looks like a small spreadsheet and in fact works much 
like one. However there is no support for formulas in the data cells.

5 The cursor will be positioned in the top left data cell. Enter the 1 as shown in 
the picture below. Use ENTER or the arrow keys to move between cells and 
fill in the table as shown below.
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6 Finally double-click in the header row over 1 and enter the field name 
Month. Repeat for the remaining columns as shown below.

Tip! If you need a table in e.g. Excel it can of course be pasted into the QlikView in-
line wizard.

7 Click OK and you should have a piece of script looking like this:

Figure 48.  The Inline Data Wizard
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Load * Inline [
Month, MonthName, Quarter
1, January, 1
2, February, 1
3, March, 1
4, April, 2
5, May, 2
6, June, 2
7, July, 3
8, August, 3
9, September, 3
10, October, 4
11, November, 4
12, December, 4];

8 Choose Run.

Two new fields have been added to the list of available fields, MonthName and Quar-
ter. The inline table has been associated with the transact table via the field Month. 

9 Click OK.

Figure 49.  The potential appearance of your inline document.
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10 Create a bar chart showing sales per quarter (choose Quarter as variable and 
add the expression Sum of Sales). In case you need help, see Working with 
QlikView on page 57.

11 Save the document under a name of your choice and close the file. If you 
wish, compare your file with the file InlineFinal.qvw.

12 If you won’t be working with QlikView for a while, you can also exit the 
program.
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LESSON 18 FIELD GROUPS AND CYCLIC 
DISPLAY

Instead of displaying single fields as dimensions in charts, it is possible to define 
groups of fields to be used for this purpose. Working with field groups allows you to 
display data in a very efficient way, since the resulting charts will show the selected 
fields in a hierarchical (drill-down) or cyclic sequence. In this lesson, these important 
features will be explained: you’ll define both hierarchic and cyclic field groups and 
create corresponding charts.

The use of field groups should not be confused with cyclic display in charts. Cyclic 
display, constituting the last part of this lesson, can be applied to any chart having 
more than one expression, and results in the expressions being displayed sequentially. 
Just like the use of field groups, however, it saves space and allows you to make 
quick changes in the data displayed in the chart.

Field groups
One main difference between QlikView and many other database viewers, OLAP 
tools etc. is that in QlikView there is no need to predefine any hierarchies in the input 
data. The unique associative logic of QlikView gives you the complete freedom to 
access any field as a full dimension in any order you like. For most purposes this 
freedom is extremely powerful. 

However, there are occasions when a predefined hierarchy could actually help you to 
display data more efficiently. QlikView therefore offers the possibility to define 
groups of fields. The groups can be hierarchic (drill-down) or non hierarchic (cyclic).

Creating a drill-down group
When several fields form a natural hierarchy, it makes sense to create a drill-
down group. 

1 Start QlikView, then open the file Groups.qvw found in the ...Tuto-
rial\Advanced directory.

2 Choose Document Properties from the Settings menu and go to 
the Groups page.

3 Click the New button. The Group Settings dialog opens. Change 
the default name to Time in the Group Name box.

4 Select Year, Quarter and Month in the list of available fields by 
CTRL-clicking them, then click Add to move them to the column of 
used fields. 
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5 Use the Promote and Demote buttons to get the correct hierarchy: 
Year, Quarter, Month. This is of great importance, since the order of 
the fields in the group corresponds to the display order in charts.

6 Click OK twice.

You have now created a drill-down group, which you can use as a dimension variable 
in a chart.

Creating and using a drill-down chart
To create a drill-down chart, do the following:

1 Go to the Sales sheet, then click the Create chart button in the tool-
bar (if the design toolbar is not displayed, choose Design Toolbar 
from the View menu).

2 Choose Drill-down as window title, then click Next> to go to the 
Dimensions page.

The Time group created above is listed among the ordinary field 
names. However, it can easily be distinguished from them: field 
groups are always preceded by specific symbols. For drill-down 
groups, this symbol is a straight arrow.

3 Choose Time as variable by moving it to the column of displayed 
fields. 

4 Click Next.

5 The Edit Expression dialog automatically opens. Compose the 
expression Sum of Sales, then click Paste. Type Sales in the Label 
box.

6 Click OK.

7 Click Next> until you get to the Colors page. Select the check box 
Multicolored.
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8 On the Number page, select Integer and set 1000$ as Thousand 
Symbol, then click Finish.

The chart, showing the sum of sales per year, looks like any other bar chart. 
However, as soon as you make a selection causing the field Year to have only 
one possible value, you discover its drill-down character:

9 Select the bar 1996 in the chart.

An ordinary chart would now display one bar, representing the sum of sales 
for 1996. This chart, however, shows the sum of sales for each quarter of the 
year 1996 (the second field in the field list defined being Quarter).

Figure 50.  The drill-down chart
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10 Select the bar representing the fourth quarter.

The chart turns to showing the sales for each month of the selected quarter. 
Month is the third, and last, field in the field group.

As soon as more than one value becomes possible in the fields further up in 
the hierarchy, the chart is automatically drilled back up.

To go back in the hierarchy, click in the outer chart area or on the drill-
up icon next to the field name. 

Creating a cyclic group
Sometimes it may be useful to group fields which do not form a natural hier-
archy or even have nothing in common at all. The reason would be to make 
quick changes of the data displayed in a chart and to save space.

Any fields can be grouped together in a cyclic group. 

1 Choose Document Properties from the Settings menu and go to 
the Groups page.

2 Click the New button. The Group Settings dialog opens. Change 
the default name to Cyclic in the name box.

3 Select Country, Salesman and Year in the list of available fields, 
then click Add to move them to the column of used fields. The order 
of the fields in the list is of no importance when defining cyclic 
groups.

Figure 51.  The drill-down chart showing the second field in the hierachy.
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4 Select the Cyclic option.

5 Click OK twice.

You have now created a cyclic group. When used as a dimension in a chart, it will 
allow you to switch between the fields of the group (x-axis) while keeping the same 
expression (y-axis).

Creating and using a cyclic chart

To create a cyclic chart, do the following:

1 Click the Create chart button in the toolbar (if the design toolbar is 
not displayed, choose Design Toolbar from the View menu).

2 Choose Cyclic as window title, then click Next> to go to the Dimen-
sions page.

The Cyclic group is listed among the ordinary field names. Just like 
the drill-down group, it is preceded by a symbol. For cyclic groups, 
this symbol is a circular arrow.

3 Double-click the Cyclic group to move it to the column of displayed 
fields/groups. 

4 Click Next>.

5 The Edit Expression dialog automatically opens. Compose the 
expression Sum of Sales, then click Paste. Type Sales in the Label 
box.

Figure 52.  The cyclic chart
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6 Click OK.

7 Click Next>. On the Sort page, sort the values by y-value.

8 On the Presentation page, set Max Number to 10.

9 Click Next> until you get to the Colors page. Select the check box 
Multicolored.

10 On the Number page, select Integer and set 1000$ as 1 000 Sym-
bol, then click Finish.

Initially, your chart shows the sum of sales per CustomerCountry, which is 
the first field in the field list.

11 Switch to the next field by clicking the cycle icon in the bottom 
right-hand corner of the chart. Now Salesman, the second field, is 
displayed.

12 If you click the cycle icon a second time, the sum of sales per year 
will be shown. Year is the third and last field of the field group.

When the last field in the list has been used, the turn goes back to the first 
field. The chart can be cycled indefinitely. 

It is also possible to right-click on the cycle icon, in which case a list of the 
fields in the cyclic group is displayed for direct selection (see the picture 
below).

13 Minimize the chart.

Figure 53.  Direct selection in the cyclic icon when right-clicking it
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Showing three charts in one frame this way is a very efficient way of dis-
playing data. It also allows you to make quick changes of graphically dis-
played data.  

Cyclic display of Expressions
The Expressions page in the Chart Properties dialog provides a check box named 
Cyclic Display. If you have a chart with two expressions, you can choose to display 
them sequentially instead of simultaneously. The switching between expressions is 
done via a button similar to the one used in cyclic charts.  

To create a chart with cyclic display of expressions, do the following:

1 Click the Create chart button in the toolbar (if the design toolbar is not dis-
played, choose Design Toolbar from the View menu).

2 Choose Cyclic Display as window title, then click Next> to go to the Dimen-
sions page.

3 Move the field Year to the column of displayed fields, then click Next>.

4 The Edit Expression dialog automatically opens. Compose the expression 
Sum of Sales, then click Paste. 

5 Click OK. Note that the Cyclic Display check box is disabled: you need two 
expressions to be able to use it.

6 Click Add again to add a second expression.

7 This time, create the expression Total count of Sales.

8 Click Paste, then OK. The Cyclic Display check box is now enabled: select 
it.

9 Click Next>. On the Sort page, sort the values by y-value, ascending.

10 On the Presentation page, set Max Number to 10.

11 Click Next> until you get to the Color page. Select the check box Multicol-
ored bars.

12 On the Number page, select Integer and set 1000$ as 1 000 Symbol (for the 
first expression), then click Finish.
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The chart looks like an ordinary bar chart showing the sum of sales per year:

However, the cycle icon in the bottom left-hand corner indicates that the chart has 
further potential.

13 Click the cycle icon.

The chart now turns to showing the number (total count) of sales performed during 
different years.

Naturally, you can choose to display more than two expressions this way. It is also 
possible to combine groups and cyclic display into powerful multi-dimensional 
charts. Only your imagination will set the limits.

14 Save the document using a name of your choice. If you wish, compare it 
with the file GroupsFinal.qvw.

15 Close the file. If you won’t be working with QlikView for a while, you can 
also exit the program.

Figure 54.  The chart using the first expression
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LESSON 19 HANDLING CROSS TABLES
A cross table is a common type of table featuring a matrix of values between two 
orthogonal lists of header data. By using the QlikView crosstable statement, you can 
load this type of table in a very elegant way. The procedure is described in this chap-
ter.

Loading a cross table 
You’ll start by looking at a crosstable in Excel (or a similar program):

Open the Explorer, then find the file Crosstable1.csv in the ...Tuto-
rial\Advanced\Examples directory and double-click it.

Microsoft Excel opens the file. It looks like below:

If this table is loaded into QlikView the usual way, the result will be one field for Year 
and one field for each of the months. This is generally not what you want: you would 
probably prefer to have three fields generated, one for each header category (Year and 
Month) and one for the data values inside the matrix.

You’ll start by loading the table into QlikView the usual way:

1 Close the file.

2 Start QlikView and choose New from the File menu. 

3 Open the Edit Script dialog.

4 Click Table Files, then find the file Crosstable1.csv and click Open.

5 If the file wizard has made a correct interpretation, click Finish.

The following statement has been generated in your script:

Figure 55.  The Crosstable1.csv file

Year Jan Feb Mar Apr May Jun
1991 45 65 78 12 78 22
1992 11 23 22 22 45 85
1993 65 56 22 79 12 56
1994 45 24 32 78 55 15
1995 45 56 35 78 68 82
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Load Year,
Jan,
Feb,
Mar,
Apr,
May,
Jun

from c:\qlikview\tutorialfiles\advanced\
examples\crosstable1.csv 
(ansi, txt, delimiter is ',', embedded labels);

6 Load the file by clicking Run.

7 Add all the fields except the system fields to the column of displayed fields. 

8 Click OK.  The following list boxes appear on your screen:

9 This is not what you want. Open the Edit Script dialog box again.

10 Now add the crosstable prefix, indicating that the table is to be loaded as a 
cross table, to your load statement. The crosstable prefix should be fol-
lowed by a parenthesis containing the names you wish to apply to the new 
fields:

Crosstable (Month, Sales) Load
Year,
Jan,
Feb,
Mar,
Apr,
May,
Jun

from c:\qlikview\tutorialfiles\advanced\
examples\crosstable1.csv 
(ansi, txt, delimiter is ',', embedded labels);

11 Click Run.

Figure 56.  The resulting list boxes
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12 The Fields dialog page opens. Move the fields Month and Sales to the col-
umn of displayed fields (the field Year is already there), then click OK.

The following list boxes appear on your screen:

This distribution of values makes a lot more sense.

13 Save the document using an appropriate name, then close it. 

Loading a cross table with more than one 
regular column

The cross table is often preceded by a number of regular columns, which should be 
loaded in a straightforward way. This is the case in the following table 
(Crosstable2.csv):

In this table the matrix columns are preceded by two regular columns. You would 
probably like QlikView to show the contents of the table in four fields:

• Salesman, containing the values of the first (regular) column

Figure 57.  The list boxes when the script has been run with the crosstable prefix.

Figure 58.  Crosstable2.csv

Salesman Year Jan Feb Mar Apr May Jun
A 1991 45 65 78 12 78 22
A 1992 11 23 22 22 45 85
A 1993 65 56 22 79 12 56
A 1994 45 24 32 78 55 15
A 1995 45 56 35 78 68 82
B 1991 57 77 90 24 90 34
B 1992 23 35 34 34 57 97
B 1993 77 68 34 91 24 68
B 1994 57 36 44 90 67 27
B 1995 57 68 47 90 80 94
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• Year, containing the values of the second (regular) column

• Month, containing the headers of the remaining columns

• Sales, containing the values of the remaining columns

To obtain this result, do the following: 

1 Choose New from the File menu. 

2 Open the Edit Script dialog.

3 Click Table Files, then find the file Crosstable2.csv and click Open.

We will now use a special wizard for creating the crosstable statement.

4 Click Next. This will take you to the last page of the file wizard, which we 
have not used up to this point.

5 Click the Crosstable button.

6 QlikView asks if Salesman is a qualifying field (regular column). Click Yes.

7 QlikView asks if Year is a qualifying field. Click Yes.

8 QlikView asks if Jan is a qualifying field. Click No.

9 QlikView now asks for the name of the new field that will contain the month 
names. Type Month and click OK.

10 QlikView will then finally ask for the name of the field to combine the sales 
figures. Type Sales and click OK.

11 In the preview pane you can now see the transfromed table. Click Finish. 
The script generated will look as follows: 

CROSSTABLE(Month, Sales, 2)
Load Salesman,
Year,
Jan,
Feb,
Mar,
Apr,
May,
Jun
FROM 
g:\documentation\qv\5.0\manual\eng\tutorialfiles\adva
nced\examples\crosstable2.csv (ansi, txt, delimiter is 
',', embedded labels);

Note that the crosstable prefix has the number 2 as a third parameter. This indicates 
the number of regular column in the original table. If no parameter is stated, 1 is 
assumed.
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12 Click Run.

13 The Fields dialog page opens. Move the fields Salesman, Year, Month and 
Sales to the column of displayed fields, then click OK.

The following list boxes appear on your screen:

14 Save the document using an appropriate name, then close it. If you won’t be 
working with QlikView for a while, you can also exit the program.

For a description of the syntax, see the Reference Manual.

Figure 59.  The resulting list boxes
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LESSON 20 AND-MODE IN A LIST BOX
Two selections in different list boxes are always interpreted as logical and, i.e. Qlik-
View will show all the field values associated with both the selections. A multiple 
selection within a list box is however usually interpreted as logical or, i.e. QlikView 
will show data entries associated with any of the selected values.

Under some circumstances, a multiple selection within a list box can be set to logical 
and, which means that QlikView will show only data entries associated with all of 
the selected values. 

This lesson features a list box set to and-mode, which you will use for usual selec-
tions as well as for not-selections. You’ll also learn under which circumstances a list 
box can be set to and-mode.

Making an and-selection

In the file And.qvw in the ...Tutorial\Advanced directory, there is such a list box:

1 Start QlikView.

Figure 60.  The List Box Properties sheet in which the and mode can be set
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2 Open the file And.qvw by pressing the Open button in the toolbar, browsing 
for the file and clicking Open.

3 Choose the tab Geography, and find the list box Membership.

This is a list of organizations and geographical areas that the different countries 
belong to. A country can be a member of several organizations, and an organization 
can have many members. There is thus a many-to-many relationship between the 
field Country and the field Membership. Moreover, the field Membership does not 
link directly to any other field but Country. Under such circumstances, the field Mem-
bership can be set to and mode. A multiple selection in the Membership field should 
then be interpreted as "show only countries that are members of all the selected orga-
nizations". 

4 Click on the list box with the right mouse button, then choose Properties, 
General.

5 Mark the check box And mode, then choose the OK button.

6 Select Europe by clicking it.

The Europe cell should now be green, and have an ampersand "&" to the left. The 
organizations shown as alternatives (white) are the ones that have one or several 
members of Europe. The organizations that are excluded are the ones with no mem-
bers on the European continent. 

7 Select G-7 by CTRL-clicking. 

You have now selected Europe and G-7, i.e. countries that are members of both. Only 
four countries remain optional, and these are all European countries in the G-7 group.

Making a not-selection
It is also possible to exclude countries in a similar way:

1 Deselect G-7 by CTRL-clicking it.

2 Select G-7 by CTRL-clicking it, keeping the mouse 
button down. Release the button when the cell has 
turned red. 

You have now selected Europe and not G-7. Only European 
countries not in the G-7 group are now optional. This type of 
selection is called forced exclusion, and is very useful in 
many-to-many relationships.

3 Close the file. If you won’t be working with Qlik-
View for a while, you can also exit the program.
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Characteristics of the and-table

Not every field can be set to logical and mode. The and mode is only possible if the 
field corresponds to the second column of a two-column table. 

Also, the field must not be fetched from more than one table. The reason for this is 
that the and-alternative is logically meaningful only if the concerned field is associ-
ated to only one other field. 

Finally, there must be no duplicate records in the table. It is thus advisable to load this 
kind of table using the distinct predicate (see the Reference Manual).

If the field is loaded this way, the And mode control in the List Box Properties dia-
log will no longer be dimmed and the logical mode of the list box can be changed.

Figure 61.  An and-table
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LESSON 21 SEMANTIC LINKS
Normally, selections are made explicitly by clicking on the field values that are inter-
esting. There is, however, also a way to make selections indirectly through semantic 
links. These are similar to field values, but with the difference that they describe the 
relations between the objects rather than the objects themselves. 

This lesson shows you how to work with semantic links as well as how to create and 
load a semantic table. Furthermore, the script function load...resident will be intro-
duced.

Working with semantic links
1 Start QlikView.

2 Open the file Presidents.qvw in the ...Tutorial\Advanced directory.

This document is a list of U.S. presidents. By selecting a president, you can 
find out when he was born, etc. 

3 Select Eisenhower. 

You see that he was the 34th president. But who was his predecessor? 

4 Click on Predecessor in the Relation list box. 

You immediately find that it was Harry S Truman. Note that Predecessor 
does not turn green. Instead, 33 in the No list box turns green. By clicking on 
Predecessor you make an indirect selection of an object, other than the one 
that is currently selected. 

Predecessor and Successor are typical semantic links.

5 Close the file.

Creating a document with semantic links
To create the above document, you need to load two tables: one logical table contain-
ing information about the presidents, and one semantic table.
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Loading the logical table

The logical table (the one above) is loaded into QlikView the usual way:

1 Click the New button to create an empty document.

2 Choose Edit Script from the File menu.

3 Click Table Files.

4 Find the file presdnts.csv in the ...\TutorialFiles\Advanced\Exam-
ples directory, then click Open.

5 The file wizard opens. Make sure that the program has made a cor-
rect interpretation, then click Finish.

An ordinary load statement has been generated in your script: 
Load No,

FirstName,
LastName,
Born,
Deceased,
Party,
Origin,
From,
To

from c:\qlikview\tutorialfiles\advanced\
examples\presdnts.csv 
(ansi, txt, delimiter is ',', embedded labels);

6 Click Run to execute the script.

7 Add all the fields except the system fields to your document, then 
click OK.

Your document now looks almost like Presidents.qvw; only the Relation list box con-
taining the semantic links is missing. For this to appear, you must load a semantic 
table.

Figure 62.  The logical table listing the U.S. presidents
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The semantic table

The semantic table must contain exactly three or four columns. Normally four col-
umns are used, the first one containing the field values that have a relation to some 
other field value and the third one containing the related field value. The second col-
umn must contain the names of the relations, and finally, the fourth one must contain 
the names of the inverse relations. 

In this case, we only have to define the order of the presidents, and what the words 
predecessor and successor mean. This can be done by loading a table like the one in 
Figure 63. The first and third columns list the numbers of the presidents, and the sec-
ond and fourth columns list the names of the relations. In this example all the rela-
tions in the second column are named Successor and all the relations in the fourth are 
named Predecessor, but the relations do not necessarily have to be the same within a 
column.

Extracting the semantic table from existing data
The semantic table does not have to exist as a table outside QlikView. It is 
more flexible to extract this table from the existing table of presidents 
through a separate load statement. 

1 Open the Edit Script dialog again.

2 Position the cursor at the end of the script.

Figure 63.  The semantic table defining the relations between the presidents
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3 Type the following rows:
Load[No] -1 as No,

'Successor' as Relation,
[No],
'Predecessor' as Relation

from c:\qlikview\tutorialfiles\advanced\
examples\presdnts.csv 
(ansi, txt, delimiter is ',', embedded labels) where 
[No] > 1;

This load statement results in the table in Table 63 on page 205. 

The first script line, No -1 as No, results in the first column of the semantic 
table (Figure 63), containing all the numeric values of the original field No 
subtracted by 1. The where clause after the parenthesis has been added to 
omit the first record, since this would link the first president to the nonexist-
ent 0:th president. 

The second and fourth script lines will load the text strings Successor and 
Predecessor (enclosed by single quotation marks) as field values into the 
respective fields (both named Relation). This procedure should not be con-
fused with the renaming of fields, where the fields to be renamed lack quota-
tion marks or are enclosed by double quotation marks (or by square 
brackets). 

It is important to use single straight quotation marks, otherwise the program 
will not make a correct interpretation. For more information on quotation 
marks, see the Reference Manual.

Note also that the load statement contains two fields labeled No and two 
fields labeled Relation. Such a load statement would cause a script execution 
error if used to load a logical table, since the loading procedure for one sin-
gle logical table demands that none of the fields have the same name. 

Loading the semantic table
For the above table to be loaded as a semantic table, the load statement must 
be preceded by the semantic qualifier: 
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4 Type semantic before load. The script now has the following 
appearance:

Load [No],
FirstName,
LastName,
Born,
Deceased,
Party,
Origin,
[From],
[To]

from c:\qlikview\tutorialfiles\advanced\
examples\presdnts.csv 
(ansi, txt, delimiter is ',', embedded labels);
Semantic Load [No] -1 as [No],

'Successor' as Relation,
[No],
'Predecessor' as Relation

from c:\qlikview\tutorialfiles\advanced\
examples\presdnts.csv 
(ansi, txt, delimiter is ',', embedded labels) where 
No > 1;

5 Click Run.

6 Add the new field Relation to your document by moving it to the 
column of displayed fields, then click OK.

Study your document: it is now identical with Presidents.qvw. The new field 
Relation has two field values, Successor and Predecessor, which are seman-
tic links. 

7 Select a president, e.g. Clinton.

8 Click the semantic link Predecessor.

9 The value George Bush is displayed. Click Predecessor again. 

George Bush’s predecessor, Ronald Reagan, is now displayed. This way you 
can click yourself through the entire line of presidents.

Loading the semantic table using load...resident
The most convenient way of extracting data from a previously loaded table, 
like you did above, is to use the resident clause. 

The procedure is simple: all you need to do is add a label to the input table 
containing the data you wish to extract, and to refer to this label in a succeed-
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ing statement. To extract the above table using a resident clause, the script 
would look like the one below: 

Presidents:
Load No,

FirstName,
LastName,
Born,
Deceased,
Party,
Origin,
From,
To

from c:\qlikview\tutorialfiles\advanced\
examples\presdnts.csv 
(ansi, txt, delimiter is ',', embedded labels);
Semantic Load No -1 as No,

'Successor' as Relation,
No,
'Predecessor' as Relation

resident Presidents where No > 1;

Note that the first load statement is preceded by "Presidents:": this is the 
label specified for the first table. The second statement, instead of loading 
the file presdnts.csv a second time, simply refers to it via "resident Presi-
dents". Note that the label, when specified, ends with a colon, whereas there 
is no colon in the reference. Don’t forget the semicolon, which is used to 
indicate the end of a statement.

1 Open the Edit Script dialog.

2 Modify the script to make it look like the one above.

3 Click Run. If you have done everything correctly, the script is exe-
cuted and no changes occur in the document.

4 Save your document as Semantic.qvw.

5 Close the file. If you won’t be working with QlikView for a while, 
you can also exit the program.

The presidents example is just one simple example of how to use semantic 
links. Semantic links are very useful when working with hierarchies, e.g. in 
genealogy, where the links could be e.g. cousin, sibling, grandmother, etc. 
They can also be used for people in companies where the semantic links can 
be e.g. boss, reports to, secretary, etc. 

See the Reference Manual for more information on semantic links.
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LESSON 22 NUMBER FORMATS
QlikView can handle text strings, numbers, dates, times, time stamps and currencies 
correctly. They can be sorted, displayed in a number of different formats and they can 
be used in calculations. This means e.g. that dates, times and time stamps can be 
added to or subtracted from each other. 

This lesson deals with the basics of number interpretation and number formatting. 
For more detailed information, see the Reference Manual.

Interpretation and formatting
The issue of obtaining correct number formats is really a question of two different 
things:

• Interpretation of data when it is loaded

• Display of different number-based data types

Data representation inside QlikView
In order to understand data interpretation and number formatting in Qlik-
View, it is necessary to know how data is stored internally by the program. 
All of the data loaded into QlikView is stored in two representations, as a 
string and as a number. 

1 The string representation is always available and is what is shown in 
the list boxes and the other sheet objects. Formatting of data in list 
boxes (number format) only affects the string representation.

2 The number representation is only available when the data can be 
interpreted as a valid number. The number representation is used for 
all numeric calculations and for numeric sorting.

If several data items read into one field have the same number representa-
tion, they will all be treated as the same value and will all share the first 
string representation encountered. Example: The numbers 1.0, 1 and 1.000 
read in that order will all have the number representation 1 and the initial 
string representation 1.0. Na

Interpretation of data
QlikView tries to interpret input data as a number, date, time etc. As long as the sys-
tem default settings (found under Regional Settings in Windows 98, Regional 
Options in Windows 2000 or Regional and Language Options in Windows XP in 
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the Control Panel) are used in the data and the number interpretation variables in the 
script are correctly defined, the interpretation and the display formatting are handled 
automatically by QlikView, and the user does not need to alter the script or any set-
ting in QlikView.

1 Open the Explorer and find the file Date1.csv in the ...\Tutorial-
Files\Advanced\Examples directory. Double-click the file.

2 Excel opens the file. It consists of three fields, Date, Customer and Sales. 
Note that the dates in the Date field are formatted according to the American 
standard format M/D/YY (M=month, D=day,YY=the two final numbers of 
the year), and that the numbers in the sales field have comma as thousands 
separator.

3 Close the file.

4 Start QlikView, then choose New from the File menu.

5 Open the Edit Script dialog. A certain number of set statements, defining 
separators and number formats via the number interpretation variables, have 
been generated automatically:

SET ThousandSep=',';
SET DecimalSep='.';
SET MoneyThousandSep=',';
SET MoneyDecimalSep='.';
SET MoneyFormat='$#,##0.00;($#,##0.00)';
SET TimeFormat='th:mm:ss';
SET DateFormat='M/D/YY';
SET TimestampFormat='M/D/YY th:mm:ss[.fff]';
SET MonthNames=Jan;Feb;Mar;Apr;May;Jun;...';
SET DayNames='Mon;Tue;Wed;Thu;Fri;Sat;Sun';

These settings are taken from the regional settings in the computer on which 
the script is generated and could therefor look somewhat different on your 
computer. This ensures a correct reexecution of the QlikView script also on 
computers with other regional settings, provided that the data files remain 
the same.

6 Open the Control Panel (Start menu, Settings) and go to Regional Set-
tings.  

7 Look through the pages of the Regional Settings dialog, especially Number 
and Date, and note that the settings correspond to those defined by the vari-
ables above. To get the same results as this example, English (United States) 
must be chosen on the first page.

8 Close the Control Panel.
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The number interpretation variables may be deleted, edited or duplicated 
freely. If changed, they substitute the operating system defaults. 

Note that the thousands separator and the date format defined by the number 
interpretation variables also correspond to the formats used in your file. 
QlikView will thus interpret everything correctly:

9 Go back to QlikView and click Table Files in the Edit Script dialog.

10 Find the file Date1.csv, then click Open.

11 If the file wizard has made a correct interpretation of the contents, click Fin-
ish.

12 Click Run to execute the script.

13 Move the fields Customer, Date and Sales to the column of displayed fields, 
then click OK.

14 The three list boxes appear on your sheet. Move and size them. 

There is an easy way to find out if QlikView has interpreted the contents as 
valid numbers: valid numbers are always right-aligned in the list box, 
whereas values interpreted merely as text strings are left-aligned. 

The contents of both Sales and Date being right-aligned, you can conclude 
that they have been correctly interpreted. 

15 Save the document as Number.qvw and close it.

Once QlikView has interpreted the data as valid numbers, you can apply 
other formats using the Number page in the List Box Properties dialog. 
Formatting will be treated in the section “Formatting of data” on page 214.

Changing the number interpretation format
Suppose that the values of the field Date have the British date format (DD/
MM/YY) instead of the American, i.e. a format that differs from the system 
settings and the formats set at the beginning of the script:

1 Click the New button to create a blank document.

2 Open the Edit Script dialog, then click Table Files.

3 Find the file Date2.csv, then click Open.

4 If the file wizard has made a correct interpretation of the contents, 
click Finish.

5 Click Run to execute the script.

6 Move the fields Customer, Date and Sales to the column of dis-
played fields, then click OK.
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7 The three list boxes appear on your sheet. Move and size them. 

This time, the values of the Date list box are left-aligned, which means that 
they have been interpreted as text strings, not as valid dates. As long as this 
situation remains, you won’t be able to change the number format of the 
field, nor make calculations based on the field.

The problem can be solved in one of the following ways:

• By changing the system settings in the Control Panel

• By changing the date format setting in the script

• By using an interpretation function in the script

Changing the date format in the script
Changing the system settings is usually not a good idea, unless most of the 
files you load have a type of regional settings that is different from yours. 
Changing the date format setting in the script is a better solution (moreover, 
it is very useful if you want a person with different system settings to use the 
document):

1 Open the Edit Script dialog and change the date format setting to 
DD/MM/YY. The set statements should now be the following:

SET ThousandSep=',';
SET DecimalSep='.';
SET MoneyThousandSep=' ';
SET MoneyDecimalSep='.';
SET MoneyFormat='$# ##0.00;($# ##0.00)';
SET TimeFormat='th:mm:ss';
SET DateFormat='DD/MM/YY';
SET TimestampFormat='M/D/YY th:mm:ss[.fff]
SET MonthNames='Jan;Feb;Mar;Apr;May;Jun;...';
SET DayNames='Mon;Tue;Wed;Thu;Fri;Sat;Sun';

2 Reexecute the script by clicking Run.

3 Click OK to close the dialog, then study your document and note 
that the values in the list box Date are now right-aligned. They have 
thus been interpreted as valid dates.

4 Save the document as Number2.qvw and close it.

Using interpretation functions
If you load several files which all have different number formats, you may 
want to use an interpretation function instead. Interpretation functions are 
used to interpret field contents or expressions. Do the following: 
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1 Create a blank document by clicking New.

2 Open the Edit Script dialog. Note that the date format is M/D/YY 
again, since you haven’t changed the system settings.

3 Click Table Files and open the file Date2.csv.

4 If the file wizard has made a correct interpretation of the contents, 
click Finish.

5 Modify the script to make it look like below:
Load date#(Date, ’DD/MM/YY’) as Date,

Customer,
Sales

from c:\qlikview\tutorialfiles\advanced\
examples\Date2.csv 
(ansi, txt, delimiter is ’,’, embedded labels);

Date# is the interpretation function, Date is the field to be inter-
preted, and DD/MM/YY is the date format according to which you 
want the field contents to be interpreted. The syntax, as well as fur-
ther examples, are found in the Reference Manual.

6 Choose Run to execute the script.

7 Move the fields Customer, Date and Sales to the column of dis-
played fields, then click OK.

Study the document and note that the values of the field Date have 
once again been interpreted as valid dates. The result is identical 
with the one of Number2.qvw. 

8 Save the document as Number3.qvw.

Interpretation problems due to different separators are solved in the 
same way. 

Note When interpreting dates with only two positions for year, e.g. YY-
MM-DD, QlikView will assume that the date falls within a moving 
window of -50 to +49 years counted from the current year according 
to the system clock. Thus, 88-08-08 will be interpreted as 1988-08-
08, whereas 44-08-08 will be interpreted as 2044-08-08.

Files are not always homogeneous. If you have a file containing differently 
formatted data in one and the same field, you can use the alt function, which 
tests if the field contains data formatted according to the specified number 
representations. See the Reference Manual.
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Once QlikView has interpreted data as valid numbers, it is possible to choose another 
number format in the properties dialog for the sheet object.

1 Click on the list box Date with the right mouse button, then choose Proper-
ties... from the float menu.

2 Go to the Number page.  

3 Choose Override Document Settings in order to set a separate number for-
mat for the list box.

4 The format is set to Mixed. Change it to Date by selecting the option.

5 In the Format box, the default date format of the operating system appears. 
It can be changed to any other format of your choice. For instance, you may 
prefer the standard ISO format YYYY-MM-DD. Erase the contents of the 
Format box and enter the new format, or click the ISO button.

6 Click OK.

The specified format has been applied to the values of the list box Date. To choose 
another date format, simply open the Number page of the properties dialog again and 
change the contents of the Format box. 

The easiest way to change the number format for several fields is to use the Docu-
ment Properties dialog. 

If the field originally contained differently formatted values, e.g. certain dates with 
the format M/D/YY and others with the format DD/MM/YY,  you may want to return 
to the original formatting. For ordinary text files, however, this is only possible if the 
script is re-executed with the Survive Reload check box (Number page) deselected. 

The Default from input button on the Number page is only available for fields with a 
defined data type read from a database via ODBC.

7 Save and close the document. If you won’t be working with QlikView for a 
while, you can also exit the program.

It is also possible to set the formatting by using formatting functions in the script. See 
the Reference Manual, Book I.

For more detailed information about number formats, see the Reference Manual, 
Book I. Year 2000 compliance is treated in the Introduction part of the Reference 
Manual.
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LESSON 23 ACCESS RESTRICTION
It is important that information is distributed only to those with access rights to it. 
Since QlikView makes the previously cumbersome process of retrieving information 
a very simple task, it is obvious that an access restriction mechanism is necessary. 
This kind of mechanism can be added when creating the document. In this lesson, 
which is the last lesson of the Tutorial, you’ll add an access restriction mechanism to 
a previously created file.

Access levels
Access to QlikView documents can be restricted to specified users or groups of users. 
When creating the document, these are assigned the access levels ADMIN or USER. 
If no access level is assigned, the user cannot open the QlikView document. For clar-
ity, it is often useful to use other access levels, e.g. NONE, but these will always be 
treated as “no access”.

A person with ADMIN access can change everything in the document. Using the 
Security page in the Document Properties and Sheet Properties dialogs, a person 
with ADMIN access can limit the users’ possibilities of modifying the document. 
Read more about this in the Reference Manual. A person with USER privileges can-
not access the Security pages.  A NONE access does not give any access at all to the 
QlikView document.

Sections in the Script
All access control is managed via files, SQL databases or inline clauses in the same 
way as QlikView normally handles data. It is thus possible to store the access data in 
a normal database. The script statements managing the security tables are given 
within the access section, which in the script is initiated by the statement section 
access.

If an access section is defined in the script, the part of the script loading the "normal" 
data must be put in a different section, initiated by the statement section application.
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Example:
Section Access;
Load * inline

[ACCESS,USERID,PASSWORD
ADMIN, A,X
USER,U,Y  ];

Section Application;
Load … from …

Section Access system fields
The access levels are assigned to users in one or several tables loaded within the sec-
tion access. These tables can contain several different user-specific system fields, 
typically USERID and PASSWORD, and the field defining the access level, 
ACCESS. The full set of section access system fields are described in the reference 
manual. Other fields like e.g. GROUP or ORGANISATION may be added to facili-
tate the administration, but QlikView does not treat these fields in any special way. 

None, all, or any combination of the security fields may be loaded in the access sec-
tion. However, if the ACCESS field is not loaded, all the users will have ADMIN 
access to the document and the section access will not be meaningful.

ACCESS
A field that defines what access the user should have.

USERID
A field that should contain a user ID that has the privilege specified 
in the field ACCESS.

PASSWORD
A field that should contain an accepted password.

SERIAL
A field that should contain a number corresponding to the QlikView 
serial number. Example: 4900 2394 7113 7304

QlikView will first compare the QlikView serial number with the field 
SERIAL. It will then, if necessary, prompt for User ID and password and 
compare these with the fields USERID and PASSWORD. 

If the combination of User ID, password and serial number is found in the 
Section Access table, the document is opened with the corresponding access 
level. If not, QlikView will deny the user access to the document. If the User 
ID and/or the password are not entered correctly within three attempts the 
entire log-on procedure must be repeated.
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Example 1:
Only serial number is checked. One specific computer gets ADMIN 
access. Everyone else gets USER access. Note that a star can be 
used to mark “any serial number”.

Example 2:
The administrator and the computer with serial number 4900 2394 
7113 7304 (the server on which QlikView runs as a batch job) gets 
ADMIN access. Everyone else gets USER access when entering 
“USER” as user ID and password.

Loading security tables
Suppose you have two tables containing security information, the first one named 
acclist.csv, the second accserid.csv. The first table contains the security fields USE-
RID, PASSWORD and ACCESS, the second the security field SERIAL. Since the 
same associative logic that is the hallmark of QlikView is used also in the access sec-
tion, the  tables will be associated via the optional field COMPUTER NAME.

Note All fields listed in Load or Select statements in the section access must be 
written in UPPER CASE. Any field name containing lower case letters in the 
database will be converted to upper case before being read by the Load or 
Select statement. However, the user ID and the password entered by the 
end-user opening the QlikView document are case insensitive..

USERID PASSWORD ACCESS GROUP COMPUTER NAME
Sharon 7VFI1R ADMIN IT All
Sharon FROMME2U USER IT All

Bob LOVE15 ADMIN Marketing Bob
Bob 15ALL USER Marketing All
Pete NUMBER1 USER Personnel All

Sarah ABSOLUT USER Personnel Sarah

COMPUTER NAME SERIAL
Sharon 1234 5678 9012 3456

Bob 1234 5678 9012 3457
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Note The serial number must be given in 4x4 number groups separated by a blank.

You’ll now load the above tables into QlikView: 

1 Open the document for which you want access control, e.g. Advanced.qvw.

2 Open the Edit Script dialog and position the cursor at the beginning of the 
script, but after the set statements.

3 Click Table Files.

4 Select the files acclist.csv and accserid.csv (in the ...Tuto-
rial\Advanced\Examples directory) and click Open.

5 The files are opened in the file wizard. Click Finish for both files.

6 For the tables to be used for access control, the statements loading them need 
to be placed in a separate section. Type section access; at the top of the 
script (after the set statements). Don’t forget the semicolon. 

7 To distinguish the access section from the application section, position the 
cursor after the statements loading the security tables, then type section 
application;. Don’t forget the semicolons: they indicate the end of a state-
ment.

The first part of your script should now have the following appearance:

Pete 1234 5678 9012 3458
Sarah 1234 5678 9012 3459
All *

COMPUTER NAME SERIAL
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Section access;
Directory c:\qlikview\tutorialfiles\
advanced\examples;
Load USERID,

PASSWORD,
ACCESS,
GROUP,
[COMPUTER NAME]

from acclist.csv 
(ansi, txt, delimiter is ',', embedded labels);
Load [COMPUTER NAME],

SERIAL
from accserid.csv 
(ansi, txt, delimiter is ',', embedded labels);

Section application;
Load Country,

 Capital,...

The directory statement specifies the path to the files.  

8 Choose Run to execute the script.

9 Click OK to close the dialog.

The following access rights will be granted:

Sharon will have access rights from all the computers (since all the serial num-
bers are allowed). Depending on which password she uses she will be 
granted either ADMIN or USER access rights.

Bob will have ADMIN rights when he sits at his own computer (Serial num-
ber 1234 5678 9012 3457) and enters his UserID (Bob) and Password 
(LOVE15). He will have USER rights on all the computers (all serial 
numbers allowed) when he gives his UserID (Bob) and Password 
(15ALL).

Pete will have USER access from all the computers provided he gives his 
UserID and correct password, and

Sarah will have to use her own computer (Serial number 1234 5678 9012 
3459) and give a correct UserID and Password to be able to open the 
QlikView document with USER access rights.
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Using the Security pages
People with ADMIN privileges can prevent the execution of certain commands:

1 Choose Document Properties from the Settings menu.

2 Go to the Security page.

The Security page contains a list of QlikView commands. By deselecting a 
check box, you prevent the document users from executing that command. 

3 Deselect Add Sheets and Edit Script, then click OK.

Note that the commands you deselected are now dimmed, i.e. inactive.

4 Save the file as Access.qvw, then close it and exit QlikView.

There is also a Security page on the Sheet Properties page, containing fur-
ther commands

Working with access restriction
Suppose you are Pete and wish to work with the document. 

1 Open QlikView, then choose Open from the File menu.

2 Find the file Access.qvw and click Open.

3 QlikView prompts for the correct User ID. Enter Pete, then click OK.  

4 QlikView now prompts for the correct password. As Pete, you have USER 
rights from all the computers. Enter your password, i.e. NUMBER1 (case 
insensitive). Click OK.

If you have done everything correctly, the document now opens and you can work 
with it. Note, however, that you cannot add sheets or view the script, since these com-
mands have been inactivated. Note also that you cannot access the Security pages: 
these pages are only available for ADMIN users. 

If you wish to be granted access to all the parts of the document, you need to enter 
Sharon’s UserID and Password (make sure to pick the password granting her 
ADMIN access rights.

5 Close the file. If you won’t be working with QlikView for a while, you can 
also exit the program.

The syntax of the section statement is given in the Reference Manual. For further 
information on access restriction, see the Appendix of that manual.
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You have now finished the entire Tutorial. As you create your own documents, be 
sure to take advantage of all the resources available to you. For further information, 
see the Reference Manual.
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