Using Expressor with a MS SQL connection

    When trying to create a connection to Microsoft SQL Server with QlikView Expressor using the provided 32 bit native drivers, you may receive the following error:


    SQLSTATE:[08001], Code:[0], Msg:[expressor][ODBC SQL Server Wire Protocol driver]Connection refused. Verify Host Name and Port Number.


    You may be able to connect to the MS SQL Server with other applications however they might be using a different driver / protocols to connect, so therefore it may seem that the MS SQL Server configuration is valid.


    In this case, if this is a new installation of MS SQL Server which is a local installation (on the same pc).


    Please verify the following:


    That it works when creating a ODBC DSN using the 32-BIT version driver "SQL Server Native Client 11.0".


    Programs -> expressor -> expressor3 -> system tools -> Data Sources (ODBC) - this ensures that the proper 32 bit ODBC admin tool is being used


    If this works - then verify the following on the MS SQL Server side.


    The problem may be the protocols that are enabled on the MS SQL Server. After installing MS SQL 2012 - you will need to enable TCP/IP in the SQL Server Configuration Manager in order to get the provided QlikView Expressor drivers to work.


    Programs ->MS SQL->Configuration Tools->SQL Server Configuration Manager




    By default TCP/IP is not enabled. Also check your TCP/IP Dynamic ports - make sure the property is blank and does not have a 0 as a value. Scroll through the list and do this for all IP addresses to be sure. I encountered a number of machines that have installed named "INSTANCES" of MS SQL Server and they needed to modify these settings.  Please refer to this document for more information onusing Named Instances:


    The configure the QlikView Expressor Database Connection as usual:



    This document was generated from the following discussion: Expressor SQL connection