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achakilam1022
Creator II
Creator II

Qlik Sense Proxy Log Error

Hi all,

I found this in our Qlik sense server proxy logs. Any idea why this would show up? We are currently on April 2018 version (installed patch 1 release).

Audit Trace:

658 20180702T230547.148-0500 WARN

host_name Audit.Proxy.Qlik.Sense.Communication.Communication.Tcp.StreamFactory 83

b6eef4ab-2b72-4a9c-8996-6d5cc6076b30 domain_name\service_account

Error during stream authentication as Server

System Trace:

188 20180703T045547.150-0500 WARN host_name

System.Proxy.Qlik.Sense.Communication.Communication.Tcp.StreamFactory 73 cf46834e-90d3-4973-b8ea-ce6873fd6564 domain_name\service_account Error during stream authentication as Server Authentication failed because the remote party has closed the transport stream.    at System.Net.Security.SslState.InternalEndProcessAuthentication(LazyAsyncResult lazyResult)↵↓   at System.Net.Security.SslState.EndProcessAuthentication(IAsyncResult result)↵↓   at Qlik.Sense.Communication.Communication.Tcp.StreamFactory.<>c__DisplayClass10_1.<Negotiate>b__2(IAsyncResult result) cf46834e-90d3-4973-b8ea-ce6873fd6564

Thanks!

12 Replies
Anonymous
Not applicable

Getting the same error! Need a solution.

Gencho
Creator II
Creator II

Hello

I've found this article

Let me know if this is helpful for you

Description

After a fresh installation, the user is unable to access the QMC / Hub. Basic pre-requisites have been confirmed like the service account being a local administrator.

When inspecting the Repository > Trace > System log, you see the following error:

System.Repository.Qlik.Sense.Communication.Communication.Tcp.StreamFactory

Error during stream authentication as client

Authentication failed because the remote party has closed the transport stream.

at System.Net.Security.SslState.InternalEndProcessAuthentication(LazyAsyncResult lazyResult)

at System.Net.Security.SslState.EndProcessAuthentication(IAsyncResult result)

at Qlik.Sense.Communication.Communication.Tcp.StreamFactory.<>c__DisplayClass8_1.<Negotiate>b__2(IAsyncResult result)

Cause

Qlik Sense, currently, requires TLS 1.0 to be enabled for interservice communication.

Resolution

Ensure that TLS 1.0 is enabled on the server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server --> DisabledByDefault set to 0 & Enabled - Set to 1

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client -- > DisabledByDefault set to 0 & Enabled - Set to 1

Reboot Server for the registry keys are activated

achakilam1022
Creator II
Creator II
Author

Hi Gerardo,

Thanks for the reply.

I have:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Client

And under this, we already have DisabledByDefault set to 1.


Thanks!



Gencho
Creator II
Creator II

Hello Amuktha,

Do you have a cluster or is a single server? what version do you have installed?

Sometimes it is an error of the antivirus, so could you check that it is disabled or make sure that Qlik sense it is in the whitelist, check the common issues like:

  • The user that runs the services it's in the Administrators group
  • check the Qlik sense ports
  • Check the whitelist of the virtual proxy, if you have a cluster, make sure that you have all the servers in the whitelist

What it worked for me was that I had different users that ran the Qlik sense services, make sure that you have the same user in all the servers (if you have a cluster)

Hoping that this will be helpful for you, regards

achakilam1022
Creator II
Creator II
Author

Hi Gerardo,

We have a single server and we are on Jun  2018 version. We turned off windows defender antivirus.

  • The user that runs the services it's in the Administrators group - Yes, we have a single service account which is  a part of the admin group
  • check the Qlik sense ports - Looks good
  • Check the whitelist of the virtual proxy, if you have a cluster, make sure that you have all the servers in the whitelist -  Yes, we have whitelisted

Thanks!

achakilam1022
Creator II
Creator II
Author

Gerardo,

We have SSL not TLS under protocols. does this make any difference?

Thanks!

Gencho
Creator II
Creator II

Internet says that it is an old version of SSL, I don't think that will be a big difference by the way, did you tried the option repair?

Control panel ->install and uninstall programs-> select qlik sense-> right clic and select change-> follow the wizard and finally select the option repair.

A few times Qliktech recommended me that option (in older cases) I never apply it  because I found the solution, but Qlikteck told me that you will have all the settings that you have until now, just will fix if there is something corrupted

Looks like you have a lot of time with this error, let me know if you have any comment or if you could fix it

2018-08-15 14_47_18-ssl vs tls - Buscar con Google.png

tomovangel
Partner - Specialist
Partner - Specialist

Did you got it to work, because I have the exact same issue !!!

achakilam1022
Creator II
Creator II
Author

We still have this error in our proxy logs.