<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: Qlik tasks failing after installing new ODBC 18 driver. in Qlik Replicate</title>
    <link>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544866#M16040</link>
    <description>&lt;P&gt;Hello Desmond,&amp;nbsp;&lt;a href="https://community.qlik.com/t5/user/viewprofilepage/user-id/2924"&gt;@desmondchew&lt;/a&gt;&amp;nbsp;&lt;/P&gt;
&lt;P data-end="77" data-start="55"&gt;Thanks for the update.&lt;/P&gt;
&lt;P data-end="165" data-start="79"&gt;Could you please try running the same test against another table as well? For example:&lt;/P&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp;select top (1)&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp; &amp;nbsp; SCHEMA_NAME(uid)&amp;nbsp; as ownerName,&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp; &amp;nbsp; name&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; as tableName,&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp;from sysobjects;&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&amp;nbsp;&lt;/DIV&gt;
&lt;DIV&gt;If the issue persists, I would suggest opening a support ticket and uploading the &lt;STRONG data-end="370" data-start="350"&gt;server log files&lt;/STRONG&gt; so that we can investigate further.&lt;/DIV&gt;
&lt;DIV&gt;&amp;nbsp;&lt;/DIV&gt;
&lt;DIV&gt;thanks,&lt;/DIV&gt;
&lt;DIV&gt;John.&lt;/DIV&gt;</description>
    <pubDate>Mon, 16 Mar 2026 08:38:26 GMT</pubDate>
    <dc:creator>john_wang</dc:creator>
    <dc:date>2026-03-16T08:38:26Z</dc:date>
    <item>
      <title>Qlik tasks failing after installing new ODBC 18 driver.</title>
      <link>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544851#M16036</link>
      <description>&lt;P&gt;We are replicating from source SQL server 2022 into target Snowflake. We have ODBC 17 and installed ODBC 18 into the server. After installing, the task been running fine. After several hours, however it started to give error.&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;DIV&gt;Failed to prepare get capture list statement&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;select&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; SCHEMA_NAME(uid)&amp;nbsp; &amp;nbsp; as ownerName,&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; name&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; as tableName,&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; id&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; as objectId,&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; &amp;nbsp;0 as row_count,&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; type as tableType&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;from sysobjects&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;where&lt;/DIV&gt;&lt;DIV&gt;&lt;SPAN&gt;(category=0 or category = 32) -- exclude SYS pretenders&lt;/SPAN&gt;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;and OBJECTPROPERTY ( id , 'IsSystemTable' ) =0&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;and&amp;nbsp; &amp;nbsp;name&amp;lt;&amp;gt;N'sysdiagrams'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;and&amp;nbsp; &amp;nbsp;name not like N'attrep_mscdc_ddl_history'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;and&lt;/DIV&gt;&lt;DIV&gt;(&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; ((&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;( type = N'U' ) and SCHEMA_NAME(uid) = N'dbo' and name = N'PAss'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;or&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;( type = N'U' ) and SCHEMA_NAME(uid) = N'dbo' and name = N'PassThru_ForQlik_Daily'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;) -- Explicit Inclusion&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; or&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; (&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;( (1=0) ) -- Patterned Inclusion&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;and not&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp;(&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;( type = N'U' ) and SCHEMA_NAME(uid) LIKE N'%' and name LIKE N'attrep_changes%'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;or&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;( type = N'U' ) and SCHEMA_NAME(uid) LIKE N'%' and name LIKE N'attrep_apply%'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;or&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;( type = N'U' ) and SCHEMA_NAME(uid) LIKE N'%' and name LIKE N'attrep_truncation%'&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;or&amp;nbsp;&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;( type = N'U' ) and SCHEMA_NAME(uid) LIKE N'%' and na&lt;BR /&gt;&lt;BR /&gt;Task 'AXReport_AX' failed&lt;BR /&gt;Build tables list failed&lt;BR /&gt;Cannot get captured tables list&lt;BR /&gt;Failed to get the capture list from the endpoint&lt;BR /&gt;&lt;BR /&gt;Cannot access source partitions as the user does not have the VIEW DATABASE STATE permission. The Full Load task will continue, but changes to partitioned tables will not be captured. RetCode: SQL_ERROR SqlState: HYT00 NativeError: 0 Message: [Microsoft][ODBC Driver 18 for SQL Server]Query timeout expired. Failed (retcode -1) to execute statement: 'select 1 FROM sys.dm_db_partition_stats'&lt;BR /&gt;&lt;BR /&gt;We did grant the permission&lt;BR /&gt;USE DB&lt;BR /&gt;GO&lt;BR /&gt;GRANT VIEW DATABASE STATE TO produser;&lt;BR /&gt;GO&lt;BR /&gt;&lt;BR /&gt;Any idea?&lt;BR /&gt;&lt;BR /&gt;Desmond&lt;/DIV&gt;&lt;DIV&gt;&amp;nbsp;&lt;/DIV&gt;</description>
      <pubDate>Mon, 16 Mar 2026 04:58:23 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544851#M16036</guid>
      <dc:creator>desmondchew</dc:creator>
      <dc:date>2026-03-16T04:58:23Z</dc:date>
    </item>
    <item>
      <title>Re: Qlik tasks failing after installing new ODBC 18 driver.</title>
      <link>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544852#M16037</link>
      <description>&lt;P&gt;Hello Desmond,&amp;nbsp;&lt;a href="https://community.qlik.com/t5/user/viewprofilepage/user-id/2924"&gt;@desmondchew&lt;/a&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;The error is not related to the ODBC Driver 18. It appears to be a &lt;STRONG&gt;permission issue&lt;/STRONG&gt;.&lt;/P&gt;
&lt;P&gt;Could you please try running the following query manually using the &lt;STRONG&gt;produser&lt;/STRONG&gt; account?&lt;/P&gt;
&lt;P&gt;&lt;FONT face="courier new,courier"&gt;select 1 FROM sys.dm_db_partition_stats;&lt;/FONT&gt;&lt;/P&gt;
&lt;P&gt;If the required permissions are in place, the query should return rows.&lt;BR /&gt;If not, SQL Server will return an error indicating any additional permissions are required.&lt;/P&gt;
&lt;P&gt;thanks,&lt;BR /&gt;John.&lt;/P&gt;</description>
      <pubDate>Mon, 16 Mar 2026 05:09:01 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544852#M16037</guid>
      <dc:creator>john_wang</dc:creator>
      <dc:date>2026-03-16T05:09:01Z</dc:date>
    </item>
    <item>
      <title>Re: Qlik tasks failing after installing new ODBC 18 driver.</title>
      <link>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544854#M16038</link>
      <description>&lt;P&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-inline" image-alt="query is succeed.jpg" style="width: 640px;"&gt;&lt;img src="https://community.qlik.com/t5/image/serverpage/image-id/187323iBBAF2B297D9D7C3E/image-size/large?v=v2&amp;amp;px=999" role="button" title="query is succeed.jpg" alt="query is succeed.jpg" /&gt;&lt;/span&gt;&lt;/P&gt;&lt;P&gt;I login as the Qlik user - prod and able to run the query. Doesn't seem like a permission issue.&lt;/P&gt;</description>
      <pubDate>Mon, 16 Mar 2026 05:12:52 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544854#M16038</guid>
      <dc:creator>desmondchew</dc:creator>
      <dc:date>2026-03-16T05:12:52Z</dc:date>
    </item>
    <item>
      <title>Re: Qlik tasks failing after installing new ODBC 18 driver.</title>
      <link>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544866#M16040</link>
      <description>&lt;P&gt;Hello Desmond,&amp;nbsp;&lt;a href="https://community.qlik.com/t5/user/viewprofilepage/user-id/2924"&gt;@desmondchew&lt;/a&gt;&amp;nbsp;&lt;/P&gt;
&lt;P data-end="77" data-start="55"&gt;Thanks for the update.&lt;/P&gt;
&lt;P data-end="165" data-start="79"&gt;Could you please try running the same test against another table as well? For example:&lt;/P&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp;select top (1)&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp; &amp;nbsp; SCHEMA_NAME(uid)&amp;nbsp; as ownerName,&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp; &amp;nbsp; name&amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; &amp;nbsp; as tableName,&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&lt;FONT face="courier new,courier"&gt;&amp;nbsp;from sysobjects;&lt;/FONT&gt;&lt;/DIV&gt;
&lt;DIV&gt;&amp;nbsp;&lt;/DIV&gt;
&lt;DIV&gt;If the issue persists, I would suggest opening a support ticket and uploading the &lt;STRONG data-end="370" data-start="350"&gt;server log files&lt;/STRONG&gt; so that we can investigate further.&lt;/DIV&gt;
&lt;DIV&gt;&amp;nbsp;&lt;/DIV&gt;
&lt;DIV&gt;thanks,&lt;/DIV&gt;
&lt;DIV&gt;John.&lt;/DIV&gt;</description>
      <pubDate>Mon, 16 Mar 2026 08:38:26 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544866#M16040</guid>
      <dc:creator>john_wang</dc:creator>
      <dc:date>2026-03-16T08:38:26Z</dc:date>
    </item>
    <item>
      <title>Re: Qlik tasks failing after installing new ODBC 18 driver.</title>
      <link>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544867#M16041</link>
      <description>&lt;P&gt;Hi John,&lt;BR /&gt;&lt;BR /&gt;Thank you. We have identified the issue. It is due to a blocking session in the source database. Once we killed that session, replica is able to move.&lt;/P&gt;&lt;P&gt;&lt;BR /&gt;Desmond&lt;/P&gt;</description>
      <pubDate>Mon, 16 Mar 2026 08:39:51 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Qlik-Replicate/Qlik-tasks-failing-after-installing-new-ODBC-18-driver/m-p/2544867#M16041</guid>
      <dc:creator>desmondchew</dc:creator>
      <dc:date>2026-03-16T08:39:51Z</dc:date>
    </item>
  </channel>
</rss>

