<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>article Qlik Sense SAML Integration fails with 500 Internal Server Error, Unanticipated ComponentSpace.SAML2.Exceptions.SAMLBindingException in Official Support Articles</title>
    <link>https://community.qlik.com/t5/Official-Support-Articles/Qlik-Sense-SAML-Integration-fails-with-500-Internal-Server-Error/ta-p/1711692</link>
    <description>&lt;P&gt;Setting up SAML with Qlik Sense Enterprise on Windows fails.&lt;/P&gt;
&lt;P&gt;Accessing the Hub leads to a &lt;FONT face="courier new,courier"&gt;500 Internal Server Error&lt;/FONT&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;The Qlik Sense Proxy logs (default: C:\Programdata\Qlik\Sense\Log\Proxy\Trace\xxx_Audit.log) shows:&lt;/P&gt;
&lt;P&gt;&lt;FONT face="courier new,courier"&gt;Unanticipated ComponentSpace.SAML2.Exceptions.&lt;STRONG&gt;SAMLBindingException&lt;/STRONG&gt; occurred for connection&lt;/FONT&gt;&lt;/P&gt;
&lt;H3&gt;&lt;BR /&gt;&amp;nbsp;Resolution:&lt;/H3&gt;
&lt;P&gt;&lt;BR /&gt;Create new IDP Metadata to change the binding method for the SAML Request to HTTP Redirect instead.&lt;BR /&gt;&lt;BR /&gt;If using new SHA256 certificates ensure the conversion was performed.&amp;nbsp;&lt;A href="https://community.qlik.com/t5/Knowledge-Base/SHA-256-and-Converting-the-Cryptographic-Service-Provider-Type/ta-p/1716032" target="_blank" rel="noopener"&gt;SHA-256 and Converting the Cryptographic Service Provider Type&lt;/A&gt;&lt;/P&gt;
&lt;P&gt;Example:&lt;/P&gt;
&lt;LI-CODE lang="markup"&gt;&amp;lt;md:SingleSignOnService Location="https://server/MiddlewareRestServices/extension/SS0" Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect"/&amp;gt;&lt;/LI-CODE&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3 class="qlik-migrated-tkb-headings"&gt;Cause:&lt;/H3&gt;
&lt;P&gt;&lt;BR /&gt;This error might indicate that the HTTP method you use to bind for SAML authentication requests in your IDP Metadata is not supported.&lt;/P&gt;
&lt;P&gt;Only HTTP Redirect is currently supported so if you use HTTP POST instead you will get this error.&amp;nbsp;&lt;BR /&gt;&lt;BR /&gt;More details are available on our online documentation:&amp;nbsp;&lt;A href="https://help.qlik.com/en-US/sense-admin/Subsystems/DeployAdministerQSE/Content/Sense_DeployAdminister/QSEoW/Deploy_QSEoW/Server-Security-Authentication-Solutions.htm" target="_self"&gt;Authentication solutions&lt;/A&gt;&lt;/P&gt;</description>
    <pubDate>Tue, 16 Nov 2021 11:32:39 GMT</pubDate>
    <dc:creator>Bastien_Laugiero</dc:creator>
    <dc:date>2021-11-16T11:32:39Z</dc:date>
    <item>
      <title>Qlik Sense SAML Integration fails with 500 Internal Server Error, Unanticipated ComponentSpace.SAML2.Exceptions.SAMLBindingException</title>
      <link>https://community.qlik.com/t5/Official-Support-Articles/Qlik-Sense-SAML-Integration-fails-with-500-Internal-Server-Error/ta-p/1711692</link>
      <description>&lt;P&gt;Setting up SAML with Qlik Sense Enterprise on Windows fails.&lt;/P&gt;
&lt;P&gt;Accessing the Hub leads to a &lt;FONT face="courier new,courier"&gt;500 Internal Server Error&lt;/FONT&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;The Qlik Sense Proxy logs (default: C:\Programdata\Qlik\Sense\Log\Proxy\Trace\xxx_Audit.log) shows:&lt;/P&gt;
&lt;P&gt;&lt;FONT face="courier new,courier"&gt;Unanticipated ComponentSpace.SAML2.Exceptions.&lt;STRONG&gt;SAMLBindingException&lt;/STRONG&gt; occurred for connection&lt;/FONT&gt;&lt;/P&gt;
&lt;H3&gt;&lt;BR /&gt;&amp;nbsp;Resolution:&lt;/H3&gt;
&lt;P&gt;&lt;BR /&gt;Create new IDP Metadata to change the binding method for the SAML Request to HTTP Redirect instead.&lt;BR /&gt;&lt;BR /&gt;If using new SHA256 certificates ensure the conversion was performed.&amp;nbsp;&lt;A href="https://community.qlik.com/t5/Knowledge-Base/SHA-256-and-Converting-the-Cryptographic-Service-Provider-Type/ta-p/1716032" target="_blank" rel="noopener"&gt;SHA-256 and Converting the Cryptographic Service Provider Type&lt;/A&gt;&lt;/P&gt;
&lt;P&gt;Example:&lt;/P&gt;
&lt;LI-CODE lang="markup"&gt;&amp;lt;md:SingleSignOnService Location="https://server/MiddlewareRestServices/extension/SS0" Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect"/&amp;gt;&lt;/LI-CODE&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3 class="qlik-migrated-tkb-headings"&gt;Cause:&lt;/H3&gt;
&lt;P&gt;&lt;BR /&gt;This error might indicate that the HTTP method you use to bind for SAML authentication requests in your IDP Metadata is not supported.&lt;/P&gt;
&lt;P&gt;Only HTTP Redirect is currently supported so if you use HTTP POST instead you will get this error.&amp;nbsp;&lt;BR /&gt;&lt;BR /&gt;More details are available on our online documentation:&amp;nbsp;&lt;A href="https://help.qlik.com/en-US/sense-admin/Subsystems/DeployAdministerQSE/Content/Sense_DeployAdminister/QSEoW/Deploy_QSEoW/Server-Security-Authentication-Solutions.htm" target="_self"&gt;Authentication solutions&lt;/A&gt;&lt;/P&gt;</description>
      <pubDate>Tue, 16 Nov 2021 11:32:39 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Official-Support-Articles/Qlik-Sense-SAML-Integration-fails-with-500-Internal-Server-Error/ta-p/1711692</guid>
      <dc:creator>Bastien_Laugiero</dc:creator>
      <dc:date>2021-11-16T11:32:39Z</dc:date>
    </item>
  </channel>
</rss>

