<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>article Unable to install or upgrade Qlik Sense to a remote PostgreSQL database with FIPS enabled in Official Support Articles</title>
    <link>https://community.qlik.com/t5/Official-Support-Articles/Unable-to-install-or-upgrade-Qlik-Sense-to-a-remote-PostgreSQL/ta-p/1717223</link>
    <description>&lt;P&gt;When attempting to install or upgrade Qlik Sense Enterprise on Windows and connecting to a remote PostgreSQL database, the installer will fail to connect if FIPS is enabled.&lt;/P&gt;
&lt;P&gt;&lt;STRONG&gt;Error during installation:&amp;nbsp;&lt;/STRONG&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;&lt;SPAN&gt;The database could not be reached. Details: Exception has been thrown by the target of an invocation.&lt;/SPAN&gt;&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;SPAN&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-inline" image-alt="the database could not be reached.png" style="width: 502px;"&gt;&lt;img src="https://community.qlik.com/t5/image/serverpage/image-id/100566i8D32BDD9041693F0/image-size/large?v=v2&amp;amp;px=999" role="button" title="the database could not be reached.png" alt="the database could not be reached.png" /&gt;&lt;/span&gt;&lt;/SPAN&gt;&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&lt;STRONG&gt;Error during upgrade:&lt;/STRONG&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;This version of Qlik Sense requires a 'SenseServices' database for multi cloud capabilities. Ensure that you have a created a 'SenseService' database in your cluster before upgrading.&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;This version of Qlik Sense requires a 'QSMQ' database for multi cloud capabilities. Ensure that you have a created a 'QSMQ' database in your cluster before upgrading.&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;This version of Qlik Sense requires a 'Licenses' database for multi cloud capabilities. Ensure that you have a created a 'Licenses' database in your cluster before upgrading.&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-inline" image-alt="this version of qlik sense requires a database for.png" style="width: 522px;"&gt;&lt;img src="https://community.qlik.com/t5/image/serverpage/image-id/100567i11B0363CF6FF8057/image-size/large?v=v2&amp;amp;px=999" role="button" title="this version of qlik sense requires a database for.png" alt="this version of qlik sense requires a database for.png" /&gt;&lt;/span&gt;&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3&gt;&lt;FONT color="#339966"&gt;&lt;STRONG&gt;Resolution:&lt;/STRONG&gt;&lt;/FONT&gt;&lt;/H3&gt;
&lt;P&gt;There are two options available.&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&lt;FONT color="#339966"&gt;&lt;STRONG&gt;Option 1 (for newer version of Qlik Sense):&lt;/STRONG&gt;&lt;/FONT&gt;&lt;/P&gt;
&lt;P&gt;Modify the password encryption for Postgres users and update it to use &lt;FONT face="courier new,courier"&gt;scram-sha-256&lt;/FONT&gt;.&lt;/P&gt;
&lt;OL&gt;
&lt;LI&gt;Log into your stand-alone Postgres database server&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Open PowerShell and navigate to the install location of PostgreSQL. IE:&amp;nbsp; &lt;FONT face="courier new,courier"&gt;C:\Program Files\PostgreSQL\12\bin&lt;/FONT&gt;&lt;/SPAN&gt;&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Access Postgres console:&amp;nbsp;&lt;FONT face="courier new,courier"&gt; .\psql -h localhost -p 4432 -U postgres&lt;/FONT&gt;&lt;/SPAN&gt;&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Run the following commands to update the encryption:&lt;/SPAN&gt;&lt;BR /&gt;
&lt;PRE&gt;postgres=# SHOW password_encryption;
 password_encryption
---------------------
 md5
(1 row)&lt;BR /&gt;
postgres=# SET password_encryption TO 'scram-sha-256';
SET&lt;BR /&gt;
postgres=# SHOW password_encryption;
 password_encryption
---------------------
 scram-sha-256
(1 row)&lt;BR /&gt;&lt;BR /&gt;****change the password from what is displayed in this example****
postgres=# ALTER USER postgres WITH PASSWORD 'yourpostgresuserpwd';
ALTER ROLE

postgres=# ALTER USER qliksenserepository WITH PASSWORD 'yourqliksensrepositoryuserpwd'; 
ALTER ROLE


--check if both have now a scram-sha-256 prefix

 SELECT usename, passwd FROM pg_shadow WHERE usename IN ('postgres', 'qliksenserepository');

      usename       |                    passwd
--------------------+--------------------------------------------------
 postgres | SCRAM-SHA-256$4096:[some scram-sha-256 hash...]=
 qliksenserepository           | SCRAM-SHA-256$4096:[some scram-sha-256 hash...]=&lt;/PRE&gt;
&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Run the Qlik Sense upgrade again&lt;/SPAN&gt;&lt;/LI&gt;
&lt;/OL&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&lt;STRONG&gt;&lt;FONT color="#339966"&gt;Option 2 (for older versions of Qlik Sense):&amp;nbsp;&lt;/FONT&gt;&lt;/STRONG&gt;&lt;/P&gt;
&lt;OL&gt;
&lt;LI&gt;Create a file in the same directory as the installer naming it&amp;nbsp;&lt;I&gt;the same name as the installer.config&lt;/I&gt;&lt;/LI&gt;
&lt;LI&gt;In the installer paste in this XML information:&lt;BR /&gt;&lt;LI-CODE lang="markup"&gt;&amp;lt;?xml version="1.0" encoding="utf-8" ?&amp;gt;
&amp;lt;configuration&amp;gt;
	&amp;lt;runtime&amp;gt;
		&amp;lt;enforceFIPSPolicy enabled="false" /&amp;gt;
	&amp;lt;/runtime&amp;gt;
&amp;lt;/configuration&amp;gt;​&lt;/LI-CODE&gt;&lt;/LI&gt;
&lt;LI&gt;Save the file&lt;/LI&gt;
&lt;LI&gt;Re-run the installer&lt;/LI&gt;
&lt;/OL&gt;
&lt;P&gt;&lt;STRONG&gt;Example:&lt;/STRONG&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;Installation file name: Qlik_Sense_setup.exe&lt;BR /&gt;Config file name: Qlik_Sense_setup.exe.config&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3&gt;&lt;FONT color="#339966"&gt;&lt;STRONG&gt;Cause:&lt;/STRONG&gt;&lt;/FONT&gt;&lt;/H3&gt;
&lt;P&gt;The Qlik Sense installer uses a third-party library (Npgsql) which is not built for systems with FIPS enabled. This limitation is uncovered when attempting to authenticate against a remote PostgreSQL database. Once the installation is complete, it is recommended to disable the FIPS check for Qlik Sense's services themselves as well , see&amp;nbsp;&lt;A href="https://community.qlik.com/t5/Knowledge-Base/Running-Qlik-Sense-on-Windows-systems-with-FIPS-compliance/ta-p/1715095" target="_blank" rel="noopener"&gt;Running Qlik Sense on Windows systems with FIPS compliance enabled&lt;/A&gt;&amp;nbsp;for direction there.&lt;/P&gt;</description>
    <pubDate>Wed, 15 Feb 2023 12:16:24 GMT</pubDate>
    <dc:creator>Andre_Sostizzo</dc:creator>
    <dc:date>2023-02-15T12:16:24Z</dc:date>
    <item>
      <title>Unable to install or upgrade Qlik Sense to a remote PostgreSQL database with FIPS enabled</title>
      <link>https://community.qlik.com/t5/Official-Support-Articles/Unable-to-install-or-upgrade-Qlik-Sense-to-a-remote-PostgreSQL/ta-p/1717223</link>
      <description>&lt;P&gt;When attempting to install or upgrade Qlik Sense Enterprise on Windows and connecting to a remote PostgreSQL database, the installer will fail to connect if FIPS is enabled.&lt;/P&gt;
&lt;P&gt;&lt;STRONG&gt;Error during installation:&amp;nbsp;&lt;/STRONG&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;&lt;SPAN&gt;The database could not be reached. Details: Exception has been thrown by the target of an invocation.&lt;/SPAN&gt;&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;SPAN&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-inline" image-alt="the database could not be reached.png" style="width: 502px;"&gt;&lt;img src="https://community.qlik.com/t5/image/serverpage/image-id/100566i8D32BDD9041693F0/image-size/large?v=v2&amp;amp;px=999" role="button" title="the database could not be reached.png" alt="the database could not be reached.png" /&gt;&lt;/span&gt;&lt;/SPAN&gt;&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&lt;STRONG&gt;Error during upgrade:&lt;/STRONG&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;This version of Qlik Sense requires a 'SenseServices' database for multi cloud capabilities. Ensure that you have a created a 'SenseService' database in your cluster before upgrading.&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;This version of Qlik Sense requires a 'QSMQ' database for multi cloud capabilities. Ensure that you have a created a 'QSMQ' database in your cluster before upgrading.&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;FONT face="courier new,courier"&gt;This version of Qlik Sense requires a 'Licenses' database for multi cloud capabilities. Ensure that you have a created a 'Licenses' database in your cluster before upgrading.&lt;/FONT&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&lt;span class="lia-inline-image-display-wrapper lia-image-align-inline" image-alt="this version of qlik sense requires a database for.png" style="width: 522px;"&gt;&lt;img src="https://community.qlik.com/t5/image/serverpage/image-id/100567i11B0363CF6FF8057/image-size/large?v=v2&amp;amp;px=999" role="button" title="this version of qlik sense requires a database for.png" alt="this version of qlik sense requires a database for.png" /&gt;&lt;/span&gt;&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3&gt;&lt;FONT color="#339966"&gt;&lt;STRONG&gt;Resolution:&lt;/STRONG&gt;&lt;/FONT&gt;&lt;/H3&gt;
&lt;P&gt;There are two options available.&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&lt;FONT color="#339966"&gt;&lt;STRONG&gt;Option 1 (for newer version of Qlik Sense):&lt;/STRONG&gt;&lt;/FONT&gt;&lt;/P&gt;
&lt;P&gt;Modify the password encryption for Postgres users and update it to use &lt;FONT face="courier new,courier"&gt;scram-sha-256&lt;/FONT&gt;.&lt;/P&gt;
&lt;OL&gt;
&lt;LI&gt;Log into your stand-alone Postgres database server&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Open PowerShell and navigate to the install location of PostgreSQL. IE:&amp;nbsp; &lt;FONT face="courier new,courier"&gt;C:\Program Files\PostgreSQL\12\bin&lt;/FONT&gt;&lt;/SPAN&gt;&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Access Postgres console:&amp;nbsp;&lt;FONT face="courier new,courier"&gt; .\psql -h localhost -p 4432 -U postgres&lt;/FONT&gt;&lt;/SPAN&gt;&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Run the following commands to update the encryption:&lt;/SPAN&gt;&lt;BR /&gt;
&lt;PRE&gt;postgres=# SHOW password_encryption;
 password_encryption
---------------------
 md5
(1 row)&lt;BR /&gt;
postgres=# SET password_encryption TO 'scram-sha-256';
SET&lt;BR /&gt;
postgres=# SHOW password_encryption;
 password_encryption
---------------------
 scram-sha-256
(1 row)&lt;BR /&gt;&lt;BR /&gt;****change the password from what is displayed in this example****
postgres=# ALTER USER postgres WITH PASSWORD 'yourpostgresuserpwd';
ALTER ROLE

postgres=# ALTER USER qliksenserepository WITH PASSWORD 'yourqliksensrepositoryuserpwd'; 
ALTER ROLE


--check if both have now a scram-sha-256 prefix

 SELECT usename, passwd FROM pg_shadow WHERE usename IN ('postgres', 'qliksenserepository');

      usename       |                    passwd
--------------------+--------------------------------------------------
 postgres | SCRAM-SHA-256$4096:[some scram-sha-256 hash...]=
 qliksenserepository           | SCRAM-SHA-256$4096:[some scram-sha-256 hash...]=&lt;/PRE&gt;
&lt;/LI&gt;
&lt;LI&gt;&lt;SPAN&gt;Run the Qlik Sense upgrade again&lt;/SPAN&gt;&lt;/LI&gt;
&lt;/OL&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;&lt;STRONG&gt;&lt;FONT color="#339966"&gt;Option 2 (for older versions of Qlik Sense):&amp;nbsp;&lt;/FONT&gt;&lt;/STRONG&gt;&lt;/P&gt;
&lt;OL&gt;
&lt;LI&gt;Create a file in the same directory as the installer naming it&amp;nbsp;&lt;I&gt;the same name as the installer.config&lt;/I&gt;&lt;/LI&gt;
&lt;LI&gt;In the installer paste in this XML information:&lt;BR /&gt;&lt;LI-CODE lang="markup"&gt;&amp;lt;?xml version="1.0" encoding="utf-8" ?&amp;gt;
&amp;lt;configuration&amp;gt;
	&amp;lt;runtime&amp;gt;
		&amp;lt;enforceFIPSPolicy enabled="false" /&amp;gt;
	&amp;lt;/runtime&amp;gt;
&amp;lt;/configuration&amp;gt;​&lt;/LI-CODE&gt;&lt;/LI&gt;
&lt;LI&gt;Save the file&lt;/LI&gt;
&lt;LI&gt;Re-run the installer&lt;/LI&gt;
&lt;/OL&gt;
&lt;P&gt;&lt;STRONG&gt;Example:&lt;/STRONG&gt;&lt;/P&gt;
&lt;P class="lia-indent-padding-left-30px"&gt;Installation file name: Qlik_Sense_setup.exe&lt;BR /&gt;Config file name: Qlik_Sense_setup.exe.config&lt;/P&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3&gt;&lt;FONT color="#339966"&gt;&lt;STRONG&gt;Cause:&lt;/STRONG&gt;&lt;/FONT&gt;&lt;/H3&gt;
&lt;P&gt;The Qlik Sense installer uses a third-party library (Npgsql) which is not built for systems with FIPS enabled. This limitation is uncovered when attempting to authenticate against a remote PostgreSQL database. Once the installation is complete, it is recommended to disable the FIPS check for Qlik Sense's services themselves as well , see&amp;nbsp;&lt;A href="https://community.qlik.com/t5/Knowledge-Base/Running-Qlik-Sense-on-Windows-systems-with-FIPS-compliance/ta-p/1715095" target="_blank" rel="noopener"&gt;Running Qlik Sense on Windows systems with FIPS compliance enabled&lt;/A&gt;&amp;nbsp;for direction there.&lt;/P&gt;</description>
      <pubDate>Wed, 15 Feb 2023 12:16:24 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Official-Support-Articles/Unable-to-install-or-upgrade-Qlik-Sense-to-a-remote-PostgreSQL/ta-p/1717223</guid>
      <dc:creator>Andre_Sostizzo</dc:creator>
      <dc:date>2023-02-15T12:16:24Z</dc:date>
    </item>
  </channel>
</rss>

