<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>article QlikView Services don't start: Shutting down service since there are data with invalid encryption in Official Support Articles</title>
    <link>https://community.qlik.com/t5/Official-Support-Articles/QlikView-Services-don-t-start-Shutting-down-service-since-there/ta-p/1716203</link>
    <description>&lt;P&gt;One or more of the following QlikView Services fail to start:&lt;/P&gt;
&lt;UL&gt;
&lt;LI&gt;QlikView Management Service (QMC)&lt;/LI&gt;
&lt;LI&gt;QlikView&amp;nbsp;Directory Service Connector (DSC)&lt;/LI&gt;
&lt;LI&gt;QlikView&amp;nbsp;Web Server (QVWS)&lt;/LI&gt;
&lt;LI&gt;QlikView&amp;nbsp;Distribution Service (QDS)&lt;/LI&gt;
&lt;/UL&gt;
&lt;P&gt;The following is logged in the individual services log files:&lt;BR /&gt;&amp;nbsp;&lt;/P&gt;
&lt;DIV style="margin-left: 40px;"&gt;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;Shutting down the service since there are data with invalid encryption. To continue, activate the 'EraseUndecryptableData' config flag by setting it to true in the config file to erase the invalid data.&lt;/SPAN&gt;&lt;/DIV&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H4 class="qlik-migrated-tkb-headings"&gt;&lt;STRONG&gt;Cause:&lt;/STRONG&gt;&lt;/H4&gt;
&lt;P&gt;&lt;BR /&gt;&lt;SPAN&gt;At start-up, each service validates all its encrypted data entries to ensure they are accessible. If the service encounters data that cannot be decrypted, it reports it as an error and stops its own execution.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;or&lt;BR /&gt;&lt;BR /&gt;The error found in the Management Service log indicates that there was a problem with the certificates used by the QlikView services and that it can no longer decrypt important data.&lt;BR /&gt;&lt;BR /&gt;This can be caused by:&lt;/P&gt;
&lt;UL&gt;
&lt;LI&gt;An upgrade failure&lt;/LI&gt;
&lt;LI&gt;An invalid certificate&lt;/LI&gt;
&lt;LI&gt;Accidental deletion of certificates&lt;/LI&gt;
&lt;/UL&gt;
&lt;P&gt;&lt;BR /&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3 class="qlik-migrated-tkb-headings"&gt;&lt;STRONG&gt;Resolution:&lt;/STRONG&gt;&lt;/H3&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;The process for erasing the "UndecryptableData" requires a modification to the individual services configuration files.&amp;nbsp;&lt;BR /&gt;&lt;BR /&gt;For an overview on this topic, please review the QlikView online help chapter on&lt;A href="https://help.qlik.com/en-US/qlikview/Subsystems/Server/Content/QV_Server/QlikView-Server/QVSRM_CertificateTrustNew.htm" target="_blank" rel="noopener"&gt; Certificate Trust&lt;/A&gt;, in particular the Undecryptable Data section.&lt;BR /&gt;&lt;BR /&gt;The below example was written for the QlikView Management Service but can be adapted for any other service.&amp;nbsp;&lt;BR /&gt;&lt;BR /&gt;To delete "UndecryptableData",&amp;nbsp; add a value to the&amp;nbsp;&lt;STRONG&gt;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;QVManagementService.exe.config&lt;/SPAN&gt;&lt;/STRONG&gt;&amp;nbsp;file, unless it is already present.&lt;/P&gt;
&lt;UL&gt;
&lt;LI&gt;Shut down the QlikView Management service&amp;nbsp;&lt;/LI&gt;
&lt;LI&gt;Locate the file&lt;STRONG&gt;&amp;nbsp;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;QVManagementService.exe.config&lt;/SPAN&gt;&lt;/STRONG&gt;&amp;nbsp;&amp;nbsp;by default located in&lt;STRONG&gt;&amp;nbsp;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;"C:\Program Files\QlikView\Management Service"&lt;/SPAN&gt;&lt;/STRONG&gt;&lt;/LI&gt;
&lt;LI&gt;Open the file in a text editor&lt;/LI&gt;
&lt;LI&gt;Below&amp;nbsp; &lt;SPAN style="font-family: courier new,courier,monospace;"&gt;&amp;lt;!-- ****** QlikView Management&amp;nbsp;Service - BACKEND ****** --&amp;gt; &lt;/SPAN&gt;add the following section:&lt;/LI&gt;
&lt;/UL&gt;
&lt;DIV style="margin-left: 40px;"&gt;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;&amp;nbsp;&amp;lt;!-- Set to true if the Management&amp;nbsp;service will not start due to being unable to decrypt after upgrade --&amp;gt;&amp;nbsp;&lt;BR /&gt;&amp;lt;add key="EraseUndecryptableData" value="true"/&amp;gt;&amp;nbsp;&lt;/SPAN&gt;&lt;/DIV&gt;
&lt;UL&gt;
&lt;LI&gt;Save the file in the original location.&lt;/LI&gt;
&lt;LI&gt;Start the QlikView Management service from Windows Services console and verify it starts up and then stops again.&lt;/LI&gt;
&lt;LI&gt;Repeat the steps, removing the line this time, and restart the service once more.&lt;/LI&gt;
&lt;/UL&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H4&gt;&lt;STRONG&gt;Related Content:&lt;/STRONG&gt;&lt;/H4&gt;
&lt;UL&gt;
&lt;LI&gt;&lt;A href="https://community.qlik.com/t5/Support-Knowledge-Base/Error-1067-when-starting-QlikView-services/ta-p/1710924" target="_blank" rel="noopener"&gt;Error 1067 when starting QlikView services &lt;/A&gt;&amp;nbsp;&lt;/LI&gt;
&lt;LI&gt;&lt;A href="https://community.qlik.com/t5/Support-Knowledge-Base/QlikView-Distribution-Service-error-on-start-up-1067-Process/ta-p/1712527" target="_blank" rel="noopener"&gt;QlikView Distribution Service error on start-up 1067: Process terminated unexpectedly&lt;/A&gt;&amp;nbsp;&lt;/LI&gt;
&lt;/UL&gt;</description>
    <pubDate>Fri, 09 Oct 2020 10:00:55 GMT</pubDate>
    <dc:creator>Sonja_Bauernfeind</dc:creator>
    <dc:date>2020-10-09T10:00:55Z</dc:date>
    <item>
      <title>QlikView Services don't start: Shutting down service since there are data with invalid encryption</title>
      <link>https://community.qlik.com/t5/Official-Support-Articles/QlikView-Services-don-t-start-Shutting-down-service-since-there/ta-p/1716203</link>
      <description>&lt;P&gt;One or more of the following QlikView Services fail to start:&lt;/P&gt;
&lt;UL&gt;
&lt;LI&gt;QlikView Management Service (QMC)&lt;/LI&gt;
&lt;LI&gt;QlikView&amp;nbsp;Directory Service Connector (DSC)&lt;/LI&gt;
&lt;LI&gt;QlikView&amp;nbsp;Web Server (QVWS)&lt;/LI&gt;
&lt;LI&gt;QlikView&amp;nbsp;Distribution Service (QDS)&lt;/LI&gt;
&lt;/UL&gt;
&lt;P&gt;The following is logged in the individual services log files:&lt;BR /&gt;&amp;nbsp;&lt;/P&gt;
&lt;DIV style="margin-left: 40px;"&gt;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;Shutting down the service since there are data with invalid encryption. To continue, activate the 'EraseUndecryptableData' config flag by setting it to true in the config file to erase the invalid data.&lt;/SPAN&gt;&lt;/DIV&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H4 class="qlik-migrated-tkb-headings"&gt;&lt;STRONG&gt;Cause:&lt;/STRONG&gt;&lt;/H4&gt;
&lt;P&gt;&lt;BR /&gt;&lt;SPAN&gt;At start-up, each service validates all its encrypted data entries to ensure they are accessible. If the service encounters data that cannot be decrypted, it reports it as an error and stops its own execution.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;or&lt;BR /&gt;&lt;BR /&gt;The error found in the Management Service log indicates that there was a problem with the certificates used by the QlikView services and that it can no longer decrypt important data.&lt;BR /&gt;&lt;BR /&gt;This can be caused by:&lt;/P&gt;
&lt;UL&gt;
&lt;LI&gt;An upgrade failure&lt;/LI&gt;
&lt;LI&gt;An invalid certificate&lt;/LI&gt;
&lt;LI&gt;Accidental deletion of certificates&lt;/LI&gt;
&lt;/UL&gt;
&lt;P&gt;&lt;BR /&gt;&amp;nbsp;&lt;/P&gt;
&lt;H3 class="qlik-migrated-tkb-headings"&gt;&lt;STRONG&gt;Resolution:&lt;/STRONG&gt;&lt;/H3&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;P&gt;The process for erasing the "UndecryptableData" requires a modification to the individual services configuration files.&amp;nbsp;&lt;BR /&gt;&lt;BR /&gt;For an overview on this topic, please review the QlikView online help chapter on&lt;A href="https://help.qlik.com/en-US/qlikview/Subsystems/Server/Content/QV_Server/QlikView-Server/QVSRM_CertificateTrustNew.htm" target="_blank" rel="noopener"&gt; Certificate Trust&lt;/A&gt;, in particular the Undecryptable Data section.&lt;BR /&gt;&lt;BR /&gt;The below example was written for the QlikView Management Service but can be adapted for any other service.&amp;nbsp;&lt;BR /&gt;&lt;BR /&gt;To delete "UndecryptableData",&amp;nbsp; add a value to the&amp;nbsp;&lt;STRONG&gt;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;QVManagementService.exe.config&lt;/SPAN&gt;&lt;/STRONG&gt;&amp;nbsp;file, unless it is already present.&lt;/P&gt;
&lt;UL&gt;
&lt;LI&gt;Shut down the QlikView Management service&amp;nbsp;&lt;/LI&gt;
&lt;LI&gt;Locate the file&lt;STRONG&gt;&amp;nbsp;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;QVManagementService.exe.config&lt;/SPAN&gt;&lt;/STRONG&gt;&amp;nbsp;&amp;nbsp;by default located in&lt;STRONG&gt;&amp;nbsp;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;"C:\Program Files\QlikView\Management Service"&lt;/SPAN&gt;&lt;/STRONG&gt;&lt;/LI&gt;
&lt;LI&gt;Open the file in a text editor&lt;/LI&gt;
&lt;LI&gt;Below&amp;nbsp; &lt;SPAN style="font-family: courier new,courier,monospace;"&gt;&amp;lt;!-- ****** QlikView Management&amp;nbsp;Service - BACKEND ****** --&amp;gt; &lt;/SPAN&gt;add the following section:&lt;/LI&gt;
&lt;/UL&gt;
&lt;DIV style="margin-left: 40px;"&gt;&lt;SPAN style="font-family: courier new,courier,monospace;"&gt;&amp;nbsp;&amp;lt;!-- Set to true if the Management&amp;nbsp;service will not start due to being unable to decrypt after upgrade --&amp;gt;&amp;nbsp;&lt;BR /&gt;&amp;lt;add key="EraseUndecryptableData" value="true"/&amp;gt;&amp;nbsp;&lt;/SPAN&gt;&lt;/DIV&gt;
&lt;UL&gt;
&lt;LI&gt;Save the file in the original location.&lt;/LI&gt;
&lt;LI&gt;Start the QlikView Management service from Windows Services console and verify it starts up and then stops again.&lt;/LI&gt;
&lt;LI&gt;Repeat the steps, removing the line this time, and restart the service once more.&lt;/LI&gt;
&lt;/UL&gt;
&lt;P&gt;&amp;nbsp;&lt;/P&gt;
&lt;H4&gt;&lt;STRONG&gt;Related Content:&lt;/STRONG&gt;&lt;/H4&gt;
&lt;UL&gt;
&lt;LI&gt;&lt;A href="https://community.qlik.com/t5/Support-Knowledge-Base/Error-1067-when-starting-QlikView-services/ta-p/1710924" target="_blank" rel="noopener"&gt;Error 1067 when starting QlikView services &lt;/A&gt;&amp;nbsp;&lt;/LI&gt;
&lt;LI&gt;&lt;A href="https://community.qlik.com/t5/Support-Knowledge-Base/QlikView-Distribution-Service-error-on-start-up-1067-Process/ta-p/1712527" target="_blank" rel="noopener"&gt;QlikView Distribution Service error on start-up 1067: Process terminated unexpectedly&lt;/A&gt;&amp;nbsp;&lt;/LI&gt;
&lt;/UL&gt;</description>
      <pubDate>Fri, 09 Oct 2020 10:00:55 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Official-Support-Articles/QlikView-Services-don-t-start-Shutting-down-service-since-there/ta-p/1716203</guid>
      <dc:creator>Sonja_Bauernfeind</dc:creator>
      <dc:date>2020-10-09T10:00:55Z</dc:date>
    </item>
  </channel>
</rss>

