<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: Problem with Pig Job: UnknownHostException in Talend Studio</title>
    <link>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224917#M17439</link>
    <description>For reference (as I had this problem again today and could not remember), the solution is adding the hostname to your /etc/hosts file like this: 
&lt;BR /&gt;127.0.0.1 localhost speedport_w723_v_typ_a_1_00_098</description>
    <pubDate>Wed, 18 Sep 2013 11:56:29 GMT</pubDate>
    <dc:creator>Anonymous</dc:creator>
    <dc:date>2013-09-18T11:56:29Z</dc:date>
    <item>
      <title>Problem with Pig Job: UnknownHostException</title>
      <link>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224913#M17435</link>
      <description>&lt;P&gt;Hi,&lt;BR /&gt;I use Apache Hadoop 1.0 on a Mac in pseudo-distributed mode. The installation works with Talend HDFS components.&lt;BR /&gt;I have a simple Pig Job (load, distinct, filter, store), as described in the component guide. I think the configuration of the Talend components is okay (namenode: "hdfs://localhost:9000", jobtracker host: "localhost:9001". The problem is probably a wrong configuration on my Mac OS or I have to add something to my Hadoop configuration (which is almost only default values)?!&lt;BR /&gt;I get the exception (attached at the end) when running the job.&lt;BR /&gt;"speedport_w723_v_typ_a_1_00_096" (which is the unknown host of the exception) is the name which I see in systems preferences of my Mac =&amp;gt; To log in to this computer remotely, type "ssh kai@speedport_w723_v_typ_a_1_00_096".&lt;BR /&gt;Probably, this is no real Talend problem, but I am missing enough background knowledge to solve it. Maybe you can help?&lt;BR /&gt;Thank you.&lt;BR /&gt;Best regards,&lt;BR /&gt;Kai&lt;/P&gt; 
&lt;PRE&gt;Starting job PigAnalyzerJob at 16:06 02/01/2013.&lt;BR /&gt;&lt;BR /&gt; connecting to socket on port 4038&lt;BR /&gt; connected&lt;BR /&gt;WARNING: org.apache.hadoop.metrics.jvm.EventCounter is deprecated. Please use org.apache.hadoop.log.metrics.EventCounter in all the log4j.properties files.&lt;BR /&gt;13/01/02 16:06:35 INFO executionengine.HExecutionEngine: Connecting to hadoop file system at: hdfs://localhost:9000&lt;BR /&gt;2013-01-02 16:06:35.609 java Unable to load realm info from SCDynamicStore&lt;BR /&gt;13/01/02 16:06:36 INFO executionengine.HExecutionEngine: Connecting to map-reduce job tracker at: localhost:9001&lt;BR /&gt;13/01/02 16:06:36 INFO pigstats.ScriptState: Pig features used in the script: DISTINCT,FILTER&lt;BR /&gt;13/01/02 16:06:37 INFO mapReduceLayer.MRCompiler: File concatenation threshold: 100 optimistic? false&lt;BR /&gt;13/01/02 16:06:37 INFO mapReduceLayer.MultiQueryOptimizer: MR plan size before optimization: 1&lt;BR /&gt;13/01/02 16:06:37 INFO mapReduceLayer.MultiQueryOptimizer: MR plan size after optimization: 1&lt;BR /&gt;13/01/02 16:06:37 INFO pigstats.ScriptState: Pig script settings are added to the job&lt;BR /&gt;13/01/02 16:06:37 INFO mapReduceLayer.JobControlCompiler: mapred.job.reduce.markreset.buffer.percent is not set, set to default 0.3&lt;BR /&gt;13/01/02 16:06:37 INFO mapReduceLayer.JobControlCompiler: creating jar file Job7394100148415978202.jar&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.JobControlCompiler: jar file Job7394100148415978202.jar created&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.JobControlCompiler: Setting up single store job&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.JobControlCompiler: Setting identity combiner class.&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.JobControlCompiler: BytesPerReducer=1000000000 maxReducers=999 totalInputFileSize=0&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.JobControlCompiler: Neither PARALLEL nor default parallelism is set for this job. Setting number of reducers to 1&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.MapReduceLauncher: 1 map-reduce job(s) waiting for submission.&lt;BR /&gt;13/01/02 16:06:39 WARN mapred.JobClient: Use GenericOptionsParser for parsing the arguments. Applications should implement Tool for the same.&lt;BR /&gt;13/01/02 16:06:39 INFO mapred.JobClient: Cleaning up the staging area hdfs://localhost:9000/tmp/hadoop-kwahner/mapred/staging/kwahner/.staging/job_201301021559_0001&lt;BR /&gt;13/01/02 16:06:39 ERROR security.UserGroupInformation: PriviledgedActionException as:kwahner cause:java.net.UnknownHostException: speedport_w723_v_typ_a_1_00_096: speedport_w723_v_typ_a_1_00_096: nodename nor servname provided, or not known&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.MapReduceLauncher: 0% complete&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.MapReduceLauncher: job null has failed! Stop running all dependent jobs&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.MapReduceLauncher: 100% complete&lt;BR /&gt;13/01/02 16:06:39 WARN mapReduceLayer.Launcher: There is no log file to write to.&lt;BR /&gt;13/01/02 16:06:39 ERROR mapReduceLayer.Launcher: Backend error message during job submission&lt;BR /&gt;java.net.UnknownHostException: speedport_w723_v_typ_a_1_00_096: speedport_w723_v_typ_a_1_00_096: nodename nor servname provided, or not known&lt;BR /&gt;	at java.net.InetAddress.getLocalHost(InetAddress.java:1438)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient$2.run(JobClient.java:874)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient$2.run(JobClient.java:850)&lt;BR /&gt;	at java.security.AccessController.doPrivileged(Native Method)&lt;BR /&gt;	at javax.security.auth.Subject.doAs(Subject.java:415)&lt;BR /&gt;	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1083)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient.submitJobInternal(JobClient.java:850)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient.submitJob(JobClient.java:824)&lt;BR /&gt; disconnected&lt;BR /&gt;	at org.apache.hadoop.mapred.jobcontrol.Job.submit(Job.java:378)&lt;BR /&gt;	at org.apache.hadoop.mapred.jobcontrol.JobControl.startReadyJobs(JobControl.java:247)&lt;BR /&gt;	at org.apache.hadoop.mapred.jobcontrol.JobControl.run(JobControl.java:279)&lt;BR /&gt;	at java.lang.Thread.run(Thread.java:722)&lt;BR /&gt;Caused by: java.net.UnknownHostException: speedport_w723_v_typ_a_1_00_096: nodename nor servname provided, or not known&lt;BR /&gt;	at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)&lt;BR /&gt;	at java.net.InetAddress$1.lookupAllHostAddr(InetAddress.java:866)&lt;BR /&gt;	at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1258)&lt;BR /&gt;	at java.net.InetAddress.getLocalHost(InetAddress.java:1434)&lt;BR /&gt;	... 11 more&lt;BR /&gt;13/01/02 16:06:39 ERROR pigstats.SimplePigStats: ERROR 2997: Unable to recreate exception from backend error: java.net.UnknownHostException: speedport_w723_v_typ_a_1_00_096: speedport_w723_v_typ_a_1_00_096: nodename nor servname provided, or not known&lt;BR /&gt;13/01/02 16:06:39 ERROR pigstats.PigStatsUtil: 1 map reduce job(s) failed!&lt;BR /&gt;13/01/02 16:06:39 INFO pigstats.SimplePigStats: Script Statistics: &lt;BR /&gt;HadoopVersion	PigVersion	UserId	StartedAt	FinishedAt	Features&lt;BR /&gt;1.0.0	0.9.2	kwahner	2013-01-02 16:06:37	2013-01-02 16:06:39	DISTINCT,FILTER&lt;BR /&gt;Failed!&lt;BR /&gt;Failed Jobs:&lt;BR /&gt;JobId	Alias	Feature	Message	Outputs&lt;BR /&gt;N/A	tPigFilterRow_1_RESULT,tPigLoad_1_RESULT	DISTINCT	Message: java.net.UnknownHostException: speedport_w723_v_typ_a_1_00_096: speedport_w723_v_typ_a_1_00_096: nodename nor servname provided, or not known&lt;BR /&gt;	at java.net.InetAddress.getLocalHost(InetAddress.java:1438)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient$2.run(JobClient.java:874)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient$2.run(JobClient.java:850)&lt;BR /&gt;	at java.security.AccessController.doPrivileged(Native Method)&lt;BR /&gt;	at javax.security.auth.Subject.doAs(Subject.java:415)&lt;BR /&gt;	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1083)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient.submitJobInternal(JobClient.java:850)&lt;BR /&gt;	at org.apache.hadoop.mapred.JobClient.submitJob(JobClient.java:824)&lt;BR /&gt;	at org.apache.hadoop.mapred.jobcontrol.Job.submit(Job.java:378)&lt;BR /&gt;	at org.apache.hadoop.mapred.jobcontrol.JobControl.startReadyJobs(JobControl.java:247)&lt;BR /&gt;	at org.apache.hadoop.mapred.jobcontrol.JobControl.run(JobControl.java:279)&lt;BR /&gt;	at java.lang.Thread.run(Thread.java:722)&lt;BR /&gt;Caused by: java.net.UnknownHostException: speedport_w723_v_typ_a_1_00_096: nodename nor servname provided, or not known&lt;BR /&gt;	at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)&lt;BR /&gt;	at java.net.InetAddress$1.lookupAllHostAddr(InetAddress.java:866)&lt;BR /&gt;	at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1258)&lt;BR /&gt;	at java.net.InetAddress.getLocalHost(InetAddress.java:1434)&lt;BR /&gt;	... 11 more&lt;BR /&gt;	/Users/kwahner/Desktop/people_filtered.txt,&lt;BR /&gt;Input(s):&lt;BR /&gt;Failed to read data from "/Users/kwahner/Desktop/people.txt"&lt;BR /&gt;Output(s):&lt;BR /&gt;Failed to produce result in "/Users/kwahner/Desktop/people_filtered.txt"&lt;BR /&gt;Counters:&lt;BR /&gt;Total records written : 0&lt;BR /&gt;Total bytes written : 0&lt;BR /&gt;Spillable Memory Manager spill count : 0&lt;BR /&gt;Total bags proactively spilled: 0&lt;BR /&gt;Total records proactively spilled: 0&lt;BR /&gt;Job DAG:&lt;BR /&gt;null&lt;BR /&gt;&lt;BR /&gt;13/01/02 16:06:39 INFO mapReduceLayer.MapReduceLauncher: Failed!&lt;BR /&gt;Job PigAnalyzerJob ended at 16:06 02/01/2013. &lt;/PRE&gt;</description>
      <pubDate>Sat, 16 Nov 2024 12:07:38 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224913#M17435</guid>
      <dc:creator>Anonymous</dc:creator>
      <dc:date>2024-11-16T12:07:38Z</dc:date>
    </item>
    <item>
      <title>Re: Problem with Pig Job: UnknownHostException</title>
      <link>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224914#M17436</link>
      <description>The following maybe of help
&lt;BR /&gt;1. 
&lt;A href="http://stackoverflow.com/questions/6307244/hadoop-namenode-format-returns-a-java-net-unknownhostexception" rel="nofollow noopener noreferrer"&gt;http://stackoverflow.com/questions/6307244/hadoop-namenode-format-returns-a-java-net-unknownhostexception&lt;/A&gt;
&lt;BR /&gt;2. 
&lt;A href="http://www.thegeekstuff.com/2012/02/hadoop-pseudo-distributed-installation/" rel="nofollow noopener noreferrer"&gt;http://www.thegeekstuff.com/2012/02/hadoop-pseudo-distributed-installation/&lt;/A&gt;
&lt;BR /&gt;Ciaran</description>
      <pubDate>Thu, 17 Jan 2013 23:01:26 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224914#M17436</guid>
      <dc:creator>Anonymous</dc:creator>
      <dc:date>2013-01-17T23:01:26Z</dc:date>
    </item>
    <item>
      <title>Re: Problem with Pig Job: UnknownHostException</title>
      <link>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224915#M17437</link>
      <description>Hi,&lt;BR /&gt;Did you find the solution?&lt;BR /&gt;thanks &lt;span class="lia-unicode-emoji" title=":grinning_face_with_big_eyes:"&gt;😃&lt;/span&gt;</description>
      <pubDate>Sun, 17 Mar 2013 19:14:42 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224915#M17437</guid>
      <dc:creator>Anonymous</dc:creator>
      <dc:date>2013-03-17T19:14:42Z</dc:date>
    </item>
    <item>
      <title>Re: Problem with Pig Job: UnknownHostException</title>
      <link>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224916#M17438</link>
      <description>It is a problem with the hosts file. Depending on where your Hadoop server is located (in my case in a VM), you might change some VM settings and / or configure your hosts file.&lt;BR /&gt;Please check Ciaran's links. They might help you.</description>
      <pubDate>Sun, 17 Mar 2013 22:54:42 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224916#M17438</guid>
      <dc:creator>Anonymous</dc:creator>
      <dc:date>2013-03-17T22:54:42Z</dc:date>
    </item>
    <item>
      <title>Re: Problem with Pig Job: UnknownHostException</title>
      <link>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224917#M17439</link>
      <description>For reference (as I had this problem again today and could not remember), the solution is adding the hostname to your /etc/hosts file like this: 
&lt;BR /&gt;127.0.0.1 localhost speedport_w723_v_typ_a_1_00_098</description>
      <pubDate>Wed, 18 Sep 2013 11:56:29 GMT</pubDate>
      <guid>https://community.qlik.com/t5/Talend-Studio/Problem-with-Pig-Job-UnknownHostException/m-p/2224917#M17439</guid>
      <dc:creator>Anonymous</dc:creator>
      <dc:date>2013-09-18T11:56:29Z</dc:date>
    </item>
  </channel>
</rss>

