<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic &amp;quot;Failed to load document, You don't have access...&amp;quot; Popup fix/suppression using AJAX client. in QlikView</title>
    <link>https://community.qlik.com/t5/QlikView/quot-Failed-to-load-document-You-don-t-have-access-quot-Popup/m-p/831852#M292719</link>
    <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hi,&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I realize similar issues have been posted several times before, but in researching all other posts I am yet to find a solution to my issue.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;My server setup is:&lt;/P&gt;&lt;P&gt;QlikView Server version 11.20.12354.0 Enterprise Edition with 5 Document CAL's&lt;/P&gt;&lt;P&gt;Windows Server 2008 R2 Standard Service Pack 1 (64 bit edition)&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;SPAN style="text-decoration: underline;"&gt;Qlikview Server configuration:&lt;/SPAN&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;First, I created a custom directory (Directory Service Connector) with a username &amp;amp; password. I then created a custom user for this directory. To this custom user, I then assigned 1 of my Document CAL's from the Documents &amp;gt; File.qvw &amp;gt; Document CALs tab of the file I wish to access via AJAX. I also ensured that the Authorization tab &amp;gt; Users with Access to this Document was set to "All users".&lt;/SPAN&gt;&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;To ensure that the custom user directory works, I have the QVS set to DMS authorization (not NTFS). I then set the QVWS authentication type to "Custom User" and the Login Address to "Alternate login page (web form).&lt;BR /&gt;&lt;/SPAN&gt;&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;SPAN&gt;Next, I create a simple HTML file that embeds the Qlikview document in an iFrame. I will access this file from a remote computer outside the server with a path similar to &lt;/SPAN&gt;&lt;A class="jive-link-external-small" href="http://dev-qlikview/qvajaxzfc/Dashboard.html" rel="nofollow"&gt;http://dev-qlikview/qvajaxzfc/Dashboard.html&lt;/A&gt;&lt;SPAN&gt;.&lt;/SPAN&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;Now, when I access the path via a different computer I am initially met with a popup that says "Failed to load this document, you don't have access to this document", then the web form appears in my iframe and I am then able to successfully login with my username and password I created in the custom directory.&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;My issue is: &lt;/STRONG&gt;I am using this Qlikview Document as a demonstration to clients. If clients see the "Failed to load this document" popup, they will become confused and think the demonstration is broken. &lt;EM&gt;How can I suppress this popup?&lt;/EM&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="text-decoration: underline;"&gt;Document fixes I have performed:&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;Under Document properties &amp;gt; Opening tab &amp;gt; Uncheck both Initial Data reduction based on Section Access &amp;amp; Strict Exclusion&lt;/LI&gt;&lt;LI&gt;Ensure there is no section access to this document&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I'd greatly appreciate any help on this issue. I've spent several days researching fixes to no avail. Let me know if I need to provide any more information.&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
    <pubDate>Tue, 31 Mar 2015 19:21:21 GMT</pubDate>
    <dc:creator />
    <dc:date>2015-03-31T19:21:21Z</dc:date>
    <item>
      <title>"Failed to load document, You don't have access..." Popup fix/suppression using AJAX client.</title>
      <link>https://community.qlik.com/t5/QlikView/quot-Failed-to-load-document-You-don-t-have-access-quot-Popup/m-p/831852#M292719</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;P&gt;Hi,&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I realize similar issues have been posted several times before, but in researching all other posts I am yet to find a solution to my issue.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;My server setup is:&lt;/P&gt;&lt;P&gt;QlikView Server version 11.20.12354.0 Enterprise Edition with 5 Document CAL's&lt;/P&gt;&lt;P&gt;Windows Server 2008 R2 Standard Service Pack 1 (64 bit edition)&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;SPAN style="text-decoration: underline;"&gt;Qlikview Server configuration:&lt;/SPAN&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;First, I created a custom directory (Directory Service Connector) with a username &amp;amp; password. I then created a custom user for this directory. To this custom user, I then assigned 1 of my Document CAL's from the Documents &amp;gt; File.qvw &amp;gt; Document CALs tab of the file I wish to access via AJAX. I also ensured that the Authorization tab &amp;gt; Users with Access to this Document was set to "All users".&lt;/SPAN&gt;&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;To ensure that the custom user directory works, I have the QVS set to DMS authorization (not NTFS). I then set the QVWS authentication type to "Custom User" and the Login Address to "Alternate login page (web form).&lt;BR /&gt;&lt;/SPAN&gt;&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;&lt;SPAN style="font-size: 10pt; line-height: 1.5em;"&gt;&lt;SPAN&gt;Next, I create a simple HTML file that embeds the Qlikview document in an iFrame. I will access this file from a remote computer outside the server with a path similar to &lt;/SPAN&gt;&lt;A class="jive-link-external-small" href="http://dev-qlikview/qvajaxzfc/Dashboard.html" rel="nofollow"&gt;http://dev-qlikview/qvajaxzfc/Dashboard.html&lt;/A&gt;&lt;SPAN&gt;.&lt;/SPAN&gt;&lt;BR /&gt;&lt;/SPAN&gt;&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;Now, when I access the path via a different computer I am initially met with a popup that says "Failed to load this document, you don't have access to this document", then the web form appears in my iframe and I am then able to successfully login with my username and password I created in the custom directory.&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;STRONG&gt;My issue is: &lt;/STRONG&gt;I am using this Qlikview Document as a demonstration to clients. If clients see the "Failed to load this document" popup, they will become confused and think the demonstration is broken. &lt;EM&gt;How can I suppress this popup?&lt;/EM&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;SPAN style="text-decoration: underline;"&gt;Document fixes I have performed:&lt;/SPAN&gt;&lt;/P&gt;&lt;UL&gt;&lt;LI&gt;Under Document properties &amp;gt; Opening tab &amp;gt; Uncheck both Initial Data reduction based on Section Access &amp;amp; Strict Exclusion&lt;/LI&gt;&lt;LI&gt;Ensure there is no section access to this document&lt;/LI&gt;&lt;/UL&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I'd greatly appreciate any help on this issue. I've spent several days researching fixes to no avail. Let me know if I need to provide any more information.&lt;/P&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Tue, 31 Mar 2015 19:21:21 GMT</pubDate>
      <guid>https://community.qlik.com/t5/QlikView/quot-Failed-to-load-document-You-don-t-have-access-quot-Popup/m-p/831852#M292719</guid>
      <dc:creator />
      <dc:date>2015-03-31T19:21:21Z</dc:date>
    </item>
  </channel>
</rss>

