Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
master_t
Partner - Creator II
Partner - Creator II

Can't connect to Qlik Sense: timeout error during configuration

Hello everyone

I'm trying out Qlik Alerting, but I got stuck during the initial configuration phase.

In particular, the problem is when configuring the connection to Qlik Sense. I've entered all the information correctly, but when I click next this error show up:

master_t_1-1589448942365.png

 

Does anyone know what's going wrong here?

Some further info:

  • Qlik Sense is running correctly (on the same machine)
  • The virtual proxy is configured for Windows authentication and the session cookie name is correct
  • The user qlik_admin has the RootAdmin role
  • I'm connecting using localhost (QS and Qlik Alerting are on the same machine), so there shouldn't be any issues with ports/firewall) 

Any ideas of what's going on?

Labels (1)
1 Solution

Accepted Solutions
master_t
Partner - Creator II
Partner - Creator II
Author

Well, I did the configuration together with Qlik support and this time it worked without issues... Murphy's law I guess 😅

View solution in original post

6 Replies
Sunil_Kenth
Former Employee
Former Employee

Hi

Did you manage to resolve this?

Can you try using the i.p or host name of the machine to generate the Qlik Sense certs pem files and then use the same i.p or host name in the Qlik Alerting data source configuration page?

Thanks,

Sunil 

master_t
Partner - Creator II
Partner - Creator II
Author

Hello Sunil, thanks for your reply.

I'm already using the exported certificates with the appropriate names, even re-exported them to make sure. I tried connecting both with hostname "localhost" and with the actual public domain name of the machine, but same result.

I did further testing, actually I think the "timeout" error was temporary, I did MANY more tries, including reinstalling Qlik Alerting, the actual error I'm getting is this:

master_t_0-1589808575723.png

So, an "internal server error", with an underlying HTTP 409 error under the hood.

I checked the Qlik Alerting server logs, but nothing get written there when this error happens.

I also submitted this problem to Qlik support, but I haven't got any feedback as of yet. 

Brendan
Partner - Contributor II
Partner - Contributor II

Hi,

Did you get any answers on this?

I am facing the same 'Internal Server Error. Please check logs' on step 5 of the installation.

I also can't find anything in the Qlik Alerting logs, although unsure which logs to check (message is very vague)

Thanks

Brendan

master_t
Partner - Creator II
Partner - Creator II
Author

I've already contacted qlik support about this. They did some tests on my server, but couldn't figure it out, I'm now waiting for the dev team to analyze the case and get back to me. I'll update this thread as soon as there's any news.

Brendan
Partner - Contributor II
Partner - Contributor II

Hi,

I got around this by redoing the installation, using a different SMTP server and Connect as User.

To redo the installation you have to:

  1. Uninstall Qlik Alerting through Windows Programs (you may need to reboot machine if services won't stop)
  2. Install Robo 3T and connect to the Mongo DB and right click to drop the Qlik Alerting Database
  3. Reinstall Qlik Alerting

I don't believe that particular log is written anywhere and any time I come across that error now, I don't waste time looking for the log and just try something different.

Hope that helps.

Brendan

master_t
Partner - Creator II
Partner - Creator II
Author

Well, I did the configuration together with Qlik support and this time it worked without issues... Murphy's law I guess 😅