Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Join us for a live Q&A! September 21, 10 AM ET - Onboarding Fast in Qlik Sense SaaS! REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Brip51
Creator
Creator

Duplicate existing extension Invalid Vis

Hi,

I am trying to duplicate an existing extension and then modify it slightly.

In the Dev Hub I duplicate the extension and rename it. When I test the duplicated extension without making any modifications I get a message - 

"Invalid Visualization. The visualization was not found on the server. This extension is not available: SelectionTest1 ({1})"

Since I am duplicating an existing extension I am not sure what the issue is.

Any ideas on what I am missing would be greatly appreciated.  

This is my first time trying to modify and extension.  My update works in the original extension when I test it, but I do not want to change that original extension.

 

Thanks,

Brian

 

 

Labels (1)
1 Solution

Accepted Solutions
ErikWetterberg

So, there is a problem with properties.js. Does it exist? Is there any syntax error in it? Does it have any dependencies?

View solution in original post

7 Replies
ErikWetterberg

Check the array of dependencies in the extension. Also check for syntax errors, like missing curly braces  or extra curly braces.

Brip51
Creator
Creator
Author

the original dependency was-

define(['jquery', 'qlik', 'css!./FEI-SelectionsApplier.css', './properties'],

I updated that to the new name-

define(['jquery', 'qlik', 'css!./SelAPCust.css', './properties'],

I believe that is correct. 

also I went through the code to check the syntax and it matched the original code (which works).

Thank you for your help.  If you have any other thoughts please reply.

ErikWetterberg

Do you get any errors in the browser console? Like 404 not found etc.

 

Brip51
Creator
Creator
Author

Yes. Thanks.  I didn't even think to look there! 

Failed to load resource: the server responded with a status of 404 (Not Found)
/resources/chunks/setup-view.aaafe511db98d706b7b3.js:8 Error: Script error for "extensions/SelAPCust/properties", needed by: extensions/SelAPCust/SelAPCust
http://requirejs.org/docs/errors.html#scripterror
at makeError (/resources/chunks/setup-view.aaafe511db98d706b7b3.js:8)
at HTMLScriptElement.onScriptError (/resources/chunks/setup-view.aaafe511db98d706b7b3.js:8)

 

I don't know what it means or why I would get the error with the same code.

ErikWetterberg

So, there is a problem with properties.js. Does it exist? Is there any syntax error in it? Does it have any dependencies?

View solution in original post

Brip51
Creator
Creator
Author

Thanks Erik,

I got it to work.  

I created the properties.js file in the Dev-Hub extension editor in the duplicated extension and it worked.

I am not sure why that file was not duplicated from the original extension, but now I know how to fix the issue in the future.  Thanks again for the help !

Brian

ErikWetterberg

I think dev-hub only copies the files listed in wbfolder.wbl file, so if properties.js is not in that file it would not be copied.