Do not input private or sensitive data. View Qlik Privacy & Cookie Policy.
Skip to main content

Announcements
Congratulations to the new Qlik Luminary and Partner Ambassador class! Meet them here
cancel
Showing results for 
Search instead for 
Did you mean: 
dobak
Partner - Contributor III
Partner - Contributor III

SFTP connection with a non standard port

per default qlik supports only ports 22 and 2222 for SFTP connections.

i created a connection to a host with port 22 then i tried to edit the port in qmc connection string to 443.

geting the error: The following parameter validation errors were found: sftpPort: Port is invalid.

 

I see no reason why a SFTP service should not be able to run any ports.

Is there a way how to workaround this?

Labels (1)
1 Reply
KevinEliezer
Support
Support

Qlik Sense Enterprise currently supports only ports 22 and 2222 for SFTP connections. Custom ports, including 443, are not supported. This is why you are encountering the validation error “sftpPort: Port is invalid” when attempting to modify the connection string in the QMC.
 

At this time, there is no workaround to configure a custom SFTP port. The available port options are restricted to 22 and 2222 in the QMC.
 

Therefore, if the SFTP server is configured to use a custom port such as 2124 or 443, it cannot be used directly for an SFTP connection from Qlik Sense Enterprise with the current functionality.