Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
April 22, 2PM EST: Learn about GeoOperations in Qlik Sense SaaS READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
FMDF
Contributor III
Contributor III

Tasks failing. Manual load succeeds.

I have created an Oracle oledb connection to an Oracle 11 database.

I am pulling data from a view.  When I run the query in Toad, it takes 1 second to complete.

I created the code to load data in Qlik from the view.  While in the app, when I click LOAD, it takes about 47 seconds to load the data.

When I schedule the job to run from the tasks in QMC, it will not finish.

Has anyone else experienced this issue?

I have tried using the Oracle connector in QMC, I have tried 2 different OLEDB drivers.  At one point the view code was just a query in Qlik.  I had them convert the query to a view in Oracle hoping it would not fail.

Completely stuck.

 

The job eventually fails.

Error: Connector reply error: ErrorSource: OraOLEDB, ErrorMsg: ORA-01652: unable to extend temp segment by 128 in tablespace TEMP

I have worked with our Oracle support team to address this issue.  The have increased tablespace in TEMP segment.  They have watched the tamp tablespace while executing and it does not seem to be running out of space.

And, as I mentioned, it only happens when running as a scheduled task.

 

Any ideas?

 

 

0 Replies