Skip to main content
Announcements
Marching toward a simplified navigation! READ ON
cancel
Showing results for 
Search instead for 
Did you mean: 
Ribeiro
Specialist
Specialist

A função FieldValue não está deixando número repetidos.

O campo abaixo Rep caso seja número iguais ele está dando erro.

Acredito que seja a função FieldValue ou outra coisa.

Alguém tem uma sugestão...

Veja que o número 10 está repetido. Neste caso está da o erro abaixo...

Exemplo Como eu Gostaria:

LOAD * Inline

[

field,Rep

123123,10

312312,8

312314,10

];

2017-11-29_15-38-25.png

Exemplo  Que está funcionando.

TMP:

LOAD * Inline

[

field,Rep

123123,1

312312,5

312314,8

];

FOR i = 1 TO NoOfRows('TMP')

LET vTbl = FieldValue('field', $(i));

LET vCon = previous(FieldValue('Rep',     $(i)));

  TRACE $(vCon);

sumary:

LOAD '$(vTbl)' AS MyField,

$(vCon)  AS MyRep,

RecNo()  AS CONT

AutoGenerate $(vCon)

;

NEXT 

DROP Table TMP;

EXIT Script;

Neves
1 Solution

Accepted Solutions
luismadriz
Specialist
Specialist

Hmmm, duas línguas, o mesmo problema .... com dados diferentes neles ... engenhoso!

Use Peek em vez de FieldValue,

Saudações

Luis

PS. Eu não conheço português, então deixei o Google Translate me ajudar

View solution in original post

2 Replies
luismadriz
Specialist
Specialist

Hmmm, duas línguas, o mesmo problema .... com dados diferentes neles ... engenhoso!

Use Peek em vez de FieldValue,

Saudações

Luis

PS. Eu não conheço português, então deixei o Google Translate me ajudar

Ribeiro
Specialist
Specialist
Author

Obrigado Luiz. Estava com presa.

Neves