Skip to main content

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
aschmeelk
Contributor III
Contributor III

DSN not found on task reload

Hi folks,

Running Qlik Sense April 2018 release; I have created a 64 bit DSN on our Qlik Central node Server and when I'm in the Data Load Editor of my App, the connection works fine.  It's when I create a Task to reload the App that I get the following  Error: Connector connect error: SQL##f - SqlState: IM002, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

I have verified ownership, the DSN, basically everything I can think of, why would the Reload Task fail in QMC when the App loads without errors from it's Data Load Editor? 

Completely stumped here!

Labels (1)
1 Solution

Accepted Solutions
prashanthi_gn
Contributor III
Contributor III

Also make sure the driver is configured in all the nodes.

View solution in original post

9 Replies
jwjackso
Specialist III
Specialist III

Is it a System DSN?

aschmeelk
Contributor III
Contributor III
Author

Yes system dsn
prashanthi_gn
Contributor III
Contributor III

what kind of driver is that?

If its a Oracle , then can you please check if there is tnsnames.ora file in the networks/adimin folder.

prashanthi_gn
Contributor III
Contributor III

Also make sure the driver is configured in all the nodes.
jonathandienst
Partner - Champion III
Partner - Champion III

When you ran the reload successfully from Data Manager, were you working with Desktop or were you opening the app from your workspace on the hub?

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
aschmeelk
Contributor III
Contributor III
Author

My workspace on the Hub.
aschmeelk
Contributor III
Contributor III
Author

No, not Oracle. MySQL driver.

aschmeelk
Contributor III
Contributor III
Author

That was it! I had forgotten to create the DSN on our Rim node.  Thank you!

jamshed07
Partner - Contributor III
Partner - Contributor III

Your answer save my day. That's worked for me too, create the DSN on our Rim node