Qlik Community

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Support Case Portal has moved to Qlik Community! Read the FAQs to start exploring Support resources.
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Qlik Sense Fetches Weird/Wrong Results Initially and Fixes after next reload

Good day everyone!

Here is my problem, 

After establishing a connection to the Oracle Database, Qlik executed an SQL query shown on the image attached. However, the resulting value for WORD_CMPTD_DESC column contains 'A', 'LL COMPLETE', and 'ALL COMPLETE'. The expected result is 'ALL COMPLETE' only. Aside from that, other columns especially those coming from the wo.<columnname> are wrong. Meanwhile, when this SQL query is executed in the Oracle database, the output is correct. 

I reloaded again the qvf file but the values are now correct. That is without changing anything at all. I just reloaded the data and the issue is fixed. I tried a multiple reload and the value is still correct. However, the next day, when I reloaded the dashboard, the values are back to A', 'LL COMPLETE', and 'ALL COMPLETE' and the values are wrong again.

Lastly, I tried to remove those unused columns both in Qlik and SQL query and the values are fine and those weird values are not present in the data. 

The following are the unused fields:



Why is this happening? Are there any limitations in SQL Query being executed using Qlik? Or is there any problem with the data connector? (We used Oracle ODBC, Native ODBC, OLE_DB but the issue is the same on these connectors.) 

Addition: Are there any limitations in the number of columns that Qlik can handle, currently the application has 911 columns joined together through SQL and just pulls few columns after the SQL join?

0 Replies