Skip to main content

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
Rehan
Creator III
Creator III

Qlik Web Connector Office 365 Sharepoint Connector Issue

We are currently using Qlik Web Connectors March 2020. I am trying to connect to the Office 365 sharepoint and running into issues. Below are the steps done so far.

Completed the authentication using the Base URL https://Domain.sharepoint.com/

The web URL is https://domain.sharepoint.com/sites/ABC/Lists/OM%20Approved%20Funding/OM%20Funding%20Datasheet%20Vie..., which I can successfully access using the web browser.

I then tried using the ListFolders options with the Sub Site Path as /sites/ABC/Lists/ and when I try to execute getting the message 

"There was an error running the table (Failed on attempt 1 to GET. (The remote server returned an error: (404) Not Found.))"

Please see attached message.

Any idea what am I missing here 

 

 

 

1 Solution

Accepted Solutions
PadmaPriya
Support
Support

Hello @Rehan 

 

Please refer to below articles:

https://community.qlik.com/t5/Knowledge-Base/Qlik-Web-Connectors-and-Google-Analytics-quot-Failed-on...

https://support.qlik.com/articles/000106463

 

Thanks,

Padma Priya

Qlik Support

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!

View solution in original post

4 Replies
stevedark
MVP
MVP

Hi @Rehan 

I believe that the SharePoint files folder structure is a tree, so start with no value in the sub site path and then try adding one branch at a time to see if you can find what you need.

It may be that ABC needs to be your site parameter and lists your sub site.

Steve

chrisbrain
Specialist II
Specialist II

@Rehan Yes - to agree with and add to what @stevedark said a little - I would start with the SubSites table with no parameters and confirm the subsite path.

It looks to me like /sites/ABC 'may' be the subsite but I am just guessing a little - the SubSites table might help you here assuming you have the permissions to enumerate sites.

beeido.com - BI | Software | Qlik Integration Services
GitFirst - A CI/CD solution for Qlik Sense
nategreen
Contributor III
Contributor III

@Rehan I am getting the same error - did you ever find a solution?

PadmaPriya
Support
Support

Hello @Rehan 

 

Please refer to below articles:

https://community.qlik.com/t5/Knowledge-Base/Qlik-Web-Connectors-and-Google-Analytics-quot-Failed-on...

https://support.qlik.com/articles/000106463

 

Thanks,

Padma Priya

Qlik Support

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!