Qlik Community

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
pavanpatha
Contributor III
Contributor III

Qlik sense Mashup not working as expected with Multiple proxies

Hi all,

We have the a Mashup application that interacts with Qlik sense server with multinode environment. The Landscape of Qliksense is as follows

1) QS Central node

2) 3 Engine nodes

3) 2 Proxy Nodes

 

The Mashup (Built using Angular JS and ASP.NET) is hosted on IIS and uses the ticket based authentication and interacts with Qliksense. We have 2 proxy servers (proxy1 and proxy2) includes in our virtual proxy that does the ticket authentication for the mashup. 

The major issue that we are facing is that the, Mashup fails intermittently to authenticate when both the proxy servers are turned on .    In our lower environment there is only 1 Proxy server and it works seamless.

Coming to the Higher environment, we have includes 2 proxy servers to have high availability . In such instances the authentication fails intermittently. When this has been troubleshooted, its observed that the Qliksense authentication cookie has been generated by proxy 1 and at times the request goes to proxy2 ( i am not aware if its load balancing startegy) which doesnt resolve the authentication cookie and hence it fails. We are unsure how the user session should always be redirected to one proxy server throughout his session even though we have 2 proxy servers included in virtual proxy. Having 2 proxy servers has been recommendation to us for high availability.

We are unable to fix this and hence we have disabled one of our proxy server and the Virtual proxy always points to proxy1.

 

Thanks,

Pavan

2 Replies
amartinez35
Partner - Specialist
Partner - Specialist

Hi,

We have the same problem 😞

Have you found a solution? (except disable the second proxy)

Thanks

pavanpatha
Contributor III
Contributor III
Author

No luck :(. waiting if someone can help