Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
Showing results for 
Search instead for 
Did you mean: 

QlikSense Not Reloading Data after Feb 2018 Update

I updated my Qlik Sense Desktop app to the February 2018 version and since then have not been able to re-load data at all. My data is linked through a web file to a file on an FTP. I have always updated this simply through the Data Manager using the "reload from data source" button. Since the update, when i click on this button the app says "loading" for a few seconds and this disappears with no new data. I have also tried to load through the data load editor and that doesn't work. I have confirmed that there is updates from the web file to pull in, Qlik sense is just not pulling it in. Any advice? Anyone else experiencing this issue?

4 Replies
Contributor II
Contributor II

Yes I'm experiencing the same issue. No matter what load or refresh button I press Sense does not seem to actually retrieve new data. The only thing that seems to work is to delete the connection and create it again.

Contributor II
Contributor II

I am getting the same problem, and also need to delete the connection and create it again, to get new data in. It's extremely annoying, to say the least - I have custom column names and need to re-create them EVERY time.


Also have same issue.  Except yesterday - the 6 tables in app updated, and I was surprised!

The documentation says (or implies) that reload in Data Manager only occurs when a CHANGE is made to a table in Data Manager.

And the presence of new data is not a change in this sense.

So work around is to make a change to each table.


Safest is to create a 'dummy' column in each original table.

Then in Data Manager, edit the table and press "Select data from source".  ADD the 'dummy' column and press "update". Result is the new data that you want plus a new column.  It updates now because there was a change to the table. You app is not affected because any data in the 'dummy' column just sits there, not referenced.

Next time you update, repeat the process, but DELETE the 'dummy' column.

It's not ideal but works.  Not so bad for main data tables -- where you know there will be new data -- but for lookup tables, you'll just have to know if they've been changed, or safer, just do the process above for all tables.


After install of June 2018 Qlik Sense, problem solved.

Data updates automatically when Qlik restarted after new data entered in table.

Data change during a session:  Have to go to Data Load Editor, 'Load data' button -- works, new data appears in tables.

So the hover message on the Load button -- "Run script and refresh data from data sources" means what is says (now)