Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
LINKEDIN LIVE: Democratizing data to enhance customer-centricity. JULY 29TH REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
ajaysikharam
Contributor III
Contributor III

Web Connectors 365 Sharepoint: AADSTS90027: We are unable to issue tokens from this API version

Hi All, I have upgraded Qlik webconnectors today and facing the below error message: Appreciate your assistance/inputs to fix this.

There was a problem authenticating with the connector, further information is listed below:

error = invalid_request
error_description = AADSTS90027: We are unable to issue tokens from this API version on the MSA tenant. Please contact the application vendor as they need to use version 2.0 of the protocol to support this.
Trace ID: c336a681-1277-47c5-99f6-f0d40f000c00
Correlation ID: 1703e731-ffc0-4bea-b163-ca63bd1887f1
Timestamp: 2021-04-16 17:22:49Z
 
 
Labels (1)
1 Solution

Accepted Solutions
p_verkooijen
Partner
Partner

@ajaysikharam managed to get around this by using select_account in the CanAuthenticate

p_verkooijen_0-1618851429883.png

 

View solution in original post

8 Replies
p_verkooijen
Partner
Partner

Hi @ajaysikharam same error here.

Tried 2 different O365 environments.

I have tried webconnector versions, both give the same error

  • December-2020 (2.98.2.20131)
  • Version: March-2020 (2.77.5.31203)

FYI raised a case with Qlik support 02183627 - QLIK WEBCONNECTOR OFFICE 365 SHAREPOINT OUTDATED?

ajaysikharam
Contributor III
Contributor III
Author

we were working fine with March 2020(licensed version), as our license was expiring we upgraded to December 2020 (as Qlik announced premium web connectors will be available for free and no license is required). It is from then am getting the error with code:AADSTS90027. when did you login the support ticket ? I have one logged in on Friday still waiting for solution :(.

p_verkooijen
Partner
Partner

Logged the ticket today, can you give the ticket number.
Then I will reference it in my ticket

ajaysikharam
Contributor III
Contributor III
Author

02182065  this is the ticket number I have created on Friday.

 

p_verkooijen
Partner
Partner

@ajaysikharam managed to get around this by using select_account in the CanAuthenticate

p_verkooijen_0-1618851429883.png

 

View solution in original post

vivek_gajjar01
Partner
Partner

Can you confirm which version of the Web Connectors you are using? as I'm also having the same issue however I cannot see the select_account option available in the drop-down, I've only got None & Consent. The version of Web Connectors I'm using is March-2020 (2.77.1.23956).

ajaysikharam
Contributor III
Contributor III
Author

We were using December 2020 version of web connectors.

Francisco_Fernandez

Hello,


I've created the following article describing the issue :

https://community.qlik.com/t5/Knowledge-Base/Qlik-Web-Connectors-Error-AADSTS90027-when-using-quot-c... 

it will be updated as the investigation progresses.


Please note that this issue also affects the Azure storage connector and Microsoft dynamics CRM V2.

Best regards,

Francisco