Skip to main content
Announcements
Marching toward a simplified navigation! READ ON
cancel
Showing results for 
Search instead for 
Did you mean: 
jbouslimi
Contributor III
Contributor III

Does QS Desktop support magic link with authentification via Gluu+ Saml ?

Does anyone use QS Desktop with QS server authentification ( Gluu+ SAML)?

I did not find any info whether QS Desktop supports authentification via virtual proxy (Gluu IDP + SAML).

Thank you for your input.

Labels (1)
1 Solution

Accepted Solutions
jbouslimi
Contributor III
Contributor III
Author

There was a bug in Gluu version 3.1.3 and below.

It is working for Gluu 3.1.6+. We installed Gluu 3.1.8 and now everything is  working as expected.

Hope this helps you.

View solution in original post

4 Replies
Levi_Turner
Employee
Employee

I'm currently using ADFS SAML as the client authentication link without issues myself so I would not expect Gluu to be a blocker here.

jbouslimi
Contributor III
Contributor III
Author

Yes we have an issue.

QS Desktop avril 2020 patch 2, Qlik sense server avril 2020 patch 2 ,  Nginx + Gluu IDP + SAML.

No page login displayed from Gluu IDP and got this error in the welcome QS Desktop page.

Server authentification attempt failed. 

QlikSenseBrowser log:

PID13976 - 2020-06-01T15:50:18.021 - WARNING - QObject::connect: No such signal NetworkAccessManager::error(QNetworkReply::NetworkError)

PID13976 - 2020-06-01T15:50:18.021 - WARNING - QObject::connect: No such signal QNetworkAccessManager::sslErrors(const QList<QSslError> &)

Appreciate any help...Thank you

Levente_Szittya
Partner - Contributor III
Partner - Contributor III

We face same issue (almost same error message). What can be the issue? Moreover, what can be the solution?

We have this log now:

PID5464 - 2020-11-30T16:12:07.813 - WARNING - QObject::connect: No such signal QNetworkAccessManager::error(QNetworkReply::NetworkError)
PID5464 - 2020-11-30T16:12:07.814 - WARNING - QObject::connect: No such signal QNetworkAccessManager::sslErrors(const QList<QSslError> &)

Thanks and best regards,

Levente

jbouslimi
Contributor III
Contributor III
Author

There was a bug in Gluu version 3.1.3 and below.

It is working for Gluu 3.1.6+. We installed Gluu 3.1.8 and now everything is  working as expected.

Hope this helps you.