Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
qlikplaut
Partner
Partner

Error 500 - Internal server error - Cannot establish a connection to Qlik Sense: Qlik Sense Management Console

Hello everyone,

I'm trying to install Qlik Sense Server on my laptop, but I must be doing something wrong because after installation completes I cannot log in to QMC. All services are running and I have tried accessing QMC from IE and Chrome, both show the same error message. I am running win 8.1. Would it be related to a certificate?

Any ideas?

25 Replies
p_verkooijen
Partner
Partner

Same issue here, but I believe it's related to the PostgreSQL because of several errors in my Windows Application Eventlog.

Server was a QV Next machine, uninstalled QV Next and removed all remaining folders (C:\ProgramData\Qlik , C:\Program Files\Qlik)

QV Sense Installer installed succesfully.

Event log :

The description for Event ID 0 from source PostgreSQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

ERROR:  relation "EdmMetadata" does not exist at character 55

STATEMENT:  SELECT

  "Extent1"."Id",

  "Extent1"."ModelHash"

  FROM "EdmMetadata" AS "Extent1"

  ORDER BY "Extent1"."Id" DESC

  LIMIT 1

p_verkooijen
Partner
Partner

Just checked the certificates on the QV Sense server,

Since the servername also changed from QVNext to QVSense there were several old QVNext certificates existing. And no QVSense certificates.

Removed all found certificates, after restarting the services qvsense certificates were generated. However the QMC and Hub were not functional (webpage does not exist).

Started the QVSense server installer and did a Repair installation, after this installation the QMC works !

Michael_Tarallo
Employee
Employee

Hi Bogdan,

Would you happen to have Skype running on the same machine, possibly using ports 443 or 80?

skype.png

Regards,

Mike

Regards,
Mike Tarallo
Qlik
qlikplaut
Partner
Partner
Author

Hi Mike,

I do have Skype running on the same machine. I unticked the option to use those specific ports and ran the Repair Installation but it did not change anything.

I also tried to install the Server on a different machine, the result was the same. Same error message, same certificate (only in personal but not in trusted).

Kind regards,

Bogdan

Michael_Tarallo
Employee
Employee

Hi Bogdan - let me know what support finds.

Can you perform this process following these:

  • Log into whatever ID you originally installed as and uninstall Qlik Sense from the Add / remove programs
  • Delete everything here: C:\ProgramData\Qlik
  • Remove any old certificates as previously discussed
  • Log out
  • Create an admin equivalent account such as sense_system - as per the Quick Install Guide - (below)
  • log in and use the sense_system account you just created - not your id.
  • Perform the Custom install not the Quick Install
  • Check the box to Enter in your Service credentials
    a. Enter the domain\username ex. computer_name\sense_system
    b. Leave Central Node checked
    c. Click Next

Let me know

Just in case - here is the videos:

Qlik Sense Platform - (Server) Installation (video)

Qlik Sense Platform - Token Licensing and Assigning Access Passes (video)

Qlik Sense Quick Installation Guide

Allocating Access Passes Information Guide

Main: New to Qlik Sense Platform Videos

Regards,
Mike Tarallo
Qlik
darkhorse
Partner
Partner

Hi Bogdan,

- Did you install the Qlik Sense Desktop to the same machine? If yes, just uninstall and then clear the certificates (2 in each category, personal and computer). Then try reinstalling the Qlik Sense server only(after proper restarts of the server).

- Did you install with a local user or a domain user? If with domain user, try using a local admin local user.

- Are you trying to access with a local user or domain user? Try logging in with a local user (the one that starts the services). That way it should work; otherwise we get the same error with a domain user. Plus, if it's your first time to login, the domain should be defined so it would be kinda normal to get that error.

BR

Serhan

Caique_Zaniolo
Employee
Employee

Hi Bogdan,

I had the same issue installing Qlik Sense on a VM.

I noticed the installed prompted me for a Host Name.

hostname.png

I edited the address and removed the .localdomain, leaving just the machine name as a host name.

Everything worked after that.

Please let us know if that fixes your issue.

Regards

Caique

aparnanair1405
Contributor II
Contributor II

Hi Caique,

This also helped me resolve "Error 404 - Not found Cannot establish a connection to Qlik Sense: Qlik Sense Management Console" after resolution.

Thanks,

Aparna

gainkarthi
Partner
Partner

What version are you using. if it's 2.2, there is a known issue, services will run, but portal will not come up.

image242
Creator
Creator

Thanks Giuseppe,

This solved my problem. Turns out I was running QlikSense 2 as a different service account when I upgraded to 3.0.1.

Jason