Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Join us for a live Q&A! September 21, 10 AM ET - Onboarding Fast in Qlik Sense SaaS! REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
GusthavoLima
Partner
Partner

Error in postgres as deploying multiple nodes.

Hello guys, I recently implemented a qlik sense cluster, using a Master Node and two Slaves. However I am getting the following error in postgres.

ERROR: duplicate key value violates unique constraint "ix_sensemq_target_topic_messageid"
DETAIL: Key (target, topic, messageid)=(AppDistributionService, app.update, 9ab82626-a136-48e0-85ff-8687d56d9c0a) already exists.
STATEMENT:
INSERT INTO sensemq (id, messageid, messagetype, createddate, expirydate, source, target, topic, data)
VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9)

 

For the implementation of the Master Node, the backup was performed followed by the restore of the old server.

Labels (3)
5 Replies
mbrdenmark
Contributor III
Contributor III

Like to hear more on this. I see this error 100's of times throughout the day in the event log as well.

I don't noticed any problems in the operation of Sense itself, but I see elevated CPU consumption for the repository service after this issue escalated after upgrading to Qlik Sense June 2020.

Brett_Bleess
Support (Former)
Support (Former)

@GusthavoLima About the best I have is the following Help link that should provide the official steps on creating the multi-node cluster, so you can verify you followed the steps correctly:

https://help.qlik.com/en-US/sense-admin/November2020/Subsystems/DeployAdministerQSE/Content/Sense_De...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
martinhazer
Partner
Partner

Hi all,
I have the same issue in multinode deployment.
We also migrated the central node to the new machine.
It is quite possible that migration is related to this.
Any idea what exactly it could cause? @Brett_Bleess 

Thank you very much.
MH

mhenning
Partner
Partner

Hi Gustavo, we are having this same issue in a single node June 2020 Patch 1 environment. Did you ever work out a fix?

Jaroslav_Stsetinin

This bug was fixed in May 2021 Patch 2 and later.  You need to upgrade your Qlik Sense.