Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Error while Installing Qlik Sense in Kubernetes

HI Techies,


I have started working on  Installing Qlik Sense in Kubernetes on my local personal windows 10, 8 Gb ram and 4 core machine.

I am referring the document made by Qlik know expert


Now above document has two files 

1.  0-install-tools.ps1 which guide us to install tools, reference Qlik doc behind the powershell file is

I ran it and it was executed fine with no errors.

now I have Oracle VM virtual box manager, minkube, which is running fine.

 Then I ran second file 1-Deploy-Minikube.ps1 which is made by

It has commands to

kick off minikube start, 

# Force Kubectl to point to minikube, 

# Run the following command to add Qlik’s helm chart repository to Helm. This is where Qlik Sense is pulled from

# use helm to deploy into Kubernetes, the helm Tiller pod is added to the Kubernetes cluster first.

# Install custom resource definitions used by dynamic engines

but when it try to execute 

# Install the Qlik Sense package

helm install -n qliksense qlik/qliksense -f values.yaml

it gives me error:

Error: validation failed: error validating "": error validating data: unknown object type "nil" in

, I tried to run the command by going to the folder where values.yaml but same error.

I have not much knowledge about Kubernetes so please help me to fix the error step wise step ?


Thanks in advance



Labels (1)
  • SaaS

21 Replies
Contributor II
Contributor II

Thanks for the reply @ToniKautto !

If we want to deploy Qlik internally, could we deploy Qlik sense on Linux servers or do we have to deploy Qlik sense on Windows only?





Qlik Sense Enterprise on Windows is the current alternative for deployment in your own environment. 

There may be other architecture choices allowing you to utilize Qlik Cloud, but for those, I'd suggest that you connect with your Qlik sales rep and discuss alternatives with a Qlik solution architect.