Skip to main content
The way to achieve your own success is the willingness to help somebody else. Go for it!
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Error while upgrading from 3.1 SR2 to Nov 2018

Hi All,

I am facing an issue while upgrading qlik sense from 3.1 SR2 to Nov 2018. The part of the Log shows up like the below.

0:32 98 Trying again.
Action 18:10:35 08 Trying again.
Action 18:10:35 20 Password validation failed.
CustomAction CA_ValidateSuperUserPassword returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (84:48) [18:10:35:255]: Note: 1: 2265 2: 3: -2147287035
MSI (s) (84:48) [18:10:35:255]: User policy value 'DisableRollback' is 0
MSI (s) (84:48) [18:10:35:255]: Machine policy value 'DisableRollback' is 0


MSI (s) (84:48) [18:10:52:035]: Product: PostgreSQL -- Installation failed.

MSI (s) (84:48) [18:10:52:036]: Windows Installer installed the product. Product Name: PostgreSQL. Product Version: 12.44.1. Product Language: 1033. Manufacturer: QlikTech International AB. Installation success or error status: 1603.

MSI (s) (84:48) [18:10:52:049]: Deferring clean up of packages/files, if any exist
MSI (s) (84:48) [18:10:52:050]: MainEngineThread is returning 1603

Attached complete Log files of the installation . 


And now if I try to restart the upgrade by running the setup file as administrator it is taking as an complete new installation rather than a upgrade.Please find the screenshots error screenshot 1.png

error screenshot2.png


Thanks in Advance.





3 Replies


I am assuming 3.1 SR2 was already setup for shared persistence and that you currently having a non-working environment. 

Did you take a DB dump before attempting the first update? 
If so, I would suggest uninstalling completely the software, reinstalling 3.1 SR2 and restoring the database.

Once you have a working environment, attempt again the update.

Daniele - Senior Technical Support Engineer & SaaS Support Coordinator at Qlik
If a post helps to resolve your issue, please accept it as a Solution.
Contributor III
Contributor III

Hi Daniele,

Thanks for reaching out yes I tried to reinstall 3.1 SR2 altogether and tried to upgrade the Nov 2018 but after the first step it again came up with the same error where it asks me for a Install rather than upgrade. But I tried to install however and from the old backup.tar file which was taken on 3.1 SR2 I was able to run the PG_restore and get all the settings back to the New installation of NOV 2018 version  and I manually moved all the Apps, App content etc and everything is running fine now. One issue was regarding the Port 80 which was not open but it got resolved eventually after we included that port number in the inbound rules.





Great! Then everything seems to be solved? so I guess this issue is solved? unless you have any other question or issue? 

Giuseppe Novello
Principal Technical Support Engineer @ Qlik