Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
QLIKWORLD LIVE! MAY 16 - 19TH, EARLY BIRD DISCOUNTS! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

How to log into qmc and hub after a fresh Qlik Sense Server installatioan on a Windows 7 local virtual machine?

Hi, I have just installed a Qlik Sense Server on a Windows 7 virtual machine running on my laptop.

The installation wizard works fine and no error shows up.

The name of my machine is: WIN-UMSVTAM11OT

My Windows VM username is: admin

My Windows VM password is: password

I now have shortcuts on my desktop to:

https://win-umsvtam11ot.localdomain/hub and https://win-umsvtam11ot.localdomain/qmc

Both shortcuts take me to a browser (I have tried IE and Chrome) and redirect me to:

https://win-umsvtam11ot.localdomain:4244/windows_authentication/?targetId=123-some-random-id-number

I am then prompted for username and password in a popup window.

I have tried the following (username ; password) pairs:

- (admin ; password)

- (WIN-UMSVTAM11OT\admin ; password)

- (WIN-UMSVTAM11OT/admin ; password)

- (whatever ; whatever)

- ( ; )

Every time a submit the credentials, the popup closes and opens again.

Every now and then the popup closes and doesn't open again, but I am then stuck on the the same ':4244/windows_authentication' page, which unfortunately is blank.

In Chrome dev tools, Network tab I get:

- /qmc - Status 301 Moved Permanently

- /qmc - Status 302 Found

- ?targetId=random-id-number - Status either 401 Unauthorized or 403 Forbidden.

I was never able to connect since installation. Any tips on how to log in correctly?

1 Solution

Accepted Solutions
jonathandienst
Partner
Partner

I wonder if QS Server could ever be made to work on Win7 Home version. Win7 Home is quite limited in its networking and management capabilities and I think QS Server will be using Windows APIs that are not supported by Win7 Home.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein

View solution in original post

7 Replies
shraddha_g
Partner
Partner

niceqlik
Partner
Partner

Hi Thomas,

It seems that your local "admin" account may be blocked.

Try to check it is active , otherwise you need to reactivate it.

Capture.PNG

Not applicable
Author

Hi Shraddha, it seems like at least port 4244 is open.

Using 'netstat -a' in cmd I get the following line, but nothing on 4248.

This page‌ says that

- 4248 is used for HTTP Windows Authentication

- 4244 is used for HTTPS Windows Authentication

What are the implications of port 4248 not being open?

Not applicable
Author

Hi Ismail, I have struggled to find the User Properties window, only to realize that my VM is running a Windows 7 Home Basic version. Therefore, I cannot open this window and check if my admin account is active. Is there another way to check? (If not, my next step will be reinstalling another version of Win 7.)

shraddha_g
Partner
Partner

See if another process is using that port

jonathandienst
Partner
Partner

I wonder if QS Server could ever be made to work on Win7 Home version. Win7 Home is quite limited in its networking and management capabilities and I think QS Server will be using Windows APIs that are not supported by Win7 Home.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
Not applicable
Author

Hi Jonathan, thanks for your input.

I have completed the installation of Qlik Sense server on a Windows 7 Professional virtual machine.

... and it works !

It was my mistake to install the Home version in the first place. However, the Qlik Sense Server requirements page‌ doesn't specify which versions of Win 7 are supported or not.

Is it that obvious that nobody installs servers on Home version?