Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE
Showing results for 
Search instead for 
Did you mean: 

Problems upgrading to Qlik june 2017 (solved)

We had a Qlik sense server 3.2 SR2 instance which we required to upgrade to the June 2017 version. I tried several times without success. I reviewed a lot of posts here but none of them described my situation therefore I tried almost most of the solutions related to upgarde problemas even if they were not describing my problem. This strategy helped me to learn a lot of tips, but it didn't solved my problem and then I decided to raise my problem to support.

I went to the support portal and I found this fix at the support Knowledge base that finally helped me with my upgrade. https://qliksupport.force.com/QS_CaseWizardKnowledgeArticle?id=kA5D00000004NPTKA2

For all these people that had a problem like mine I want to share my experience hoping that it might help somebody in the future.

  • My logs showed a failed postgress installation, sometimes this logs are difficult to read. I noticed the error is described in the same link that comes above
  • I noticed that it was running it on a windows server 2008. I discovered that I should upgrade to 2012 and install all the patches Installing Qlik Sense June 2017 on windows 2008 server R2. Patches solved a problem with a stalled hub, in other words , upgrading to 2012 was not enough for my Qlik 3.2 SR2 instance to run. This was not  the solution to my problem but this was a really helpful (and a must) post
  • I tried installing Visual C++ redistributable 2010 but it turned out that it was not necessary in my case. Qlik Sense Install failed - Postgres
  • Some posts talked about a C:\Programdata directory. I had a hard time finding it. I discovered that this is a hidden directory in windows 2012. It turned out that is very helpful to have access to this directory. Many posts in this forums now make sense
  • I removed the Qlik sense service account from the Performance Monitor Users group as mentioned in the link above, restarted the server and tried the upgrade again and it worked. Now I have a fully working instance of Qlik sense June 2017


0 Replies