Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Don't miss the upcoming Q&A with Qlik session on Qlik Application Automation on November 16th! REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
CurtDaughtryBP
Contributor III
Contributor III

Qlik Cloud - Reload Task Fails - Socket Closed

I have a load scrip that has been running well for a long time.

Now - I'm getting the following error halfway through the script execution for no explainable reason.

 

The following error occurred:
 (Connector error: Socket closed)

 

How do I troubleshoot? Has anyone seen?

 

Labels (1)
  • SaaS

7 Replies
jfgiudicelli
Contributor
Contributor

Hi i've the same issue , i just change the socket size 900 to 400. tell me if it's you find any another issue

best regards

CurtDaughtryBP
Contributor III
Contributor III
Author

How would you achieve that setting change? We are using QSE on Qlik Cloud.

Akshesh_Patel
Support
Support

Which connector are you using? Socket closed' is usually seen when a connector terminates suddenly.  Look for the script error and see at what point it is failing. If you are running a complex reload then try running a simple reload and see if that works. 

CurtDaughtryBP
Contributor III
Contributor III
Author

The SalesForce connector. The reload is straight-forward (simple data extraction - select * type load) and the failure comes at different points in the scripts' progress on any given day.

Akshesh_Patel
Support
Support

Hi,

Would you mind trying now, there is recently a fix released for the web connector for a similar issue. If you are still getting an error then is it possible for you to get the reload logs or just a reload ID? 

 

Best

Akki

CurtDaughtryBP
Contributor III
Contributor III
Author

Akki,

I believe you are running the support ticket, right? Will you please respond on that thread?

StefanSonntag
Contributor II
Contributor II

@CurtDaughtryBP I experience the same thing, with Google Drive. It started about 1.5 to 2 weeks ago that I got more frequent stops in load scripts with the same error message, at varying points in various scripts. Roughly 1 out of 10 reloads failed this way. Now, at the time of writing this post things seem to work stable since 24 hrs , so lets see if this (hopefully) stays that way

Thanks,

Stefan