Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
dijksman
Contributor II
Contributor II

Qlik Sense engine service stops for no reasing?

Hi Community,

Since two weeks I experience strange behaviour with the engine service of Qlik Sense. Qlik Sense april 2018 is installed on a Windows 2016 server and for monts it ran quit smoothly. Suddenly the engine service would not come up after weekly server reboot (other services start normal and all services are automatic delayed) and since yesterday the engine service also can just stop for no reason at all during uptime. I searched the internet and this community but allthough there are several topics regarding not starting engine services, no cause is mentioned.

Is there some one here who have an explanation and permanent solution (next to rebooting again, manually starting the service and frequently running the repair function) why only this engine service stops out of the blue and can not start up after reboot?

Thanks in advance and kind regards,

Aad Dijksman

7 Replies
sujeet_shirude
Creator II
Creator II

Hi Aad,

We are experiencing similar issue too. We recently upgraded to April 2018 version and today the engine and Logging service stopped for no reason.

mto Is this a bug in the recent release?

Thank you!

Regards,

Sujeet Shirude

Michael_Tarallo
Employee
Employee

Hi Guys - thanks for tagging me - in situations like this - posting in the community may help if someone else had experienced this and has a solution - as Sujeet has (but no solution) - I have not heard anything yet - however you can open a case with or without a support contract as a guest: here: https://qliksupport.force.com/QS_CoveoCaseWizard#t=All&sort=relevancy

They can help cases like this get resolved - if you do not hear anything - please reply to this thread and I will be notified and can escalate if needed.

Regards,

Mike T

Qlik

Regards,
Mike Tarallo
Qlik
sujeet_shirude
Creator II
Creator II

Thank you mto ! I will open a case.

dijksman
Contributor II
Contributor II
Author

Michael and Sujeet,

Thanks for replying and following. When I find additional information I will post here.

Thanks and kind regards,

Aad Dijksman

rai-jmcpheeters
Contributor III
Contributor III

Our team is also experiencing this issue after reboots - the engine and logging services do not start up. I'm opening a case as well. Will post the response if received first.

hian_cintra
Partner - Contributor II
Partner - Contributor II

Hi Folks, any news abou this case?

rai-jmcpheeters
Contributor III
Contributor III

Hi everyone,

Sorry for the late reply. We did get the issue resolved using some advice from Qlik. The dependency part for the Logging service didn't work for us, but the method with the zip file (details below quoted message) did resolve the Engine issue and we're going to test it out to see if it will also work for the Logging service.

"I have picked up your case and will be working with you. Looking at your description this sounds like two issues we have experienced recently with Qlik Sense April 2018.

  • First, in April 2018 an issue was introduced that sometimes causes the engine service to attempt to start prematurely and preventing it from coming up initially. This issue is still being worked on by R&D, but they have provided a new work around.
    • See the attached ZIP that has a task creation that will start the Engine after five mins that will alleviate that issue until a fix can made, or if you would like to do planned restarts.
    • You could use a script like this one:
      • Stop-Service
      • QlikSenseRepositoryService -Force
      • Stop-Service
      • QlikSenseServiceDispatcher
      • Restart-Service QlikLoggingService
      • Start-Service
      • QlikSenseServiceDispatcher
      • Start-Service
      • QlikSenseRepositoryService
      • Start-Service
      • QlikSenseProxyService
      • Start-Service
      • QlikSenseSchedulerService
      • Start-Service
      • QlikSensePrintingService
      • Start-Sleep 60
      • Start-Service
      • QlikSenseEngineService
  • Secondly, by default the Qlik Logging Service doesn't have a dependency with the any of the other Qlik Services. The primary Qlik Services have dependency on the Qlik Sense Repository Database and Service Services. You can create this dependency by using the following power shell commands.
    • sc config QlikLoggingService
    • depend=QlikSenseRepositoryDatabase
    • sc config QlikLoggingService
    • depend=QlikSenseRepositoryService"

The zip file contained two files: a .bat and a .xml file. Their content is below because I cannot upload files.

startengineifdown.bat

@ECHO OFF

FOR /F "tokens=3 delims=: " %%H IN ('SC QUERY "QlikSenseEngineService" ^| FINDSTR "        STATE"') DO (

  IF /I "%%H" NEQ "RUNNING" (

  NET START "QlikSenseEngineService"

  )

)

startSenseEngine.xml

<?xml version="1.0" encoding="UTF-16"?>

<Task version="1.4" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">

  <RegistrationInfo>

    <Date>2018-05-29T11:22:07.0155768</Date>

    <Author>DOMAIN\Administrator</Author>

  </RegistrationInfo>

  <Triggers>

    <TimeTrigger>

      <Repetition>

        <Interval>PT5M</Interval>

        <StopAtDurationEnd>false</StopAtDurationEnd>

      </Repetition>

      <StartBoundary>2018-05-29T11:25:45</StartBoundary>

      <EndBoundary>2019-07-17T11:22:45.2344054</EndBoundary>

      <Enabled>true</Enabled>

    </TimeTrigger>

  </Triggers>

  <Principals>

    <Principal id="Author">

      <UserId>S-1-5-18</UserId>

      <RunLevel>HighestAvailable</RunLevel>

    </Principal>

  </Principals>

  <Settings>

    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>

    <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>

    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>

    <AllowHardTerminate>true</AllowHardTerminate>

    <StartWhenAvailable>false</StartWhenAvailable>

    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>

    <IdleSettings>

      <StopOnIdleEnd>true</StopOnIdleEnd>

      <RestartOnIdle>false</RestartOnIdle>

    </IdleSettings>

    <AllowStartOnDemand>true</AllowStartOnDemand>

    <Enabled>true</Enabled>

    <Hidden>true</Hidden>

    <RunOnlyIfIdle>false</RunOnlyIfIdle>

    <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>

    <UseUnifiedSchedulingEngine>false</UseUnifiedSchedulingEngine>

    <WakeToRun>false</WakeToRun>

    <ExecutionTimeLimit>PT0S</ExecutionTimeLimit>

    <Priority>7</Priority>

    <RestartOnFailure>

      <Interval>PT5M</Interval>

      <Count>3</Count>

    </RestartOnFailure>

  </Settings>

  <Actions Context="Author">

    <Exec>

      <Command>C:\imp\startengineifdown.bat</Command>

    </Exec>

  </Actions>

</Task>