Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
josecardenas
Contributor III
Contributor III

Qlik sense 1.0.2 Multi-node not working

Hi everyone

I've created a new node as slave in order to link to the master on Qlik Sense (Version 1.0.2). Although I've followed all possible advice on the manuals and on the internet and in the qlik community, I've not getting to work properly. I' ve already installed 3 times the qlik sense on the slave machine and it's not working at all and I'm getting mad!

I've tracked the logs and ports before and after the installation, and before and after  adding the new node, and I've noticed that the port 5151 for some reason is not opening and this one is needed to communicate the schedulers between the master and slave:

https://help.qlik.com/sense/en-us/developer/Subsystems/Qlik_Sense_Repository_Service_API/Content/QRS...

've checked The log on the repository (slave server) and I've got the ERROR below:

41

20150206T120204.625+0000

INFO

WIN-HOSTNAME

System.Repository.Repository.QRSMain

2416

01f5849e-be97-4d82-87ea-a4b605a14297

WIN-HOSTNAME\sense_system

Startup phase completed

01f5849e-be97-4d82-87ea-a4b605a14297

42

20150206T120238.496+0000

ERROR

WIN-HOSTNAME

System.Repository.Repository.Core.Status.ServiceStatusPoller

3352

fa5db67a-90e1-4b15-8fe4-af6cb7ccac21

WIN-HOSTNAME\sense_system

Error when requesting service alive response from 'https://WIN-HOSTNAME:5151/qss/'. Unable to connect to the remote server

fa5db67a-90e1-4b15-8fe4-af6cb7ccac21

43

20150206T120253.348+0000

ERROR

WIN-HOSTNAME

System.Repository.Repository.Core.Status.ServiceStatusPoller

3352

2479368c-6b1a-45b2-ba62-36ae75778431

WIN-HOSTNAME\sense_system

Error when requesting service alive response from 'https://WIN-HOSTNAME:5151/qss/'. Unable to connect to the remote server

2479368c-6b1a-45b2-ba62-36ae75778431


The list of ports opened in the slave:

Proto  Local Address          Foreign Address        State

TCP    0.0.0.0:135            WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:445            WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:3389           WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:4242           WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:4444           WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:5985           WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:47001          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49152          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49153          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49154          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49155          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49156          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49157          WIN-HOSTNAME:0      LISTENING

TCP    0.0.0.0:49158          WIN-HOSTNAME:0      LISTENING

TCP    127.0.0.1:4432         WIN-HOSTNAME:0      LISTENING

TCP    127.0.0.1:4432         WIN-HOSTNAME:51111  ESTABLISHED

TCP    127.0.0.1:51111        WIN-HOSTNAME:4432   ESTABLISHED

TCP    xxx.xxx.x.x:139        WIN-HOSTNAME:0      LISTENING

TCP    xxx.xxx.x.x:3389       yyy.yyy.y.y:57694      ESTABLISHED

TCP    xxx.xxx.x.x:3389      yyy.yyy.y.y:58255      ESTABLISHED

I've checked The log on the scheduler (slave server) and I've got the ERROR below:

2

20150206T121129.133+0000

INFO

WIN-HOSTNAME

System.Scheduler.Scheduler.Core.Utility.CommonInitializer

2360

d6634f2e-4cd2-47bc-8f53-bcc61c6e1ccb

WIN-HOSTNAME\sense_system

Running common startup sequence

d6634f2e-4cd2-47bc-8f53-bcc61c6e1ccb

3

20150206T121130.367+0000

ERROR

WIN-HOSTNAME

System.Scheduler.Scheduler.Communication.Wrapper.Repository.RepositoryWrapper

2360

6072438a-dbb8-42fb-ae8e-27e0b6fb833f

WIN-HOSTNAME\sense_system

Exception message from RestResponse: The remote server returned an error: (404) Not Found.

6072438a-dbb8-42fb-ae8e-27e0b6fb833f

4

20150206T121130.852+0000

ERROR

WIN-HOSTNAME

System.Scheduler.Scheduler.Communication.Wrapper.Repository.RepositoryWrapper

2360

a55049b3-bf09-4bbd-9416-9454209e3856

WIN-HOSTNAME\sense_system

Exception message from RestResponse: The remote server returned an error: (404) Not Found.

a55049b3-bf09-4bbd-9416-9454209e3856

5

20150206T121131.070+0000

ERROR

WIN-HOSTNAME

System.Scheduler.Scheduler.Communication.Wrapper.Repository.RepositoryWrapper

2360

fba02bec-5009-4a59-bcb9-152dd7057c68

WIN-HOSTNAME\sense_system

Exception message from RestResponse: The underlying connection was closed: An unexpected error occurred on a send. -> Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. -> An existing connection was forcibly closed by the remote host

108

20150206T121600.751+0000

ERROR

WIN-HOSTNAME

System.Scheduler.Scheduler.Communication.Wrapper.Repository.RepositoryWrapper

2360

3c0a7052-4e6d-4fe4-a2b6-9ce8da865e7b

WIN-HOSTNAME\sense_system

Exception message from RestResponse: The remote server returned an error: (403) Forbidden.

3c0a7052-4e6d-4fe4-a2b6-9ce8da865e7b

109

20150206T121605.794+0000

ERROR

WIN-HOSTNAME

System.Scheduler.Scheduler.Communication.Wrapper.Repository.RepositoryWrapper

2360

115be77c-cab2-4aef-95c9-669bda18d824

WIN-HOSTNAME\sense_system

Exception message from RestResponse: The remote server returned an error: (403) Forbidden.

115be77c-cab2-4aef-95c9-669bda18d824

110

20150206T121610.810+0000

ERROR

WIN-HOSTNAME

System.Scheduler.Scheduler.Communication.Wrapper.Repository.RepositoryWrapper

2360

b03350ff-a6c8-49f3-ace4-87c09ea1d971

WIN-HOSTNAME\sense_system

Exception message from RestResponse: The remote server returned an error: (403) Forbidden.

b03350ff-a6c8-49f3-ace4-87c09ea1d971

I've checked the windows event log and I'm getting many times the same error from PostgreSQL database. Here a sample:

The description for Event ID 0 from source PostgreSQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

ERROR:  column c.CreatedOn does not exist at character 10

STATEMENT:  SELECT

c."CreatedOn"

FROM "__MigrationHistory" AS c

LIMIT 1

So … from this point I've just gave up, trying to find another alternative to the issue. 

Any HELP and possible solution is really appreciated!

Thanks everybody

Jose.

11 Replies
tseebach
Luminary Alumni
Luminary Alumni

Hi Jose,

I've had pretty much a similar experience. I needed to add the exact hostnames to ip translation in hosts file. Also I did the following:

  • When uninstalling in order to correctly install, remember to remove Certificates
  • When asked about the hostname of the central server, enter the name that you put into your hostfile
  • Remember to set a password on the Central Repository

In contract to QlikView it seems that when install a Sense Cluster you need to get right install setting in place. These cannot be changed afterwards.

microland
Contributor III
Contributor III

Hi Amo,

I have done a new setup with November 2018 version. I am facing the issue while adding RIM that error says

"Cannot reach the following remote host when distributing certificates: http://nodename:4444/setup/certificateDistribution"

Atleast 5-6 times i dropped the Azure VM and started fresh installation and still it is giving the same error.

After that, i took 2 new VMs and installed Feb 2018 version with the same procedure and it is working fine.

Is there any issue with November 2018 version in installing RIM node?

Is there any specific setup needs to be done for Nov 2018? 

Any help/ inputs  would be really helpful.