Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
On-Demand Webinar: Learn proven best practices for a smooth transition to Qlik Sense® SaaS. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
microland
Contributor III
Contributor III

QlikSesnse Websocket timeout in Mashup

Hi Experts,

I have an issue with the websocket connection timeout in mashup. I have setup 60 mins session timeout in QMC but after some random time of inactivity the websocket is loosing the connectivity, hence all my charts in the mashup goes blank.

Sometime the blank is happening in 15 mins and sometime 45 mins and i am unable to predict any pattern of this also. Is there any solution to this. Any help would be really helpful.

Labels (4)
5 Replies
Bastien_Laugiero

Hello, 

The symptoms point to something in the network killing the WebSocket session before it reaches the timeout set into Qlik Sense. 

You can try to implement the following article: Enabling TCP Keep Alive Functionality in Qlik Sense and set it to 10 minutes, for example, to see if it makes any difference. 

Hope this will help!   

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
microland
Contributor III
Contributor III
Author

Hi Bastien,

I have tried this solution earlier - Enabling TCP Keep Alive Functionality in Qlik Sense already but unfortunately, this solution is also not making any difference. I have kept the ping interval as 

<add key="WebSocketPingInterval" value="60"/> 

But still the objects are going blank. we are using QlikSense Nov 2018 version. Is there any version specific settings required?

Bastien_Laugiero

Hello,

 

Thank you for your feedback. There shouldn't be any version specific configuration to apply for it to work. 

  • Have you tried the mashup from the Qlik Sense server locally or at least from a machine within the same network? 
  • Have you tried this mashup in another Qlik Sense environment? 

 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
microland
Contributor III
Contributor III
Author

I have 3 different environments, 

  1. Production 
  2. UAT
  3. OnPrem Production

The issue is there in all these 3 environments and i have tested locally (same machine), the timeout is happening there also but qlik handling the issue and some popup comes with the refresh button. But we cant do this in our environment because we are agreed the idle time in our SLA with customer is 1 hour. Thats our struggle right now. 

Bastien_Laugiero

Ok, my last suggestion would be to disable any proxy (if there is any) on the Qlik Sense server and try again from the server locally. 

If it does not help, then I would suggest opening a case to Qlik Support directly or to your partner depending on your support contract to investigate further. 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.