Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Senor_Dai
Partner
Partner

SSO Working.. redirect Users to SSO login

Hi,

I have successfully integrated Auth0 and QlikSense Enterprise by creating a virtual proxy:

Screenshot 2021-06-21 at 14.24.53.png

 

At the moment when users goto https://myqliksenseserver.com/sso they are directed to the SSO login dialogue and are able to login using the credentials created in Auth0. 

Is there a way to redirect users to this SSO login when they try and login via https://myqliksenseserver.com/  instead of showing this login page:

Screenshot 2021-06-21 at 14.28.52.png

Any help greatly appreciated.

 

Dai

Labels (1)
  • Other

1 Solution

Accepted Solutions
rzenere_methode
Partner
Partner

Hey @Senor_Dai ,

in addition to what Padma is suggesting, you could change the prefix of virtual proxy Central Proxy (Default) to something else (i.e. 'win'), and then change the prefix of virtual proxy Auth0 to nothing (so '').
This way when the users will try to reach https://myqliksenseserver.com/ they'll be redirected to Auth0.

Just be sure to keep in mind your new prefix for the virtual proxy Central Proxy (Default), because in case of issues with Auth0 that will be your only entry point to Qlik Sense.

I hope this helps,
Riccardo   

View solution in original post

6 Replies
PadmaPriya
Support
Support

Hello @Senor_Dai 

 

Please refer to below link:

Authentication solutions ‒ Qlik Sense for administrators

SAML configuration with AD FS ‒ Qlik Sense for administrators

 

Thanks,

Padma Priya

Qlik Support

We are just 'like' you and like to be liked when providing a helpful answer. You may press the 'Solution Accepted' button if an answer provided solves your issue.
rzenere_methode
Partner
Partner

Hey @Senor_Dai ,

in addition to what Padma is suggesting, you could change the prefix of virtual proxy Central Proxy (Default) to something else (i.e. 'win'), and then change the prefix of virtual proxy Auth0 to nothing (so '').
This way when the users will try to reach https://myqliksenseserver.com/ they'll be redirected to Auth0.

Just be sure to keep in mind your new prefix for the virtual proxy Central Proxy (Default), because in case of issues with Auth0 that will be your only entry point to Qlik Sense.

I hope this helps,
Riccardo   

View solution in original post

Senor_Dai
Partner
Partner
Author

Hi @rzenere_methode , thanks for the advice on this.  

 

So,  before I changed the the prefixes over I ensured my SSO user was Root Admin 🙂

When I first swapped the prefixes over I was able to login by just typing https://myqliksenseserver.com/ and the SSO login appeared. 

Once authenticated I was presented with a blank screen and an error the url http://myqliksenseserver.com/sso/samlauthn/ 

I guess I also need to change the callback url in our Auth0 settings which is currently set to :
Screenshot 2021-06-21 at 21.17.56.png

 

Current Virtual Proxy Settings:
Screenshot 2021-06-21 at 21.37.27.png

Should I change the callback url to https://myqliksenseserver.com/hub ?

 

Thanks again for your time !

 

Dai

Senor_Dai
Partner
Partner
Author

HI @rzenere_methode 

 

Thanks so much for this info..    Once I changed the prefixes over in the Virtual Proxies  the Auth0 SSO dialogue did appear when I went to https://myqliksenseserver.com/  

 

However, on submitting my credentials I was forwarded to the original callback URL as per my Auth0 settings :
Screenshot 2021-06-21 at 21.53.36.png

 

which then resulted in a page error.  Should I therefore change my callback url to https://myqliksenseserver.com/hub as per the redirection when logging in using the default virtual proxy? eg:

Screenshot 2021-06-21 at 21.55.37.png

Thanks again for your time!

 

Dai

Senor_Dai
Partner
Partner
Author

Just to add that these are the setting over in Auth0:

Screenshot 2021-06-21 at 21.53.36.png

rzenere_methode
Partner
Partner

Hey @Senor_Dai ,

yes, you should change the callback url too (removing the sso from both urls)

Riccardo