Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
MarkMV
Contributor III
Contributor III

What User ID to use with Monitoring apps?

This is my first time installing Qlik Sense.

-A Qlik Sense service account was created to run the Qlik Sense services in our environment. Call it QlikSense_adm

-Our Monitoring apps began to fail and after some research it was determined that this was due to my personal account being used as the User ID in the monitor_apps_REST data connections. Company policy requires frequent user password changes, which when my personal password is changed causes the Monitoring apps to begin to fail.

-I tried changing the User ID on these data connections to the QlikSense_adm account we created to run the environment, but I am continuing to get “Error: HTTP protocol error 403 (Forbidden): The server refused to fulfill the request”.

-The QlikSense_adm seems to be set up the same as my personal account. Both are RootAdmins. 

-Does any one have any recommendations on how I can get this to work using our service account (which does not require frequent password changes)?

2 Solutions

Accepted Solutions
Bastien_Laugiero

Hello, 

Based on the description it looks like the permission are correct (RootAdmin).

Could you please check the following article to make sure the Service Account is not Inactive or Remove Externally in the QMC. https://community.qlik.com/t5/Support-Knowledge-Base/QVX-UNEXPECTED-END-OF-DATA-HTTP-protocol-error-...

 

Hope this helps!

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.

View solution in original post

MarkMV
Contributor III
Contributor III
Author

Somehow the "RootAdmin" role was removed from the admin account. Adding that role back to the admin user solved the problem and the jobs ran successfully. 

View solution in original post

2 Replies
Bastien_Laugiero

Hello, 

Based on the description it looks like the permission are correct (RootAdmin).

Could you please check the following article to make sure the Service Account is not Inactive or Remove Externally in the QMC. https://community.qlik.com/t5/Support-Knowledge-Base/QVX-UNEXPECTED-END-OF-DATA-HTTP-protocol-error-...

 

Hope this helps!

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.

View solution in original post

MarkMV
Contributor III
Contributor III
Author

Somehow the "RootAdmin" role was removed from the admin account. Adding that role back to the admin user solved the problem and the jobs ran successfully. 

View solution in original post