Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
kelvinlawveloci
Partner - Contributor
Partner - Contributor

iOS 11 error: Connection to the Qlik Sense engine failed for unspecified reasons

I have tried using different iphones & ipads (with iOS 11) login to my QlikSense server hub, all of them prompt the same error message "An error occurred Connection to the Qlik Sense engine failed for unspecified reasons. Refresh your browser or contact your system administrator."

However, the login was successful when I used laptops and Android phones.

I have already whitelisted my server IP address and machine name in QMC.

Am I still missing something?  Any idea?

Thanks!!

9 Replies
simon_minifie
Partner - Creator III
Partner - Creator III

Hi Kelvin,

Have seen this a couple of times with IOS devices, and it seems to point to certificate trust.

Are you using the self signed certificate that Sense creates to present to the browser?

Thanks,

Simon

menta
Partner - Creator II
Partner - Creator II

I have the same problem and I use the self signed certificate

simon_minifie
Partner - Creator III
Partner - Creator III

Hi Carlo,

It's the certificate that seems to be the issue.

Apple and Google are having a big push for SSL everywhere, and seem to be activly blocking self signed certificates.

I would suggest either turning on http connections and using that, or purchasing a certified SSL certificate from Versign or similar.

Thanks,

Simon

paulodantas
Creator
Creator

Hi Kelvin,

did you fixed the issue?

If yes, please choose the correct answer or describe how you did to close the thread.

Best regards.

kelvinlawveloci
Partner - Contributor
Partner - Contributor
Author

We have fixed the issue by not using HTTPS, but enabling the Allow HTTP option in the proxies setting and works now in iOS.  Thanks!!

paulodantas
Creator
Creator

Hi Kelvin,

thanks for the reply.

Yes, I saw something like that on the internet. But for us, it´s necessary use the HTTPS.

Best regards.

paulodantas
Creator
Creator

What we did to work was move to central node and this solve the problem.

omkarvamsi
Creator
Creator

Hi All,

I have enabled http in the QMC>Proxy>Edit proxy> Port

But still i couldn't able to access the qliksense hub on IPAD.

Should i install SSL certificate on Qliksense server and should i need to configure thumb print under QMC->Proxies>Edit>Security>SSL browser certificate thumbprint.

please suggest on this.

Regards,

Omkar

 

 

patricesalem
Creator II
Creator II

Hi omkar 

 

have you finally fixed your issue ?

how did you do it ?

 

thanks

pat