Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
jatullaban
Contributor II
Contributor II

republish application, change not reflected

I'm experiencing the following problem related to republish an application.

1-duplicate application

2-modifi script in load editor to add one more parameter that was added to my db

3-load script, it loads without errors

4-republish application

5- get application republished

Finally the change is not applied, if I duplicate the recent republished app again, I don't see the change I just made either.

 

I tried different browsers and even computers.

 

Any suggestions here??

 

Labels (1)
1 Solution

Accepted Solutions
jatullaban
Contributor II
Contributor II
Author

"What I'm after here is to confirm that the reload you did before the app was published actually finished successfully."

I publish after disable, and when the app was not loading.

 

I published with a different name and then finally I saw the change reflected.

 

I also tried to do some other modifications besides the load editor, but that didn't worked,

 

Thanks a lot for your help!!!

View solution in original post

8 Replies
Or
MVP
MVP

When looking at the published application's last published time, does it show as though the application was republished (and with a more recent reload time since you also reloaded data)? Also, have you made sure to stop any reload tasks for the published app before republishing?

rohitk1609
Master
Master

Did you use Replace the app option?

jatullaban
Contributor II
Contributor II
Author

I did disable reloading on the task, and yes, I do see the latest modification time, but still the change is not reflected.

 

Before change

jatullaban_0-1657086336882.png

 

After republish:

jatullaban_1-1657086358847.png

 

jatullaban
Contributor II
Contributor II
Author

Hi, yes I did, and I see that the app has been republished also.

 

jatullaban_2-1657086516059.png

 

jatullaban_3-1657086523689.png

 

Or
MVP
MVP

This is a tad confusing. You said you reloaded the data, but in both cases, the last reload is 8:33am?

jatullaban
Contributor II
Contributor II
Author

Sorry, here you can see reloaded and republished. Still no changes reflected.

 

jatullaban_0-1657097365517.png

 

Or
MVP
MVP

That's not better - now the last reloaded is *after* the Published, so you didn't reload and then publish, you reloaded the already-published app?

What I'm after here is to confirm that the reload you did before the app was published actually finished successfully.

Some other things you try and check:

* Publish the app to a new location / ID, and see if the same behavior persists.

* Make changes to the front-end of the app rather than the script and see if they go through or not.

* Export the duplicated app and re-import it, and then follow the same steps to see if the same issue occurs.

* After backing up the app, export the already-modified version, then import it replacing the existing published app.

 

Also, your issue might be related to this bug?

Or_0-1657101141770.png

 

jatullaban
Contributor II
Contributor II
Author

"What I'm after here is to confirm that the reload you did before the app was published actually finished successfully."

I publish after disable, and when the app was not loading.

 

I published with a different name and then finally I saw the change reflected.

 

I also tried to do some other modifications besides the load editor, but that didn't worked,

 

Thanks a lot for your help!!!