Qlik Community

Groupe des Utilisateurs Francophones

Announcements
See why Qlik was recognized for the seventh year in a row – and discover how we can help you tackle your data integration challenges. Get the report
cancel
Showing results for 
Search instead for 
Did you mean: 
sabrinag
Contributor III
Contributor III

Couleur dans graph

Bonjour,

Je développe un QV où l'une de mes dimension d'étude est l'année (je dispose d'une profondeur de 3 ans).
Dans le script de chargement de mes données, j'ai attribué une couleur par année :

COUL_ANNEE : LOAD * INLINE [

ANNEE, R_ANNEE, G_ANNEE, B_ANNEE

'2016', 173,203,83

'2017', 181,56,72

'2018',  216,146,54

];

Jusqu'ici pas de soucis : une fois les données chargées, je vais dans les propriétés de mon graphique pour attribué la couleur :

"Expression" > Expression >Couleur d'arrière-plan et je renseigne la formule suivante

rgb(R_ANNEE,G_ANNEE,B_ANNEE)

Lorsque je n'ai aucun filtre sur "ANNEE", les trois couleurs s'affichent correctement

Lorsque je sélectionne au moins une des trois années, les années non sélectionnées passent en noir

Du coup, comment je peux faire pour laisser la couleur définie pour l'année, même si cette dernière n'est pas sélectionnée ?

J'ai essayé

IF(=ANNEE,rgb(R_ANNEE,G_ANNEE,B_ANNEE),rgb(R_ANNEE,G_ANNEE,B_ANNEE))

Mais, mes années non sélectionnées sont toujours noires...

Merci de votre aide !

Bonne fin de journée

1 Solution

Accepted Solutions
flochi75
Creator III
Creator III

Bonjour Sabrina,

ça ne marche pas si tu attribues simplement les couleurs souhaitées dans propriétés>Couleurs

et que tu coches "couleurs persistantes" ?

Capture.JPG

Florent

View solution in original post

2 Replies
flochi75
Creator III
Creator III

Bonjour Sabrina,

ça ne marche pas si tu attribues simplement les couleurs souhaitées dans propriétés>Couleurs

et que tu coches "couleurs persistantes" ?

Capture.JPG

Florent

sabrinag
Contributor III
Contributor III
Author

Bonjour Florent

Et merci de ton aide !

Effectivement, ça fonctionne bien !