Qlik Community

Groupe des Utilisateurs Francophones

Announcements
QLIKWORLD LIVE! MAY 16 - 19TH, EARLY BIRD DISCOUNTS! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
bckaps69
Contributor
Contributor

Problème d'interprétation des données

Bonjour,

J'importe d'un fichier QVD une liste de machine mais Qlikview interprète mal et rajoute un 0 à gauche

Données (code machine)     Interprétation QV

0100                                   0100

0200                                   0200

0300                                   0300

0402                                   0402

402                                     0402 (il rajoute un 0)

0500                                   0500

J'ai essayé une fonction Text() sans succès.

Avez-vous une solution à mon problème ?

Merci d'avance

11 Replies
bckaps69
Contributor
Contributor
Author

Mon souci c'est que ce script me sert à générer tous mes QVD (pas que la table des machines)

kevinchevrier
Partner
Partner

Dans ce cas, comme tu as une particularité.

Je ne sais pas si cela marche mais l'idée serait d'utiliser une clause where et charger en 2 temps.

Dans un premier temps :

$(vTable):

            SQL SELECT $(vClauseSelect)

            FROM $(vTable)

            $(vClauseFrom)

            WHERE  $(vClauseFrom) <> 'Machines';

Dans un second temps ;

Machines:

            SQL SELECT $(vClauseSelect),

               If(lenght(Données)>3, Données, num(Données)) as DONNEES_TRANSFORMEES

            FROM $(vTable)

            $(vClauseFrom)

            WHERE  $(vClauseFrom) = 'Machines';

Si cela ne marche pas alors il faudrait créer une variable $(vClauseFrom) sans la table Machines. Puis charger Machines à part comme expliqué ci-dessus.


Kevin