Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
master_t
Partner - Creator II
Partner - Creator II

Embedding Qlik Sense in a website: problems with fonts and cookies

Hello fellow devs

I've recently updated a ~1 year old installation of Qlik Sense Enterprise to the Feb 2024 Patch 2 release.

While Qlik Sense itself seems to work fine, I also make extensive use of the mashup api to embed Qlik objects inside my company's web pages.

Since the update, however, the mashup pages have been misbehaving: most don't load, or load very slowly, or load with messed up fonts (all the icon fonts are missing).

So, I started debugging by building a very simple mashup page, following the tutorial in the Qlik documentation, and here is the first problem I've found: as soon as I invoke require to obtain the Qlik Sense engine, like this:

require(["js/qlik"], (qlik: any) => {
	console.log("obtained qlik engine", qlik);
	this.qlikEngine = qlik;
});
 
I start getting errors and warnings in the browser console:
master_t_0-1711714702212.png

 

as you can see, not only are fonts failing to load but it also takes almost 10 seconds to obtain the Qlik Sense engine, which explains the slowness and missing icon fonts that I noticed in my mashup pages.

If I look at the network panel, I can see that the problem (the font one at least) is that the browser (Chrome) is not sending the X-Qlik-Session cookie when requesting the fonts, and thus Qlik is responding with a 302 status code to redirect to the authentication page:

master_t_1-1711714904076.png

 

I've checked online, and from what I understand it is normal for browsers to not send cookies when downloading web fonts... so is this a Qlik Sense bug? Why do the mashup APIs include fonts that are behing authentication? This didn't happen in the older version of Qlik (I think it was a November 2022), so it must be a pretty recent change.

How can we avoid this issue? Did I mess something up in my mashup or is this an issue with Qlik itself? Can it be worked around?

Labels (2)
8 Replies
alex_colombo
Employee
Employee

Hey @master_t , please open a support ticket, seems to be a bug.

master_t
Partner - Creator II
Partner - Creator II
Author

Hello Alex, thank you, I have already done it, from what support told me they're investigating the issue. I'll update the thread when they give me some feedback.

jan-ri
Contributor II
Contributor II

We have recently updated from May 2023 to Feb 2024 Patch 2 and we get the same errors.

robertbuntingtwoday
Partner - Contributor
Partner - Contributor

@master_t  Did you manage to solve the problem? We are experiencing a similar problem, on the patch 4 release. 

master_t
Partner - Creator II
Partner - Creator II
Author

@robertbuntingtwoday I've been messaged by Qlik support just the other day, reporting that the issue should be fixed in the May 2024 release. I've yet to test it because I need to upgrade my installation first, I'll report back in the next few days if I can make it work.

robertbuntingtwoday
Partner - Contributor
Partner - Contributor

Thanks for the swift reply @master_t  We'll probably give May 2024 a go very soon then. I'll let you know if it solves our issue. Thanks again! 

jan-ri
Contributor II
Contributor II

We upgraded to May 2024 and the problem was resolved.

robertbuntingtwoday
Partner - Contributor
Partner - Contributor

@jan-ri @master_t  May 2024 resolved our issue as well. Thx guys!