Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
mark_landers
Contributor II
Contributor II

I can't display images on Qlik Sense Cloud

Hi,

I am using a trial version of Qlik sense Cloud and I would like to create a table where I can display images of this table. The images are open URL from an Images hosting site. 

So I have used many extension (Vizlib Cards, Vizlib table, Image/ link detection) but the images don't appear, I have this thumbnail when the image can't be displaying

I have also added in the Content Security Policy, the origin of the hosting site but It still not working.

If you can help me with this issue it would be nice of you.

Thank you.

Issue display image.PNG

 
 
mark_landers_0-1633199820904.png

 

 
2 Solutions

Accepted Solutions
han
Employee
Employee

OK

Looking at the URL you have in the table it will  "resolve" to a HTML page.

I think you should use the URL https://zupimages.net/up/21/39/6gdq.jpg instead

 

View solution in original post

Sebastian_Linser

When setting it up initially did you follow all steps as listed here?

https://community.vizlib.com/support/solutions/articles/35000149351-deploying-vizlib-products-in-qli...

Help users find answers! Don't forget to mark a solution that worked for you! 🙂

View solution in original post

5 Replies
han
Employee
Employee

Hi,

Is there any "CSP violations" reported in the browser's console?

The table seems to have a reference to `zupimages.net` but the CSP has `www.zupimages.net`

mark_landers
Contributor II
Contributor II
Author

Hi @han 

Thank you for you're answer.

So, I have cheked the CSP and there is no error message about CSP violations. 

I also tried both with and without the "www." or https:// but it doesn't work. I still can't display images.

 

 

Sue_Macaluso
Community Manager
Community Manager

@Bastien_Laugiero @Sebastian_Linser @ToniKautto Can you guys weigh in on this thread, please. Thanks so much. 

Sue Macaluso
han
Employee
Employee

OK

Looking at the URL you have in the table it will  "resolve" to a HTML page.

I think you should use the URL https://zupimages.net/up/21/39/6gdq.jpg instead

 

View solution in original post

Sebastian_Linser

When setting it up initially did you follow all steps as listed here?

https://community.vizlib.com/support/solutions/articles/35000149351-deploying-vizlib-products-in-qli...

Help users find answers! Don't forget to mark a solution that worked for you! 🙂

View solution in original post