Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
Don't miss the upcoming Q&A with Qlik session on Qlik Application Automation on November 16th! REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
chrisH
Partner
Partner

Opening Hub in an IFrame in Google Chrome results in infinite refreshing loop

Hello,

I have placed an IFrame on a page which navigates to the qlik hub (for authorisation/authentication to retrieve cookies )

Just like:
...
<iframe src="https://QlikSenseServer"></iframe>
...

this worked well until two weeks ago.

After one of the last Chrome updates , when navigating the Iframe to the hub,  it loads the hub, but in the moment all apps would be shown, an Error message occurs saying "Connetion Lost. Make sure that Qlik Sense is running properly. If your Session has timed out due to ....", then the page in the iframe gets refreshed, tries to load the hub, running into the same error and gets refreshed again,...

In the Console there are errors like :
TypeError: Cannot set property 'navActive' of undefined(comming from hub.js)
Error: Not connected/Possibly unhandled rejection: {} (comming from enigma.js/hub.js)

ErrorHub.png

ErrorsConsole.png

My current chrome version is: 84.0.4147.135

I've tried a Server running Qlik Sense June 2020 Patch 2 -13.82.8  and
one running Qlik Sense September 2019 -13.42.1

When I Open the Hub in Chrome directly, it loads properly.

In Edge/Firefox the Hub in my Iframe loads correctly

Labels (4)
1 Solution

Accepted Solutions
chrisH
Partner
Partner
Author

In the virtual proxySettings/Advanced, activating 'Has secure attribute(https)' checkbox and

setting 'SameSite attribute (https)' combobox to 'none'

latest qlik sense server is required to see this setting(I have it June 2020 patch2)

 

fixed the problem.

View solution in original post

3 Replies
chrisH
Partner
Partner
Author

In the virtual proxySettings/Advanced, activating 'Has secure attribute(https)' checkbox and

setting 'SameSite attribute (https)' combobox to 'none'

latest qlik sense server is required to see this setting(I have it June 2020 patch2)

 

fixed the problem.

View solution in original post

hshahul04
Contributor II
Contributor II

Hi,

As per your post, I have done the changes in QMC virtual server. It is working for my node JS application with help of enigma JS. But Extension is not working.  Could you please guide me to fix this issue

 

turtle_qlikview
Contributor II
Contributor II

This worked for me.