Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
Support Case Portal has moved to Qlik Community! Read the FAQs to start exploring Support resources.
cancel
Showing results for 
Search instead for 
Did you mean: 
amartinez35
Partner
Partner

Publish and republish notification with log4net

Hi QlikGirls and QlikGuys,

I have some difficulties with log4net ^^'

 

I want:

Send notification by email when users are publishing or republishing an app (replace).

But I just can do:

Send notification by email when users are publishing an app.

 

My log4net filter (it's ok):

	  <filter type="log4net.Filter.StringMatchFilter">
			<param name="stringToMatch" value="published" />
	  </filter>

 

My logger (it's ok for publish):

    <logger name="Audit.Repository.Repository.Core.Resource.AppResource">
        <appender-ref ref="test" />
    </logger>

 

I can't find the right logger name for both...

 

In the file SERVER_AuditActivity_Repository.txt I have republishing informations but not the logger name...

 

Where I can find a list of all Qlik Sense logger?

 

Thanks ;),

Aurélien

 

 

 

 

Labels (2)
4 Replies
Anil_Babu_Samineni

Here you can check for log files

QMC - "Configure System" - "Service Cluster" - "Cluster Settings" - "Archived logs root folder" 

But, I did the same to capture from above path folder and Using "SMTP Connector" I have sent user notification.

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Levi_Turner
Employee
Employee

Mind posting your entire LocalLogConfig.xml so I can use it as a base to build from and see what can work here?

amartinez35
Partner
Partner
Author

Hi,

My LocalLogConfig.xml:

<?xml version="1.0"?>
<configuration>
	
	<appender name="test" type="log4net.Appender.SmtpAppender">
	  <filter type="log4net.Filter.StringMatchFilter">
			<param name="stringToMatch" value="published" />
	  </filter>
      <filter type="log4net.Filter.DenyAllFilter" />
      <evaluator type="log4net.Core.LevelEvaluator">
            <param name="threshold" value="INFO"/>
      </evaluator>
        <param name="to" value="***" />
        <param name="from" value="***" />
        <param name="subject" value="Qlik Sense Dev New app published" />
        <param name="smtpHost" value="***" />
        <param name="port" value="25" />
        <param name="bufferSize" value="0" />
        <param name="lossy" value="true" />
	          <layout type="log4net.Layout.PatternLayout">
            <param name="conversionPattern" value="%newline%date %-5level %newline%property{ActiveUserId}%newline%newline%newline%message%newline%newline%newline" />
        </layout>
	</appender>

	<logger name="Audit.Repository.Repository.Core.Resource.AppResource">
        <appender-ref ref="test" />
    </logger>
</configuration>

LocalLogConfig.xml  

derrydavis
Partner
Partner

Was this ever resolved? I'm running into an issue getting the stringmatchfilter working.