Qlik Community

Ask a Question

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

QlikWorld Online 2021, May 10-12: Our Free, Virtual, Global Event REGISTER TODAY
Showing results for 
Search instead for 
Did you mean: 

QIB Configuration Issue With QIB Web Chat Service

Hi Dear Qlik Community

I have a QIB Installation, the environment is the following

Server 1:

  • Product: QlikSense Server Enterprise Nov 2019
  • OS: Windows 2012
  • IP Address
  • CA Certificate URL: sense.fronteraenergy.ca


Server 2:

  • Product: QIB Version Sep 2019 (QIB SFB, QIB WebChat, QIB Applications, QIB Slack Enginee)
  • OS: Windows 2012
  • IP Address
  • CA Certificate URL: nlp.fronteraenergy.ca


Server 3:

  • Product: NLU Docker Container Version Sep 2019
  • OS: UBUNTU Server
  • IP Address
  • CA Certificate URL: nlu.fronteraenergy.ca

All server can communicate via local network, without problems

The issue are when I test the web chat extension, I wrote something, like like “Hi” or “Apps”, but the Web Chat Extension not send any answer


I configured well web chat, but not works, the Qlik Insight Bot Webchat Service Log show me the following errors


2020-01-20 13:11:30.095|INFO|anonymous_user|Reading port..

2020-01-20 13:11:30.111|INFO|anonymous_user|Port read successfully.

2020-01-20 13:11:30.111|INFO|anonymous_user|creating certificate

2020-01-20 13:11:30.142|INFO|anonymous_user|Certificate files already exist.

2020-01-20 13:11:30.142|INFO|anonymous_user|Fetching QPS configuration.

2020-01-20 13:11:30.176|INFO|anonymous_user|Took QPS configuration successfully.

2020-01-20 13:11:30.176|INFO|anonymous_user|Fetching QRS configuration.

2020-01-20 13:11:30.176|INFO|anonymous_user|Took QRS url successfully.

2020-01-20 13:11:30.176|INFO|anonymous_user|Initializing QPS & QRS objects.

2020-01-20 13:11:30.176|INFO|anonymous_user|Fetching data from Qlik Sense.

2020-01-20 13:11:32.798|ERROR|anonymous_user|HTTPSConnectionPool(host='sense.fronteraenergy.ca', port=4242): Max retries exceeded with url: /qrs/about?Xrfkey=E0duH15lkEIKkS8E (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x0000004A424DD0B8>: Failed to establish a new connection: [WinError 10061] No se puede establecer una conexión ya que el equipo de destino denegó expresamente dicha conexión',))

2020-01-20 13:11:32.798|ERROR|anonymous_user|Unable to fetch whitelisted domains and session data from Qlik Sense Server.

2020-01-20 13:14:44.984|INFO|anonymous_user|Validating session.

2020-01-20 13:14:44.986|INFO|anonymous_user|Fetching QPS configuration.

2020-01-20 13:14:44.988|INFO|anonymous_user|Took QPS configuration successfully.

2020-01-20 13:14:44.988|INFO|anonymous_user|Fetching QRS configuration.

2020-01-20 13:14:44.989|INFO|anonymous_user|Took QRS url successfully.

2020-01-20 13:14:44.989|INFO|anonymous_user|Initializing QPS & QRS objects.

2020-01-20 13:14:44.989|INFO|anonymous_user|Fetching data from Qlik Sense.

2020-01-20 13:14:45.174|INFO|anonymous_user|Successfully fetched data from Qlik Sense.

2020-01-20 13:14:45.175|INFO|anonymous_user|Initialization completed.

2020-01-20 13:14:45.176|INFO|anonymous_user|Access denied. Unauthorized access for 'https://sense.fronteraenergy.ca (' Host (IP) - Session is Empty/Not Found.


And the Browser (Chrome) console show me this error message



I made the following steps to review the issue:


  • Qlik Sense are using a valid CA certificate


  • QIB Web Chat Service has a valid CA Certificate


  • The QIB Web Chat Service are running with a Domain services account with all privileges on QIB server, is root on QMC (QlikSense server) and has professional token


  • The QIB configuration are made to central node and central default virtual proxy, also was configured with secondary virtual proxy (WebChat) with a different configuration, but not worked


  • The central virtual proxy (Default) was configured with correct white list and with and without headers but not worked, the response headers applied was


Access-Control-Allow-Origin: https://nlp.fronteraenergy.ca:4431

Access-Control-Allow-Credentials: true


              but not worked




  • The secondary  virtual proxy (WebChat) was configured with correct white list, prexif, session cookie domain and with the following response headers




Access-Control-Allow-Origin: https://nlp.fronteraenergy.ca:4431

Access-Control-Allow-Credentials: true)





I have no idea where the error can be and I don't know what else to do, maybe you can help me with something, if possible we can do a remote session to check

1 Reply

Hi Fiends