Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

cancel
Showing results for 
Search instead for 
Did you mean: 
jli87
Partner
Partner

Qlik-Cli for Saas issue running on Powershell

Hi Everyone,

I am very new to this Qlik-Cli. I've followed the directions from https://community.qlik.com/t5/Knowledge/How-to-install-and-start-using-Qlik-CLI-for-SaaS-editions-of... to get it installed but am now having issues running it through Powershell. 

I did the installation method 2 with chocolatey and was successful. When I open Powershell and type in "qlik context init" it will give me the following error.

"Error : could not create .qlik folder in home directory: mkdir H:\: The system cannot find the path specified."

I am not sure how to resolve this issue. Please let me know what I can do to fix it.

Thank you in advance.

1 Solution

Accepted Solutions
BojanTH
Employee
Employee

Hi @jli87 

We did investigation of your issue.
This error happened because the program can't create ".qlik" directory in your home directory.
We are planning to release a new version of qlik-cli in the next few days that will probably handle this issue.
Below you can find more details in case you need a quick fix.

To determine user's home directory we are using two environment variables: "HOMEDRIVE" + "HOMEPATH".
Since the path is equal to "H:\" on your machine, I assume that "HOMEDRIVE" variable is equal to "H:" and "HOMEPATH" variable is equal to "\".
To test this assumption you could run "$env:HOMEDRIVE" and "$env:HOMEPATH" in PowerShell to check the content of these variables.

If this assumption is correct and "HOMEPATH" is set to "\", you could try to change this variable to point to your home directory. The PowerShell command that will change this variable just for the current session will look something like this (please adjust the value if needed):

 

$env:HOMEPATH = "\Users\User"

 

If "qlik context init" works after this step you could consider to change this variable permanently in your system settings.

Hope this was helpful.
Bojan

 

View solution in original post

1 Reply
BojanTH
Employee
Employee

Hi @jli87 

We did investigation of your issue.
This error happened because the program can't create ".qlik" directory in your home directory.
We are planning to release a new version of qlik-cli in the next few days that will probably handle this issue.
Below you can find more details in case you need a quick fix.

To determine user's home directory we are using two environment variables: "HOMEDRIVE" + "HOMEPATH".
Since the path is equal to "H:\" on your machine, I assume that "HOMEDRIVE" variable is equal to "H:" and "HOMEPATH" variable is equal to "\".
To test this assumption you could run "$env:HOMEDRIVE" and "$env:HOMEPATH" in PowerShell to check the content of these variables.

If this assumption is correct and "HOMEPATH" is set to "\", you could try to change this variable to point to your home directory. The PowerShell command that will change this variable just for the current session will look something like this (please adjust the value if needed):

 

$env:HOMEPATH = "\Users\User"

 

If "qlik context init" works after this step you could consider to change this variable permanently in your system settings.

Hope this was helpful.
Bojan