Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
arsalanam
Creator
Creator

Websocket connection failed during handshake - error code: 403

I get this error when try to connect to any Qlik Sense app. I've looked through other threads with same error but haven't found anything helpful yet.

.js file contains:

var config = {

host: "localhost",

prefix: "/",

port: window.location.port,

isSecure: window.location.protocol === "https:"

};

Thank you for any suggestions.

4 Replies
kaanerisen
Creator III
Creator III

Hi Arsalan,

Add your server ip,'localhost' and hostname or others in whitelist (QMC virtualproxy-central)


Untitled.png

Hope it helps...

arsalanam
Creator
Creator
Author

Hi Kaan,

I tried that option but still see the error.

HostWhiteList.png

kaanerisen
Creator III
Creator III

Hi,

You just need to add 'localhost'. without 'http' or 'https'.

Pls just add 'localhost' and try if it is working.

arsalanam
Creator
Creator
Author

I did try putting just "localhost" but no effect. Also, this error comes up when I insert this code (in Red) in my .js file:

var config = {

host: "localhost",

prefix: "/",

port: window.location.port,

isSecure: window.location.protocol === "https:"

};

require.config( {

baseUrl: ( config.isSecure ? "https://" : "http://" ) + config.host + (config.port ? ":" + config.port : "") + config.prefix + "resources"

} );

require(['js/qlik'], function(qlik) {

    //if there's any error we catch it here

    qlik.setOnError( function ( error ) {

        console.log(error);

    });

var app = qlik.openApp('c3208cab-95d2-42c6-bb37-587196af3aba', config);

app.getObject(document.getElementById('QSChart'), 'rtAJ');

});

HostWhiteList2.PNG