Qlik Community

Ask a Question

Knowledge Base

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Announcements
Live chat with experts, bring your API Integration questions. June 15th, 10 AM ET. REGISTER TODAY

Data Connections Pane in Qlik Sense Hub not loading

Tomasz_Gidzgier
Support
Support

Data Connections Pane in Qlik Sense Hub not loading

The Qlik Sense Data Manager and Data Connection does not load when opening the Data Load Editor or Add Data Wizard. The Qlik Sense hub does not load a data connection or takes too long to load it.

This issue happens predominantly in Deployments within Environments with restricted Internet access. The workaround is to remove the Custom Data Connectors from the installation folder.

Other symptoms might include:

  • ErrorCode.11041 occurs when opening up an App
  • ErrorCode.11043 occurs when creating a Database connection in the data load editor.

 

After fresh installation or upgrade the User navigates to the Data Load Editor or Add and sees the following:

 

User-added image
 

And the Data Connection List is empty and the loading wheel is spinning indefinitely:

 

User-added image
 

In Add Data Wizard following can be observed:

 

User-added image
 



In most cases depending on the environment the Data Connections will eventually load after 10 to 30 minutes of waiting. However this not an ideal solution as the connections have to be loaded every time when the Data Load Editor or Add Data Wizard are accessed.

 

Cause:

 

The main cause of this issue is related to the Data Load Editor and Add Data Wizard trying to Connect with the Connectors. When the connection can not be established it will time out and retry for about 20-30 times before it will fail completely - this when the connections are finally load or not loaded. It was identified that the Connectors having most trouble with establishing a connection to the Data Load Editor and Add Data Wizard are the Data Market and ODBC Connector Package. However it is not know why yet why the Connection can not be established in Restricted Environments.

 

Resolution:


Qlik connectors are cryptographically signed for authenticity verification. The .NET framework verification procedure used for this signing includes checking OCSP and Certificate Revocation List information, which are fetched from a online resource if the system doesn't have a cached local copy. These requests will timeout due to lack of access to online resource in environments with restricted, slow or no internet connection. Due to authenticity check failure the connector will not run, and the app reload fails.

The possible workarounds are available:

 

Workaround 1

 

Follow the instructions ad documented in An error occurred / Failed to load connection error message in Qlik Sense - Server Has No Internet 

 

Workaround 2

 

Enable internet access. 

Alternatively, using a third-party tool such as Fiddler or inbuilt browser debug tools, identify the addresses used and add them to allow lists on firewalls/proxies otherwise blocking internet traffic. 

 

Workaround 3

 

Temporarily move the following files outside of Program Files:

  • OvOdbcConnectorPacakage and OvDataMarketConnector 

Files can be found in: C:\Program Files\Common Files\Qlik\Custom Data

In a multi node environment please do it for all the nodes. You can as well try removing only the OvOdbcConnectorPacakage as the OvDataMarketConnector does not always fail. 

Note that when moving the files, you will not be able to use the Data Market Connector or the ODBC Pacakage. 

Labels (2)
Comments
vegard_bakke
Partner
Partner

Any updates on this?

I have a April 2020 version of Qlik Sense, still with the same problem.

 

The websosocket returns the connection information.
They just don't show up in the browser.


vegard_bakke_0-1598280086442.png

 

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @vegard_bakke !

Do the workaround listed in this article help you resolve the issue? If not, it may be worth posting about this on our Deployment forum or investigating with support. 

vegard_bakke
Partner
Partner

Since the information is received by the browser, I don't see why I should have to remove anything from the server. It looks like a client side problem. So no I have not tried those workarounds.


However, I might have found the cause. I used the URL with the virtual proxy that was not for 'Developer' nodes.  But again, I thing it is a weird client side problem.    The only way Qlik is telling me that I cannot edit the load script using this node, is by not displaying the Data connections that already have been received by the browser.

Filippo_Nicolussi_P

Hello @vegard_bakke  

 

I see you mention April 2020 , be sure to be at least on SR3 or above. 

Best regards 

 Filippo N.

Qlikstu
Partner
Partner

If the server has limited internet access (by design) - does anybody know the URL's to add to the whitelist? 

Thanks

Stu

Jay_Brown
Support
Support

Hello @Qlikstu , I'm not sure this can be fixed by using an allow list.  There is some additional information around a .Net bug here that may help:
https://community.qlik.com/t5/Support-Knowledge-Base/An-error-occurred-Failed-to-load-connection-err...

There is a global setting, as well as a per-connector configuration.  I would test that out and see if it resolves your issue.

Version history
Revision #:
5 of 5
Last update:
‎2021-01-28 05:18 AM
Updated by:
 
Contributors