Qlik Community

Ask a Question

Knowledge Base

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Announcements
Live chat with experts, bring your API Integration questions. June 15th, 10 AM ET. REGISTER TODAY

QlikView: Image not Displayed as an Image URL Text Shown Instead of Image

Sonja_Bauernfeind
Digital Support
Digital Support

QlikView: Image not Displayed as an Image URL Text Shown Instead of Image

Images are not showing up properly in the application. URL Text is shown instead of the image in web-view on the desktop and on the ajax client from the Access Point. One possible way this can manifest is when there is a link to a google map item. 

 

Environment:

QlikView 

 

Resolution

 

QlikView Desktop and Server include a parameter to configure this behaviour:

 AllowGeneralAccessToImagesThroughURL can be configured in the Settings.ini file. By default this value is set to 0, it appears in the ini file as:

AllowGeneralAccessToImagesThroughURL=0

This setting will prevent images from appearing in any objects possible through a URL. If the URL is added to a text box without background the text box will appear to disappear in WebView or when opening the app in Server.

The reason for this parameter is that HTTP access is considered a risk because it allows the user to fetch pictures as the QVS process. As the QVS process might be running with elevated rights and runs behind a firewall, it may have access to servers that the user does not and therefore the user can fetch pictures that should be hidden from them.

Even if AllowGeneralAccessToImagesThroughURL parameter is set to 0 these images can be seen in Desktop and when accessing the app through the IE Plugin, because these images are fetched by the local client.


AllowGeneralAccessToImagesThroughURL has to be changed from 0 to 1 or 2 in the Setting.ini files for Desktop and Server.

QlikView Server:

  1. On the QlikView server, navigate to C:\ProgramData\QlikTech\QlikViewServer - Settings.ini
  2. Stop the QlikView server Service.
  3. Open the Settings.ini file.
  4. Find the line with parameter AllowGeneralAccessToImagesThroughURL=0 and change the 0 to 1. Kindly note that depending your environment this may have to change to 2.
  5. Restart the QlikView server Service.


Desktop:

  1. Close the Desktop Client.
  2. Navigate to C:\Users\<Username>\AppData\Roaming\QlikTech\QlikView - Settings.ini
  3. Find the Settings.ini file
  4. Find the line with parameter AllowGeneralAccessToImagesThroughURL=0 and change the 0 to 1 or 2.


Please note that there are 3 possible values for AllowGeneralAccessToImagesThroughURL

  •  0 = No access at all
  •  1 = Access through "http://" // 
  •  2 = Full access (same behavior as in 11.20)


A good approach if none of the above steps are working, use Bundle Load especially if you are using AJAX. More info here

For MiniCharts it may be necessary to update the parameter detailed below in the file named Setting.ini for both QV Desktop and QV Server:

WebFileUseWinAPI=1
 

Labels (2)
Attachments
Version history
Revision #:
2 of 2
Last update:
2 weeks ago
Updated by:
 
Contributors