Qlik Community

Knowledge

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Announcements
WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE

"Failed to create search index" script error during reload

cancel
Showing results for 
Search instead for 
Did you mean: 
Andre_Sostizzo
Digital Support
Digital Support

"Failed to create search index" script error during reload

This article explains how to avoid the "Failed to create search index" script error during reload.

A data load may fail with: 

An error occurred

Internal engine error.

 

The script log will show:

2017-02-28 17:17:55      Creating search index
2017-02-28 17:17:55      Failed to create search index
2017-02-28 17:17:55      Execution finished.

The cause is currently unknown. Suspected to be an App corruption caused by external influences.

 

Resolution


Solution 1

  1. Remove all search index files from the shared location configured in your Service Cluster shared location for the app which fails to reload. To locate the AppID, see How to find App ID.
    Example: \\ShareDrive\Apps\Search\AppID folder
  2. Reload the app again.

 

Solution 2

  1. Open the Qlik Sense Management Console
  2. Navigate to Engine
  3. Select an engine
  4. Open the tab Advanced
  5. Uncheck "Create search index during reload"
  6. Press Apply

 


Solution 3

Insert "Set CreateSearchIndexOnReload=0" in the load script.

Even if this is disabled during the reload, the search index will be created later after the first search request of users.

 

Solution 4

Increase the timeout value.

Rather than disabling or removing the Search Index, you can attempt to increase the timeout before the reload will error out.

To do so, you will need to modify the Qlik Sense engine settings.ini and add a customized timeout value. 

  1. Follow the instructions documented in How to modify Qlik Sense Engine's Settings.ini 
  2. Add SearchTimeoutLimit=40000
    Where 40000 is the default value and in milliseconds. Increase the value, for example by adding a 0 to increase it to 400000 or any value you wish to begin troubleshooting with. 

 

Labels (2)
Comments
BeeGees
Contributor III
Contributor III

Solution 1 didn't worked at all. Solutions 2-3 are not solutions, just workarounds. There is a reason why I'm recreating search index on each reload. Any real solution there?

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @BeeGees - I've looked through our resolved cases and option 1 through 3 has seemed to be our available solutions. If you're looking to have this investigated in detail, I would recommend logging a support ticket. 

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @BeeGees We've added a third confirmed solution to this article (increasing the timeout). 

mk_kmx
Partner - Contributor III
Partner - Contributor III

@Sonja_Bauernfeind  You've got a small mistake in your post here, Solution #4.

According to Engine Service log, default value for SearchTimeoutLimit is 40.000. Therefore, update proposed in KB does not change it. The tricky consequence is, that the setting is not even visible in log files, which can lead to a lot of detective work ("What did I do wrong?").

Sonja_Bauernfeind
Digital Support
Digital Support

Nice catch, @mk_kmx - Thank you!  I've edited the article. 

Ken_T
Creator III
Creator III

In a multi-node environment, where will the folder mentioned in the first workaround be ----- \Apps\Search\AppID folder

will this be in the location defined for the service cluster, for the App folder?
QMC > Service Cluster > App folder

thanks 

 

Ken_T
Creator III
Creator III

and is this related to the error

"the search index is incomplete. smart search might be slower than expected"

which sometimes prevent an app from loading properly (hub and qmc task), and which I cannot find any reference for in any community post

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @Ken_T 

I have reviewed internal cases that we had and have seen one instance where this issue occurred and was related to disk space/ability to write additional files to the service cluster directory of /apps/Search/. So I cannot rule out that this is related and would recommend testing the solutions mentioned in this article.

If this does not resolve the issue for you, then I'd recommend logging a case so that we can investigate.

As for your first question: Correct. This is the folder you have defined in the service cluster (yourshare\Apps\Search\AppID)

I will also update the article with additional information as you requested.

All the best,
Sonja 

Ken_T
Creator III
Creator III
You are the best
This helps a lot!
Version history
Last update:
‎2022-06-14 05:35 AM
Updated by:
Contributors